サポート » プラグイン » phpエラーで有効化できない

  • 解決済 ematoba

    (@ematoba)


    こんにちは。
    SiteGuard WP Pluginを導入後のサイトのメンテナンスのため、いったん当該プラグインを削除し、またインストールしたところphpのエラーが発生し有効化できなくなりました。
    エラーメッセージは以下の通りです

    Parse error: syntax error, unexpected '[' in /usr/home/mw2pnbg89x/www/htdocs/wordpress/wp-content/plugins/siteguard/classes/siteguard-base.php on line 95

    WordPress 5.1.6
    PHPのバージョンが古いため、Wordpressのバージョンを上げることができない状況です。

    スパムアクセスが多いため、SiteGuard WP Pluginを早急に使いたいと思っています。
    回答よろしくお願いいたします。

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • こんにちは。お困りでしょうが、いったんSiteGuard WP Pluginプラグインを削除し、またインストールしたバージョンが最新版ではないでしょうか。

    スレッド開始 ematoba

    (@ematoba)

    ありがとうございます

    新しくインストールしたプラグインのバージョンは 1.5.1
    使用中の WordPress バージョンと互換性ありと表示されていました

    ematoba さん

    こんにちは。

    ご連絡ありがとうございます。

    1.5.1のコードの中に、php5.3以前だと構文エラーになる部分があることがわかりました。
    修正版の1.5.2を本日中にリリースします。

    ご迷惑をおかけしました。
    今しばらく、お待ちください。

    その通り「互換性」ですから。話を先へ進めると、「WordPress Codex 日本語版」にある通り、「WordPress の最新バージョンは 5.3 です。」サーバー側の要件として、「PHP 7.3 以上」と決まりがあるので、「PHP 7.3」に従ってコードが書きなおされているからです。「syntax error」ですから、実行環境に見合った記法に書きなおします。

    スレッド開始 ematoba

    (@ematoba)

    ありがとうございます!
    修正版お待ちしています。

    ご使用の WordPress およびプラグインの動作環境を確認することをおすすめします。

    @fugaku

    「WordPress の最新バージョンは 5.3 です。」サーバー側の要件として、「PHP 7.3 以上」と決まりがあるので、

    WordPress 5.3 の推奨の PHP バージョンは 7.3 以上ですが、5.6.22 以上で動作します。また、プラグインはプラグインで PHP の動作環境は違います。

    ematoba さん

    1.5.2 をリリースしました。
    ご確認いただけましたら幸いです。

    よろしくお願いします。

    スレッド開始 ematoba

    (@ematoba)

    @jp-secure さん

    プラグインを更新したところ正常に動作いたしました。
    今回は素早い対応本当にありがとうございました!

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • トピック「phpエラーで有効化できない」には新たに返信することはできません。