サポート » バグ報告と提案 » phpバージョンをあげたがWP管理画面ではあがっていないことになる

  • 解決済 komelon

    (@komelon)


    ダッシュボードに「PHPの更新が必要です」とでていましたので
    サーバー側のPHPバージョンを5.2.8から7.1.15にアップデートしました。

    しかしながら、ダッシュボードから「PHPの更新が必要です」の表示はきえず、
    何か追加でプラグインをいれたくても「このプラグインは現在使用中の PHP のバージョンでは動作しません。」
    と表示されインストール不可。
    当然WPバージョンも5.2.1にもあげられません。

    CPIサーバーサポートと連絡をして、phpバージョンアップのやり方を教わり、
    正しく実行されたかと思っております。php infoで確認しても確実にあがっているのですが、
    WP的にはあがっていない認識になっているような感じです。

    どのようにすればWPダッシュボードから「PHPの更新が必要です」が消えて、
    正しくphpバージョンアップを認識してくれますでしょうか。。。

    WPバージョン:5.1.1
    PHPバージョン:7.1.15
    サーバ:CPI(ACEプラン)

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • CG

    (@du-bist-der-lenz)

    サーバーでは7.1.15のPHPが走っているけど、WordPressで5.2.8をハンドルしてるってことは考えられます。

    .htaccessの記述の中に古いバージョンの記述が残ってるんじゃないですか?
    .htaccessをサーバーのサポートに見せて問い合わせてみましょう。

    > CG様
    そのハンドルしてるのを解除?することは出来るのでしょうか。

    > npssl様
    htaccessの中身には古いバージョンの記述はありませんので、
    サーバー側にも改めて問合せしてみたいと思います。

    CPIサポートから返答あり、phpバージョンは問題なく7.1.15にあがっていると。
    しかしながら、以下回答あり、振り出しにもどりました。
    ———-
    Wordpressの動作については、弊社ではサポート対象外となってしまい
    なぜ管理画面でバージョンアップをしてないと判断をされているか、確認が出来ません。
    Wordpressの管理画面などの設定などを、ご確認をいただけますでしょうか。
    ———–

    他に試してみることはございますでしょうか?

    自己解決しました!

    wp-adminフォルダ内になぜか.htaccessファイルがおいてありました。

    削除したところアラートも消え、無事にアップデートできました。

    お騒がせしました。

    CG

    (@du-bist-der-lenz)

    wp-adminディレクトリにあったということで、管理ページを保護するためにセキュリティしていませんでしたか。ほかのディレクトリにもあるかもしれません。この機会に、怪しいファイルなど整理しませんか。

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • このトピックに返信するにはログインが必要です。