サポート » 使い方全般 » PHPバージョン変更後 データベースを選択できません

  • 解決済 moritokawa

    (@moritokawa)


    PHPのバージョンを5.3(モジュールモード)から7.2(CGIモード)に変更した際、エラーが出ました。
    5.3に戻しても同じエラー画面が出てサイトが表示されません。

    • WordPress のバージョン  5.12
    •  

    • 使用しているプラグインとテーマの情報
      (名称 Resortica Lite / 入手先 wordpress公式 / https://wordpress.org/themes/resortica-lite/  バージョン 1.47)
    • PHP、MySQL のバージョン PHP 5.3 / MySQL 5.0
    • サーバー環境(ホスティングサービス名 ASJ / OS win8)
    • ブラウザとそのバージョン chrome 77.0.3865.120

    Warning: mysqli_real_connect() expects parameter 8 to be long, string given in /home/xxxx/public_html/xxxx/wp-includes/wp-db.php on line 1612

    Warning: mysqli_get_server_info() [function.mysqli-get-server-info]: invalid object or resource mysqli in /home/xxxx/public_html/xxxx/wp-includes/wp-db.php on line 3549

    Warning: mysqli_get_server_info() [function.mysqli-get-server-info]: invalid object or resource mysqli in /home/xxxx/public_html/xxxx/wp-includes/wp-db.php on line 3549

    Warning: mysqli_get_server_info() [function.mysqli-get-server-info]: invalid object or resource mysqli in /home/xxxx/public_html/xxxx/wp-includes/wp-db.php on line 3549

    Warning: mysqli_query() [function.mysqli-query]: invalid object or resource mysqli in /home/xxxx/public_html/xxxx/wp-includes/wp-db.php on line 844

    Warning: mysqli_select_db() [function.mysqli-select-db]: invalid object or resource mysqli in /home/xxxx/public_html/xxxx/wp-includes/wp-db.php on line 1093

    Warning: mysqli_error() [function.mysqli-error]: invalid object or resource mysqli in /home/xxxx/public_html/xxxx/wp-includes/wp-db.php on line 3362

    データベースを選択できません
    データベースサーバーに接続できました(つまり、ユーザー名とパスワードは問題ありません)が、(データベース名)データベースを選択できませんでした。

    本当に存在しますか?
    ユーザー(データベース名)は(ユーザー名)データベースを使用する権限を持っていますか?
    一部のシステムでは、データベースの名前の前にユーザー名が付いているため、次のようになりますusername_(ユーザー名)。それが問題でしょうか?
    データベースの設定方法がわからない場合は、ホストに連絡してください。他のすべてが失敗した場合は、WordPressサポートフォーラムでヘルプを見つけることができます。

    wp-config.phpなど何もファイルは変更していません。

    PHPバージョン変更前に「php compatibility checker」でチェックしましたが問題ありませんでした。

    ftpからプラグインファイルを削除してみましたが変わりません。

    サーバー会社にも尋ねましたが、サーバー上は問題なく、wordpressのファイルの問題とのことでサポート外で解決策が分からず困っています。

    お分かりになる方、解決策をご教授ください。
    よろしくお願いします。

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • CG

    (@du-bist-der-lenz)

    テーマを、TwentyNineteenで再度確認ください。比較検討するのに面倒があるので。

    トピック投稿者 moritokawa

    (@moritokawa)

    ありがとうございます。
    ダッシュボードにも入れないのでphpMyAdminから
    wp_optionsのテーブル templateとstylesheetの値を「twentynineteen」に変更しました。

    ですが、同じエラー画面が表示されます。

    トピック投稿者 moritokawa

    (@moritokawa)

    見落としていました。
    wp_optionsのテーブル current_theme の値も「twentynineteen」に変更しました。
    エラー表示は変わりません。

    こんにちは

    wp-config.php に defined( 'MYSQL_CLIENT_FLAGS', ~というような行はありますか?
    そこにはどのように書かれていますか?

    トピック投稿者 moritokawa

    (@moritokawa)

    munyaguさん
    ありがとうございます。

    >wp-config.php に defined( ‘MYSQL_CLIENT_FLAGS’, ~というような行はありますか?
    >そこにはどのように書かれていますか?

    ‘MYSQL_CLIENT_SSL’
    とあります。

    その前後のシングルクオートを削除して内容を

    defined( 'MYSQL_CLIENT_FLAGS', MYSQLI_CLIENT_SSL )

    として下さい。

    • この返信は2年、 11ヶ月前にmunyaguが編集しました。

    PHP5.3 ではシングルクォート取るだけでもいけるかもしれません。

    トピック投稿者 moritokawa

    (@moritokawa)

    munyagu 様

    ご指摘の箇所、シングルクォートを消したところ、
    正常に表示されるようになりました!

    お礼が遅くなりましたが、
    ご教授ありがとうございましたm(_ _)m

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • トピック「PHPバージョン変更後 データベースを選択できません」には新たに返信することはできません。