サポート » インストール » PHP5.3.3 MySQL5.0 環境へのインストール

  • 解決済 sakihara

    (@sakihara)


    PHP5.3.3 MySQL5.0 環境へWordPressバージョン5.1.1のインストールは可能でしょうか?
    要件ページには、

    Note: If you are in a legacy environment where you only have older PHP or MySQL versions, WordPress also works with PHP 5.2.4+ and MySQL 5.0+, but these versions have reached official End Of Life and as such may expose your site to security vulnerabilities.

    とあるので、動作するのかなとおもうのですが、
    これって、WordPressバージョン5.1.1のことでしょうか?

    Requirements

    • このトピックは sakiharaが3 週間、 6 日前に変更しました。
3件の返信を表示中 - 1 - 3件目 (全3件中)
  • こんにちは

    WordPress 5.1.1 に同封されている readme.html に記載されています。

    記載されている動作環境は、

    PHP バージョン 5.2.4 以上
    MySQL バージョン 5.0 以上

    とあります。

    ただし、これはあくまでも WordPress 本体が動作するための最低条件ですので、テーマおよびプラグインによっては動作しない場合があります。ご注意ください。

    こんにちは、

    ご質問とは、直接関係ありませんが 

    今月末か来月くらいに、WordPress5.2が出る予定ですが

    5.2 になると、

    サーバーの PHP バージョンは 5.3.29 ですが WordPress 5.2-beta3-45260 は 5.6.20 以上のみでご利用になれます。

    といったメッセージが表示されて、サイトは表示できなくなるかもしれません。

    5.1.1を使い続けるにしても、テーマやプラグインが、PHPのバージョンの引き上げに伴って、

    5.6 以下の場合には、インストールできない仕組みが組み込まれていくので

    You need to update your PHP version to run this theme.
    Actual version is: 5.3.3, required version is: 5.6.

    というメッセージがでて、インストールできないテーマやプラグインが多発するかもしれません。

    https://make.wordpress.org/themes/2019/04/01/core-php-compatibility-changes-in-wordpress-5-2/

    • この返信は3 週間、 6 日前に  nobita さんが編集しました。
    • この返信は3 週間、 6 日前に  nobita さんが編集しました。

    ありがとうございます!
    一旦は、5.1.1インストール&動作問題なさそうでした。
    今後WP、PHP共にアップグレードする予定もないので、大丈夫かなという感じはします。

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • このトピックに返信するにはログインが必要です。