サポート » インストール » PHP8.1の対応バージョンについて

  • PHP8.1はWordPressバージョンいくつからサポートしておりますでしょうか?

    動作要件を確認すると「PHP バージョン7.4以上」となっておりますが、具体的にどのWordPress毎にどのPHPバージョンに対応しているのかを教えていただけますでしょうか?
    以下のような表になっていると大変ありがたいです…

    例)
    WordPress 5.5 / PHP 5.6.2–7.4
    WordPress 5.6 / PHP 5.6.2–8.0
    WordPress 5.7 / PHP 5.6.2–8.0
    WordPress 5.8 / PHP 5.6.2–8.0
    WordPress 5.9 / PHP 7.4-8.1

    上記の表は自分の推測で書きましたので正しい情報をご存知の方が居たらお願いします。

1件の返信を表示中 - 1 - 1件目 (全1件中)
  • こんにちは

    こちらの公式の記事をご確認ください。
    WordPress 5.9 and PHP 8.0-8.1

    Deprecation notices remain in WordPress 5.9 and work will continue in the 6.0 cycle.

    ということらしいので、まだ完全に対応できているわけではないようです。
    Deprecation のメッセージが表示される問題が残っている、ということなので当面はデバッグモードをオフにしていれば使えるのかな、と思います。

    過去のバージョンごとの対応表がどこにあるのか、私は分かりません。

1件の返信を表示中 - 1 - 1件目 (全1件中)
  • このトピックに返信するにはログインが必要です。