サポート » プラグイン » Post Thumbnail Editorが動作しなくなりました

  • 解決済 bonbonbon

    (@bonbonbon)


    初めまして。

    昨日(19/09/05)Wordpressが4.0.27に自動更新されて以降、Post Thumbnail Editorが動作しなくなったようで、困っております。
    アイキャッチ画像を選択し、Post Thumbnail Editorのリンクをクリックすると、Editorではなく以下から始まるソースコードが表示されてしまいます。

    <!DOCTYPE html>
    <html><head><title>Post Thumbnail Editor</title>
    <script type='text/javascript'>
    /* <![CDATA[ */
    var execphpCommonL10n = {"messageContainer":"execphp-message"};
    try{convertEntities(execphpCommonL10n);}catch(e){};;
    /* ]]> */
    </script>
    <script type='text/javascript'>

    プラグインの停止→有効化は試してみましたが、変わりませんでした。
    プラグインの削除→再インストールには画像サイズなどの設定に影響が出るのではないかと思い、躊躇しています。

    Post Thumbnail Editorのリンクをマウスオーバーした時に出るリンク先が
    admin-ajax.php
    だったので調べてみたところ、9/5に更新されていたため、今回の自動更新と関係があるのかと思った次第です。

    ちなみにWordpressのバージョンが古いことは承知していますが、諸事情あって手をつけられていません。
    今後の運用については検討しています。

    どうか正常に動かす方法を教えていただけないでしょうか。
    よろしくお願いします。

11件の返信を表示中 - 16 - 26件目 (全26件中)
  • 失礼しました。バージョン 4.0.27 は存在しないものと思っていましたが、存在するのですね。

    Release Archive

    @munyagu さんが書かれているとおりですね。
    https://ja.wordpress.org/support/topic/post-thumbnail-editor%e3%81%8c%e5%8b%95%e4%bd%9c%e3%81%97%e3%81%aa%e3%81%8f%e3%81%aa%e3%82%8a%e3%81%be%e3%81%97%e3%81%9f/#post-11658279

    Post Thumbnail Editor プラグインを対応しているバージョン(2.4.2)までダウンする(おすすめはしません)か、WordPress のバージョンを対応する 4.1 以上にアップデートすることを検討されたらどうでしょうか。

    • この返信は6 日、 23 時間前に  ishitaka さんが編集しました。

    あー、日本語は無いっていうだけなんでしょうかね。

    Release Archive

    ありがとうございます。
    いずれにしろWordPressのバージョンが古すぎますよね…

    CGさんの
    WordPress4.0.27に自動アップデートしたと通知の着たサイトで、「Post Thumbnail Editor」の動作の確認する用意はあります。
    というのはもしかして、検証していただけるということなのでしょうか!?
    そこまで甘えてしまっていいものなんですか???

    CG

    (@du-bist-der-lenz)

    パソコン作業ができるのが15時までなので、返信があって間に合いました。
    お使いの WordPress のバージョンと互換性がありません。

    とアラートが確認されましたが、インストールしました。

    CG

    (@du-bist-der-lenz)


    結果として、動作しました。

    と以上から、導かれる事がありでしょう。

    CGさん、本当にありがとうございました。
    参考にさせていただきます。

    私の 4.0.27 の環境では動きません。
    bonbonbon さんと同じように HTML ソースが表示されます。

    原因は、admin-ajax.php が返す Content-Type が、4.0.27 で text/plain になったからですが・・・

    5.2.3 では text/html のままで、理由はよくわかりません。
    4.1.27 では text/html なので、この現象に関しては 4.1.27 にすれば直ると思います。

    なんと…
    ありがとうございます!

    この現象に関しては 4.1.27 にすれば直ると思います。

    これ頑張ってみます!

    実はadmin-ajax.phpは、自動アップデートされた日に更新されているwp-admin配下の唯二のファイル(もうひとつはabout.php)で、これが肝の可能性は高いと思っていました。

    admin-ajax.php内のContent-Typeが確かにtext/plainとなっていたので、
    思い切ってtext/htmlに書き換えてみたところ、Post Thumbnail Editorが正常に動作しました!

    munyaguさん、ありがとうございました。

    他の方々も、こんな些末な質問にまでご丁寧にお付き合いいただきまして、
    本当にありがとうございました!

    コアのファイルを変更するのは良くない気がするので、admin_init フィルターフックで Content-Type を削除してセットし直した方がいいですが、もしコアのバグだったら次のアップデートで直る気もするのでコアファイルの変更もありな気もして、まぁ、次のアップデート時にもおかしくなったら考えたらいいのかもしれません。

    はいそうですね…ちょっと軽率でした。
    今のところ不具合なさそうなので、様子見ます。
    本当にありがとうございました!

11件の返信を表示中 - 16 - 26件目 (全26件中)
  • このトピックに返信するにはログインが必要です。