サポート » 開発版 » RC2のインストール時のエラー

  • 解決済 boyaji

    (@boyaji)



    RC2をインストール時に次のようなエラーが表示されました。

    「Parse error: syntax error, unexpected T_VARIABLE in /home/sites/heteml/users24/o/l/d/oldponta/web/rc2/wp-includes/functions.php on line 522」

    解決するにはどうしたらよいでしょうか?

    使用サーバーはヘテムルです。

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • WordPress 3.2 からは、システム動作環境として PHP 5.2.4 以降が要求されます。

    Parse error が発生している wp-includes/functions.php の522行目には
    $newvalue = clone $newvalue;
    とありますが、ここで出てくる clone は PHP 5 以降で利用できる命令です。
    多分、お使いの環境が PHP 5.2.4 以降では無いのではないでしょうか?

    もう一度、サーバの環境を確かめてください。
    WordPress 3.2 以降が利用できる環境かどうかは Health Check プラグインで確認できます。
    http://wordpress.org/extend/plugins/health-check/

    また、以下のエントリには詳細が記述されていますので、そちらも参照なさってはどうでしょうか?
    WordPress 3.2が出るまでに確認すること | understandard.net

    解決策としては、お使いのレンタルサーバで PHP 5.2.4 以降が利用できるようにするしかありません。
    お使いのレンタルサーバで PHP 5.2.4 以降が使えるかどうかは、このフォーラムとは関係ない話題ですので、レンタルサーバのヘルプデスクに問い合わせてください。

    早速の解答有り難うございます。
    ヘテムルサーバーではPHP5.3をサポートしているそうですが、利用するためには「.htaccess」ファイルの導入が必要とのことです。
    この指示に従って再度挑戦してみます。

    レンタルサーバーの指示通りファイルを導入したところエラー無くインストールが始まりました。
    お手数をかけました。有り難うございました。

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • トピック「RC2のインストール時のエラー」には新たに返信することはできません。