サポート » プラグイン » Search-Regexのプラグインでエラー

  • 解決済 humipine

    (@humipine)


    Search RegexのプラグインをWordPressにインストールしていました。自動更新をするようにセットしていたら、以下のようなエラーが発生して、管理画面にログイン出来ません。

    ※エラーメッセージ▼
    Parse error: syntax error, unexpected ')' in /home/infinity88/infinity108.com/public_html/wp-content/plugins/search-regex/includes/modifier/modifier-member.php on line 156

    このサイトで重大なエラーが発生しました。対応手順については、サイト管理者のメール受信ボックスを確認してください。

    WordPress のトラブルシューティングについてはこちらをご覧ください。
    ※エラーメッセージはここまで

5件の返信を表示中 - 1 - 5件目 (全5件中)
  • munyagu

    (@munyagu)

    こんにちは

    同じようにエラーになっている方がいるみたいです。

    https://wordpress.org/support/topic/fatal-error-4208/

    FTP かサーバーのフィルマネージャーでwp-content/pluginsディレクトリにあるsearch-regexディレクトリの名前を別の名前に変更するか、削除してしまってください。

    不具合が修正されるなど問題が解決するまで以下のリンク先ページ一番下から、ひとつ前のバージョン、2.4.1 をダウンロードして、プラグイン追加画面からアップロードしてお使いください。
    自動更新はしないようにしてください。

    https://wordpress.org/plugins/search-regex/advanced/

    トピック投稿者 humipine

    (@humipine)

    返信遅れてしまい申し訳ありません。
    ご指摘のフォルダー名を変更してみると、エラーがなくなりました。
    ただ、インストール済みプラグインの一覧をみると、フォルダー名を変えたプラグインが削除されたという赤色の注意メッセージが一覧の一番上に出てきます。
    このまんまにしていますが、いつになったら、再びインストールすればよいのか・・・

    一覧で無効になっている Search Regex は削除しても問題ありません。
    Search Regex がサイトの表示に必要な何かのデータを保持しているわけではありませんので。

    最新の修正版がリリースされたらインストールすれば良いと思いますが、上記リプライのトピックをときどき覗いてみてはどうでしょうか。

    いまインストールしたいなら、上記リプライにあるように 2.4.1 をダウンロードして インストールしてください。

    なにか、最新の 3.0.2 では修正されているようですが・・・
    今回のエラーの修正が 3.0.1 で、それが修正されたことによって出た別のエラーが修正されたのが、3.0.2 です。

    3.0.2 – JULY 28TH 2022
    Fix more issues with older PHP
    Fix a failed update not showing an error message
    Fix post meta not updating

    3.0.1 – JULY 26TH 2022
    Fix issue with PHP < 7.4
    Fix ID appearing on date values
    Fix a global search on options with no filter causing a bad query

    • この返信は1週、 3日前にmunyaguが編集しました。
    トピック投稿者 humipine

    (@humipine)

    アドバイスありがとうございました。3.0.2をインストールしてみてうまくいきました。このフォーラムを利用してとても良かったです。

5件の返信を表示中 - 1 - 5件目 (全5件中)
  • このトピックに返信するにはログインが必要です。