サポート » プラグイン » SiteGuardの画像認証が使えない(AllowOverrideにLimit設定済み)

  • プラグインの設定画面でONにして変更を保存にしてもOFFに戻り
    「この機能を使用するには、httpd.confのAllowOverrideにLimitを指定する必要があります。」との表示が出ます。

    サーバー会社に問い合わせたところ

    httpd.confのAllowOverrideについてですが、現状では All (Limitを含みます)が設定されています。

    とのことで問題ないみたいです。

    他に原因はありませんでしょうか?教えてください。
    (SiteGuardの他の機能は正常に動いていますし、各種操作、保存もできています。)

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • 画像認証機能を使用するには、phpに拡張ライブラリmbstringとgdがインストールされている必要があります
    http://www.jp-secure.com/cont/products/siteguard_wp_plugin/system.html

    kosikuwa さん
    こんにちは。

    画像認証機能の使用可否は、以下のURLにアクセス可能かで判断しています。
    サイトURL/wp-content/plugins/siteguard/really-simple-captcha/tmp/dummy.png

    このディレクトリに.htaccessを作成しており、アクセス制御の内容があるため、AllowOverrideにLimitが必要と表示しています。

    上記URLの最後の、tmpディレクトリや、dummy.pngが存在しない場合は、権限の問題である可能性があります。
    apacheの権限で、ディレクトリやファイルが作成可能であるか、確認してみてください。

    あるいは、apacheのエラーログにヒントがあるかもしれません。

    もっと的確なエラーメッセージを表示できるように、将来のバージョンでの改良を検討します。

    スレッド開始 kosikuwa

    (@kosikuwa)

    npssl様、jp-secure様、早速にありがとうございます。

    サーバー会社に、聞いてみます。
    結果も報告します。
    本当にありがとうございました。

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • トピック「SiteGuardの画像認証が使えない(AllowOverrideにLimit設定済み)」には新たに返信することはできません。