サポート » プラグイン » [SiteGuard WP Plugin] siteguard-wp-pluginをインストールしたら500Internal Server Errorに

  • 解決済 tkhsh

    (@tkhsh)


    siteguard-wp-pluginをインストールし、画像認証のログインページ画面が表示されました。
    ユーザー名・パスワード・画像の文字を入力してみると、
    500 Internal Server Error になってしまいました。

    サーバーのエラーログを確認してみると、
    malformed header from script. Bad header=/home/●●●/dead.letter… Sa: wp-login.php, referer: http://●●●.com/wp/login_●●●●●●
    となっています。

    同じサーバー内で別のドメインにインストールしたワードプレスでも同様の症状となってしまいました。

    アドバイスを頂けますでしょうか。
    よろしくお願いいたします。

11件の返信を表示中 - 1 - 11件目 (全11件中)
  • 메텔

    (@digitmaetel)

    プラグインを有効化した後、設定ページは全て設定しましたか。有効化しただけではないですか。

    맹조さん
    早速のご指摘ありがとうございます。

    siteguard-wp-pluginの設定はデフォルトのままで問題なかったので、
    有効化した後に設定は特に触っていません。

    他のサーバーに入れたワードプレスでは、
    siteguard-wp-pluginの設定はデフォルトのまま
    設定し直さなくとも問題なく有効に使用できています。
    設定をし直さなければ500 Internal Server Errorがでる場合もあるのでしょうか。

    なお補足ですが、
    他の使用中のプラグインは、akismetとWP Multibyte Patch
    だけですので、他のプラグインの干渉ということではなさそうです。

    よろしくお願いいたします。

    tkhshさん、こんにちは。

    ご質問の件ですが、エラーログの内容からログイン時にメールを送信する機能「ログインアラート」で、送信エラー(拒否など)が発生したことに起因している可能性があります。
    可能であれば、以下の手順で切り分け・動作確認をお願いいたします。

    1.SiteGuard WP Pluginの削除
    – /wp-content/plugins/にある、siteguardディレクトリを削除してください。
    – WordPressのインストールディレクトリにある.htaccessの以下の部分を削除してください。

     #SITEGUARD_PLUGIN_SETTINGS_START から
     #SITEGUARD_PLUGIN_SETTINGS_END まで

    2.WordPressにログインできることを確認

    ※継続してご利用いただける場合は、以下の手順も実施してください。
    3.SiteGuard WP Pluginのインストール

    4.「ログインアラート」機能の無効化
     インストール後、ログインアラートの機能を無効にしてください。

    5.動作確認
     WordPressからログアウトしてログインページに戻ったら、ユーザー名・パスワード・画像認証の文字列を入力し、ログインできるかをご確認ください。

    お手数をおかけいたしますが、宜しくお願い申し上げます。

    jp-secureさま

    大変お世話になっております。
    とても良いプラグインでいつも助かっています。

    教えて頂きました1から5まで、動作確認まで全てうまくいきました!
    ありがとうございます。m(__)m

    解決済みとする前に以下について教えて頂けると嬉しいです。

    今回は「ログインアラート」機能の無効化という対処でログインは可能になりました。
    但し、当プラグインの機能の一つ「ログインアラート」を使用しないという条件付きです。

    「ログインアラート」機能を絶対に使用しなけらばならないという訳ではありませんが、
    折角の良い機能なので、できれば有効にしたいものです。
    「ログインアラート」機能を有効にしても「送信エラー」を起こさない様にはできませんでしょうか。

    今回の現象の原因である「送信エラー」が起こった理由は、
    どの様なことが考えられますでしょうか。
    今回使用しているサーバーでは、2件中2件ともこの症状が出ておりましたが、
    サーバー側の問題に起因してるのでしょうか。

    可能であれば原因を潰したいと思っています。

    引き続きアドバイスを頂けますと助かります。
    よろしくお願いいたします。

    메텔

    (@digitmaetel)

    同じサーバー内で別のドメインにインストールしたワードプレスでも同様の症状となってしまいました。

    そして、他のサーバーのWordPressでは動作している。

    ご質問の件ですが、エラーログの内容からログイン時にメールを送信する機能「ログインアラート」で、送信エラー(拒否など)が発生したことに起因している可能性があります。

    これらから考え合わせるに、アドバイスしてもらいやすいのは、具体的にサーバーの情報が有る方が jp-secure さんサイドとしても今後の情報として助けになると思いますよ。

    맹조さま、ありがとうございます。
    そうですよね。

    さくらインターネットのレンタルサーバースタンダードプランを利用しているのですが、
    具体的にどの様なサーバー情報をお伝えしておくべきなのか、さっぱり見当がつかなくて。
    素人なもので申し訳ありません。

    jp-secureさま、具体的に必要な情報等、ご指南頂ければと思います。

    よろしくお願いいたします。

    tkhshさん、こんにちは。
    >맹조さん、フォローありがとうございます。

    ご質問の件について、切り分け・動作確認ありがとうございました。
    また、引き続き、プラグインをご利用いただきありがとうございます。

    調べてみたところ、下記URLで報告されている事象、または類似の事象が発生している可能性が考えられます。
    http://blog.longkey1.net/archive/812

    内容について、一度ご確認いただけますと幸いです。
    宜しくお願いいたします。

    메텔

    (@digitmaetel)

    リンク先URL読みました。
    ということは、他のサーバーででもメールのほうを Google Apps だとエラーが起こりうるのかしら。時間を作ったら状況を作って、じっくり試してみようと思います。

    jp-secureさま

    お陰さまで解決できました。

    ・ウェブサーバから、PHPで同じドメインへメールを送ろうとすると、内部のドメインってことでDNSを見に行かずにメールを送ってしまう
    ・内部的にはそんなメアドがないので、sendmail側でエラー
    ・Internal Server Error発生

    まさにリンク先に書いてあった上記のとおりでした。

    さくらサーバー上には作成していなかった当該ドメインのメールアドレスをWP管理者のメールアドレス欄に入力していたため、今回のエラーが発生していたようです。
    お騒がせして大変申し訳ありませんでした。

    ですので、今回は結局のところ、

    さくら上にも同じメールアドレスを作っといてやる

    という訳で、WP管理者のメールアドレスをさくらサーバー上に作成して解決いたしました。
    動作確認済みです。

    jp-secureさま、
    この度はお忙しい中ていねいに教えて頂き、本当にありがとうございました。

    맹조さまも、お付き合い頂き、ありがとうございました。

    m(__)m

11件の返信を表示中 - 1 - 11件目 (全11件中)
  • トピック「[SiteGuard WP Plugin] siteguard-wp-pluginをインストールしたら500Internal Server Errorに」には新たに返信することはできません。