サポート » プラグイン » Smart Custom Fields の WYSIWYG でデフォルトの値がセットされた時に入力データが反映されないことがある

  • お世話になります。

    Smart Custom Fields で、デフォルトの値にHTMLを設定している WYSIWYG が2つあるのですが、片方は入力したデータが正常に出力され、もう片方は正常に出力されないという現象が起きました。
    デフォルトの値とは、具体的には以下のような感じです。

    正常に出力される方

    
    <table class="table table-responsive table-striped">
    <thead>
    <tr>
    <th>氏名</th>
    <th>成績(年)</th>
    </tr>
    </thead>
    <tbody>
    <tr>
    <td></td>
    <td></td>
    </tr>
    </tbody>
    </table>
    

    正常に出力されない方

    
    <table class="table table-responsive table-striped">
    <thead>
    <tr>
    <th>NAME</th>
    <th>RESULT(YEAR)</th>
    </tr>
    </thead>
    <tbody>
    <tr>
    <td></td>
    <td></td>
    </tr>
    </tbody>
    </table>
    

    デフォルトの値は上記のようにして、各投稿では td の値だけセットして、実際のページでは一覧画面で全ての投稿のカスタムフィールドの値を出力させたいのですが、正常に出力されない方のフィールドのみ「入力したデータが反映されず、デフォルトのデータが表示されてしまう」という現象が起きます。

    具体的には、各投稿で td の値を入れたはずなのに、公開したページを見ると、デフォルトの値が出力されてしまいます。
    (投稿の編集画面で th の値を変更してみたりしても反映されず、やはり上述のデフォルトの値が出力されてしまいます。)

    デフォルトの値というのは、なにか入力すると不具合が発生するような文字などあるのでしょうか。
    日本語用のテーブルは出力され、英語用のテーブルは出力されなかったので、なにかだめな文字があったのかとも思いました。

    また、不具合の発生するサイトでは qTranslate-X という多言語対応のためのプラグインが入っていて、変種画面で言語をデフォルトの日本語ではなく英語に切り替えた状態でページを更新してしまうと、カスタムフィールドのデータが消えてしまうという現象もあるのですが、これは運用で気を付ければ大丈夫なので別件だと思っています。

    その他、PHPの一度に処理する件数が多いとデータが消えることもあるという情報も見つけたので、上限をあげたりしてみたのですが、これも解決しませんでした。

    アドバイスいただければと思います。
    よろしくお願いします。

    • このトピックは10 ヶ月、 1 週前に  fri 231 さんが編集しました。理由: プラグイン名修正
1件の返信を表示中 - 1 - 1件目 (全1件中)
  • 正常に出力されない方のカスタムフィールドの『フィールド編集』画面の設定情報を実際のものそのまま教えて貰えますか?
    差し支えなければスクリーンショットの方が良いですが。

1件の返信を表示中 - 1 - 1件目 (全1件中)
  • トピック「Smart Custom Fields の WYSIWYG でデフォルトの値がセットされた時に入力データが反映されないことがある」には新たに返信することはできません。