サポート » プラグイン » SNS連携時のエラーに500 status code for “POST /sites/164968391/publicize-connections/new”

  • 解決済 kmaruta

    (@kmaruta)


    Jetpackをインストールして、WordPress.comでtwitter・Facebookのアカウントを連携しようとしたとき、下記のエラーのポップアップが出て連携できません

    500 status code for “POST /sites/164968391/publicize-connections/new”

    のエラーが出ます。

    jetpack を用いてWPの投稿をFacebook・Twitterに自動投稿したいと思っており、そのためのアカウントとの連携です。

    このエラーに関する原因と解決法をご存知の方がおられましたら、ぜひご教示ください。

    あまり起こらないエラーなのか、フォーラムやGoogleなどで探してもなかなかトピックが見つかりません。
    よろしくお願いします。

5件の返信を表示中 - 16 - 20件目 (全20件中)
  • CG

    (@du-bist-der-lenz)

    知識が乏しいのはお互い様です。ここはわかんないけど、まぁいいやと回避しないで、肝心なところであったりなので、そういった理解の薄いところを訊いて下さい。そのとき、答えやすいように簡潔に問うて下さい。そういう書き方は努力して下さい。察して理解して下さい、と思われてもわたしは教育者ではないのですから。仕事でしたら最大工夫しますが、仲間内がわかるぐらいの表現しかできませんのでご無礼します。

    上に ishitaka さんが書かれている

    サーバーの機能で国外からのアクセスを制限するような設定になっていませんか?
    xmlrpc は使用できますか?
    https://help.onamae.com/answer/9137

    と、内容はかぶりますが、xmlrpc が使用できるかどうかの確認をしてみてください。
    トラブルシューティングのヒント

    4.XML-RPC ファイルを確認してください。サイト URL の末尾に “/xmlrpc.php” を引用符抜きで追加したページにアクセスすると確認できます。ブラウザに読み込まれたら、”XML-RPC server accepts POST requests only” というメッセージが一行で表示されるはずです。

    ネットで「いろいろなサイト」の情報を試されているようですが、ネット上の情報が全て正しいとは限らないということを覚えておいてください。
    プラグインのトラブルは、まずは配布元の情報を確認するのがベストです。

    皆様ありがとうございました。
    無事に解決することができ感謝いたします。

    現在お名前ドットコムのサーバーにて2019年3月13日よりWordPressの「wp-login.php」および
    「xmlrpc.php」ファイルに対して、日本国外のIPアドレスからアクセスが行えないように制限を実施してたようです。

    ドメイン直下の「.htaccess」ファイルの先頭行に
    – – – – – – – – – – – – – – – – – – – –
    <Files wp-login.php>
    order allow,deny
    allow from all
    </Files>
    <Files xmlrpc.php>
    order allow,deny
    allow from all
    </Files>
    – – – – – – – – – – – – – – – – – – – –
    の記述を追加することで解決しました。

    CG

    (@du-bist-der-lenz)

    そのとおりです。 Jetpackプラグインのダッシュボードから、「デバッグ」のページ(example.com/wp-admin/admin.php?page=jetpack-debugger)に、「Jetpack がうまく動作しませんか ?」「以下の問題が原因となっている可能性があります。ご確認ください。」の4項目に、「XMLRPC ファイルの問題。 XMLRPC ファイルを表示してみてください。正しく動作している場合は「XML-RPC server accepts POST requests only.」というメッセージのみが一行で表示されます。- その他の内容が表示されている場合、テーマまたはプラグインが不要な文字を追加している可能性があります。」とあります。
    現在「全てからのアクセスを許可しています」と宣言しているようなものなので、Jetpackだけを対象にしましょう。そして、サイトURLは、ドメインの下にサブディレクトリ(/wp/)が無いことが好ましいです。

    「wp-login.php」の方は、アクセス制限かけたままの方が良くないですか?

5件の返信を表示中 - 16 - 20件目 (全20件中)
  • このトピックに返信するにはログインが必要です。