サポート » プラグイン » Social Networks Auto-Poster:エラー code”:170,”message”:”Missing required parameter:

  • お世話になります。

    Social Networks Auto-Poster(SNAP)をインストール・設定した後、設定画面からテスト投稿をしてみたところ、「code”:170,”message”:”Missing required parameter: status.」のエラーが出ました。経緯は以下の通りです。

    ■Twitterのみの連携をしています。
    ■プラグインでの設定(Settingsのタブの部分)は、何も変更していません

    プラグインをインストール、テスト投稿

    Could not authenticate youというエラーが

    Twitter側でConsumer KeyやAccess TokenをRegenerat、再度Wordpressにコピペ

    エラー内容変わらず

    プラグインを一度削除、再度インストール

    errors”:[{“code”:170,”message”:”Missing required parameter: status.”というエラーに変わる

    ネットで解決方法を調べている間10分くらい放置した後、再度テスト投稿

    テスト結果が -1 という表示だけになる

    実際の投稿画面でテスト、Twitterの自動投稿がされる

    Twitterでの投稿フォーマットを変えたくて、再びプラグイン設定画面をいじったのちテスト投稿

    errors”:[{“code”:170,”message”:”Missing required parameter: status.”が再度表示

    何をどう修正したらいいのか、全く見当がつかず困惑しています。
    どなたかご教示いただけますと幸いです。
    よろしくお願いします。

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • そのプラグインを使ったことはないですが

    Twitter: Setup/Installation Social Networks Auto-Poster for WordPress

    あたりをみて、設定を再確認したらどうかなと思います。

    ありがとうございます。

    ご提案いただいたページは、何度も見ていて繰り返しイチから設定をやり直しているんですが、何も変わらずでして・・・。

    ただ、エラーは相変わらず出るのですが、Twitterへの自動投稿は正常に行われるようになりました。もう何が何やらよく分からないのですが・・・。

    今後何か不具合が出るかもしれませんが、今のところは目的を果たしていると言えるかもしれません!?

    ありがとうございました!

    手持ちの WordPress 4.7.2 にこのプラグインをいれて、手持ちの Twitterにテスト投稿しましたが、問題なく投稿されましたよ。
    ですので設定が間違っていると思います。
    Access Token は2行に折れ曲がっていますが、数字-文字の羅列 になるはずで、このあたりは間違いないでしょうか。
    また Message Format として
    Test for WordPress Plugin: %TITLE – %URL%
    を使ってみました。このあたり簡単な設定にして試してみるといいかもしれません。

    TwitterのURLですが、
    https://twitter.com/◯◯

    ですが、https から始まっていますか。
    このあたりが注意点かなぁと思います。

    • この返信は3年、 6ヶ月前にkimipoohが編集しました。

    おっと https://twitter.com/◯◯ なのに
    IDとしたら、それが埋め込まれて表示されてしまいましたので修正しました。

    • この返信は3年、 6ヶ月前にkimipoohが編集しました。

    何度もありがとうございます。

    ご指摘いただいた点は全て、何度も確認して設定を繰り返していまして。
    本当に何が原因か分からないのですが・・・。
    一応、動いてることは動いているので、このまま放置でいいかなと思えてきております^^;

    いろいろ試していただいてありがとうございます!

    なるほど。

    https://github.com/twitter/twitter-text/issues/8

    などをみると、140文字制限にひっかかったとか、\r\nという改行コードが入ってしまっているなどの場合にでるかも?とか書かれています。ですので、Message Formatの設定で改行されていないかチェックしてみるのも手かなぁとは思います。

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • トピック「Social Networks Auto-Poster:エラー code”:170,”message”:”Missing required parameter:」には新たに返信することはできません。