サポート » プラグイン » SSL化したらホームページが表示されません

  • 対象となるホームページ

    http://takeheartbeat.com/

    Warning: ksort() expects parameter 1 to be array, object given in /home/users/0/hippy.jp-thb/web/wp-content/plugins/bbpress/includes/core/template-functions.php on line 316

    上記エラーから今度はテーマ「thb」にてエラーが発生しているとのことです。

    現在の環境は5月14日にロリポップで無料独自SSLを設定したらエラーが出ました。

    最初はワードプレス管理画面にもログイン出来ずホームページも表示されませんでした。

    dvanced-custom-fields】にエラーがあった為にワードプレス管理画面にログイン出来ない為に

    ロリポップFTPから無効化しました。→_advanced-custom-fields】

    ワードプレス管理画面にログイン出来るようになりホームページのトップ画面上部にエラー表示はありますが
    一部は表示されるようになりました。

    今度は「bbpress」に問題があるとエラー表示されたのでロリポップFTPで無効化したところホームページの

    トップバナーとエラー表示だけが残りあとは真っ白になってしまいました。

    再度一時的に「bbpress」を無効化したところ
    サイトのトップページで、以下のエラーが発生いたしました。
    今度はワードプレス管理画面から「bbpress」を有効化したら無効化する以前のようにエラー表示は
    ありますが一部表示できるようになりました。

    ※「bbpress」は有効化しています。

    Fatal error: Call to undefined function is_bbpress() in /home/users/0/hippy.jp-thb/web/wp-content/themes/thb/header.php on line 120

    advanced-custom-fields バージョン 5.12.2

    bbpress バージョン 2.5.5

    ワードプレス本体 バージョン 4.1.1

    テーマ ワードプレスから提供されているテーマをカスタマイズしているようでバージョンも不明です。

    ロリポップPHP バージョン 5.3CGI版

    ロリポップMySQL 5.6

    現状、thbというテーマに問題があるようですがどのように対処していいのかわかりません。

    ホームページをなんとしてでも復旧させたいです。

    どなたか良い復旧方法を教えてください。

    よろしくお願い致します。

    ヘルプの必要なページ: [リンクを見るにはログイン]

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • こんにちは

    SSL 化したときに、Advanced Custom Fields のアップデートをしなかったでしょうか?をしていると思いますが、何をしたか覚えておられるでしょうか?
    Advanced Custom Fields が最新バージョンになっています。

    最新の Advanced Custom Fields では、php のバージョン 5.6 以降が必要ですが、サイトでは 5.3 が使われています。
    bbPress のバージョンは古いもののようで、WordPress 4.1 までしかテストされていないですが、WordPress は 5.1.3 をお使いのようです。

    安易にいろいろバージョンアップしてしまったため、いろいろなバージョンの間で齟齬が生じているようです。

    お使いのサーバーでバックアップがとれているのであれば、バックアップから戻されることが一番良いと思います。
    そうでないなら、専門の業者に対応を依頼することをお勧めします。

    された作業を思い出して Advanced Custom Fields のバージョンを戻したりなどして試行錯誤することもできるとは思いますが、さらに状況を悪くしてしまうことも考えられます。

    トピック投稿者 kytg1123

    (@kytg1123)

    アドバイスありがとうございます。プロの方に伺ったところ復旧は極めて困難であり、ホームページをリニューアルした方が時間もコストもかからないとのことでした。並行して自身で新規サイトを制作しながら今一度復旧に取り組んでみたいと思い下記のページを参考にAdvanced Custom Fields4.4.12に差し替えてみようと思います。
    https://shiritai.net/advancedcustomfields_update/

    見落としていましたが、もともとは WordPress のバージョンが 4.1.1 だったんですね。
    なぜいま、5.1.13という中途半端なバージョンになっているのか分からないですが・・・

    WordPress と Advanced Custom Fields のバージョンを元に戻せばとりあえず復旧できそうにも思いますが。

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • このトピックに返信するにはログインが必要です。