サポート » プラグイン » The ThorにプラグインYada Wikiインストールでエラー

  • 解決済 warashi

    (@warashi)


    テーマThe ThorにプラグインYada Wikiをインストールするとエラーとなります。
    以下サイトを参考にページを制作しましたが、
    https://briarpatch.co.jp/wordpress-wiki
    TOPページ(TOC)を制作、表示させたところ、
    https://briarpatch.co.jp/wordpress-wiki#toc6
    エラーが出ました。
    Fatal error: Cannot redeclare current_crumb_tag() (previously declared in /home/*****/*****.com/public_html/wp-content/themes/the-thor/inc/front/breadcrumb.php:22) in /home/*****/*****.com/public_html/wp-content/themes/the-thor/inc/front/breadcrumb.php on line 22

    他のテーマTwenty Twentyではエラーは出ません。
    このことで、解決策、もしくは何か情報をお持ちでしたら是非教えていただけないでしょうか?

10件の返信を表示中 - 1 - 10件目 (全10件中)
  • エラーメッセージの意味は、「同じ関数は2度定義できない」という意味ですよね、if文で囲んでありますか。

    スレッド開始 warashi

    (@warashi)

    메텔 様

    ありがとうございます。
    まだFTP情報を入手できていなくてエラー対象のファイルの中を見ていないのですが、テーマ内のファイルを修正するしか方法はなさそうということですね?

    スレッド開始 warashi

    (@warashi)

    https://php1st.com/1326
    対象ファイルを修正したらエラーはでなくなりました。
    ありがとうございました。

    関数が2度定義されていたので、if文で囲んで解消したのですね。ありがとうございます。

    こんにちは

    該当のテーマは有償のテーマなのでこのフォーラムではサポートできませんが、テーマを直接変更すると、購入元のサポートも無くなるんじゃないでしょうか。

    そのテーマで子テーマの利用が推奨されているか知りませんが、子テーマを使用することをお勧めします。

    スレッド開始 warashi

    (@warashi)

    皆様ありがとうございました。
    エラーは解消されましたが、修正ファイルは親テーマ内にありますので、これをどうするか協議しております。
    ただ、エラーが解決できたことで大きな前進にはなりました。
    ありがとうございました。

    子テーマ運用中であれば余計な説明になると思い控えておきましたが、修正ファイルが親テーマ内にあるのを周知しておくのが良いでしょう。このケースはプラグインとの相性と思えますし、テーマ提供側の責任ではないので確率はないでしょうが、子テーマ運用で該当箇所を修正していても、テーマやプラグインの改修情報を追跡していくのは大事でしょう。

    スレッド開始 warashi

    (@warashi)

    메텔 様
    貴重なご意見ありがとうございます。
    テーマのアップデートも想定しておりますので、判断が難しいところです。

    ただし、運用中のサイトでいきなりアップデートすることなど考えにないので、判断に悩まされたことはないです。

    テーマの inc などのディレクトリにあるファイルを子テーマに持ってくるのはなかなか難しいかもしれません。
    なぜエラーになっていたのかの原因を追求して根本解消したほうがいいと思いますよ。

10件の返信を表示中 - 1 - 10件目 (全10件中)
  • トピック「The ThorにプラグインYada Wikiインストールでエラー」には新たに返信することはできません。