サポート » 使い方全般 » TOPへのリンクが表示されなくなった

  • 解決済 Mana311

    (@mana311)


    Twenty Elevenから子テーマを作成し、作っております。
    今まで問題なくリンクされていたのですが、プラグインを入れたりしている際に、気付くとTOPページのリンクがおかしな事になっていました。

    headerにロゴを入れ、
    <a href=”<?php echo esc_url( home_url( ‘/’ ) ); ?>” title=”<?php echo esc_attr( get_bloginfo( ‘name’ , ‘display’ ) ); ?>” rel=”home”>
    のタグで、TOPへ飛ぶようになっていたのですが、いつの間にか表示されなくなってしまいました。

    飛んだ先のアドレスを見ると
    サイトトップURL/
    <b>Worning</b>: Division by zero in <b>home…~~~~~~
    80
    サイトトップURL
    このような長いURLになってました。
    何処を直したら良いのでしょうか?
    どうぞよろしくお願い致します。

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • モデレーター のむらけい (Kei Nomura)

    (@mypacecreator)

    ~~~~~~で省略されているところが重要かもしれないので、省略せずに貼ってもらったほうが回答がつきやすいと思います。

    あと、Division by zero inって、0を割り算した時に出るエラーなので、普通WordPressのテーマカスタマイズで出るようなエラーじゃないんですよね・・・
    使っているプラグイン依存かもしれないので、1つずつプラグインを止めて、どれが悪さしてるのか突き止めてみてください。
    詳しくはこちらを参考に→http://ja.forums.wordpress.org/topic/11794?replies=1

    モデレーター のむらけい (Kei Nomura)

    (@mypacecreator)

    あとすみません、貼ってもらってるコードで、
    ‘/'とかの部分、後ろの「'」はシングルクォーテーションで問題ないんですが、
    最初の「‘」が全角のアポストロフィになってます。
    これは実際のテーマに書いてあるやつもそうなってますか?
    だとしたら「‘」→「'」に直してください。

    世話役様、こちらのトピックへのリンクありがとうございます。
    このフォーラムにも慣れていないため、こちらのトピックのタグも不完全な状態になっていました。
    申し訳ありません。

    書き直してみました。
    サイトトップURL/<br /><b>Worning</b>: Division by zero in<b>home…(子テーマのあるディレクトリ)header.php</b> on line <b>80</b><br />サイトトップURL②

    そして、気付いたのですが、サイトトップURL②は、よく見ると「http:/~~」となっていました。
    つまり、「/」が一つ足りません。
    それで、割り算エラーの「Warning: Division by zero」があるのでしょうか?
    でも何処で直したら良いかわかりません。

    TOPページはちゃんと存在しています。
    どうぞよろしくお願い致します。

    >mypacecreator様
    私の2回目の投稿前にコメント頂いていたのですね。ありがとうございます。
    プラグインは一つ一つ試してみましたが、全部停止しても直りませんでした。
    また、全角のアポストロフィーを直すと、エラーになってしまい、ページが表示されなくなってしまいます。

    少し説明が足りませんでしたが、ロゴをクリックすると「ページが見つかりません」となるのですが、ヘッダー部分、フッター部分は表示されていて、「ご指定のコンテンツを見つけられませんでした。検索するか、下記のリンクが役に立つかもしれません。」となっています。
    ただ、下記のリンクなるものは、ありません。

    どうぞよろしくお願い致します。

    FireFoxで作業していたのですが、IEで見てみたら、こんなエラーが出てきます。
    TOPページのロゴをクリックした時に出るのですが、他のページからクリックしても何も表示されず、真っ白になっています。

    fault(); $(this).parent().children().not(“.event-date”).toggle(); }); }); $(function() { $(“.mini .has-events”).children().not(“.trigger”).hide(); $(“.mini .has-events .trigger”).on(“click”, function(e) { e.preventDefault(); $(this).parent().children().not(“.trigger”).toggle(); }); $(“.mini-event .close”).on(“click”, function(e) { e.preventDefault(); $(this).parent().parent().parent().toggle(); }); }); }(jQuery));

    おかしいことに気づいた時に弄っていたプラグインは My Calendar で、その前にAjax Event Calendar を削除しました。
    Ajax Event Calendarを設定した時に、php.iniファイルにmagic_quotes_gpc = Offを追加したのですが、削除と共に、こちらも元に戻しました。
    サーバーはさくらインターネットです。

    的外れな情報かもしれませんが、どうぞよろしくお願いします。

    モデレーター gatespace

    (@gatespace)

    サイトトップURL/<br /><b>Worning</b>: Division by zero in<b>home…(子テーマのあるディレクトリ)header.php</b> on line <b>80</b><br />サイトトップURL②

    子テーマの header.php の 80行目にエラーがあるよ、と言う意味です。

    親テーマ(Twenty Eleven)のheader.phpと見比べてみてください。

    Mana311さん こんにちは、

    想像ですが、

    ホームへのリンクは、

    <a href=""><img src=''></a>

    という構造で、レスポンシブな設計になっているのではないですか?

    仮にそういう場合だと、

    画像のサイズを、javascript等で、可変するという事になると思いますが、

    画像の縦横比を算出するのに、phpの getimagesize() などを使っていると、取得できなかった時に、そういったエラーが出ます。

    なので、もしそうなら、画像のほうを追っかけるといいと思います。

    >gatespace様
    ありがとうございます。そういう意味なんですね。
    80行目を見比べてみましたら、mypacecreator様がご指摘された全角のアポストロフィが悪さをしているようで、もう一度直してみたら、直りました!!
    前回やった時は、違う所まで直してしまったようです。
    せっかく教えて頂いたのに、申し訳ありません。

    >nobita様
    まさに、その通りの設計になっておりましたが、getimagesize()は使っておりませんでした。
    でも、とても参考になりました。

    お答えくださった皆様、本当にありがとうございます。
    貴重なお時間を割いてくださり、感謝致します。

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • トピック「TOPへのリンクが表示されなくなった」には新たに返信することはできません。