サポート » プラグイン » topページのみAll in One SEO Pack の設定が読み込めない

  • 解決済 piposan

    (@piposan)


    はじめて書き込ませて頂きます。
    質問の仕方が悪かったり、重複する部分があればご容赦下さい。

    WordPress3.3.2でサイト全体を構築し、SEO対策として、All in One SEO Pack 1.6.10.2 を設置しました。
    テーマはデフォルトテーマ「Twenty Eleven」を使用しています。

    ソースを確認すると、サイト全体ではAll in One SEO Pack の設定が読み込めているのですが、topページのみ以下のように、”description”も”keywords”もなく内容が読み込めていません。ダッシュボードでは表示に何ら問題がないように見えます。ソースを確認して初めて気がつきました。

    <!– All in One SEO Pack 1.6.14.5 by Michael Torbert of Semper Fi Web Design[-1,-1] –>
    <link rel=”canonical” href=”http://&#8221; />
    <!– /all in one seo pack –>

    どうしてこのようになるのでしょうか?また、どこを修正すると他のページのように、All in One SEO Pack の設定が読み込めるようになるのでしょうか。
    これではSEO対策としての意味がないような気がします。

    どなたかご教授お願い致します。

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • モデレーター jim912

    (@jim912)

    piposanさん、こんにちは。

    設定が読み込めない

    とは、具体的にどの設定が反映されていないのでしょうか。

    当方環境では、All in One SEOの設定で「Home Description」と「Home Keywords (comma separated)」を入力すれば、問題なくキーワード、ディスクリプションの出力はなされました。

    jim912さんお返事ありがとうございます。

    ご相談の件、具体的には
    フロントページの表示に設定した固定ページでのことです。
    ダッシュボードの下部分に表示されるAll in One SEO Pack欄にて、
    Title
    Description
    Keywords (comma separated)
    の書き込みがしてあるにもかかわらず、HTMLソースで確認すると、その部分が反映されていません。ソース的には以下のように空になってしまいます。

    <!– All in One SEO Pack 1.6.14.5 by Michael Torbert of Semper Fi Web Design[-1,-1] –>
    <link rel=”canonical” href=”http://&#8221; />
    <!– /all in one seo pack –>

    ちなみに他のページは、きちんとダッシュボードのAll in One SEO Pack欄の内容が、HTMLソースで表示されます。
    表示されないのは、フロントページの表示に設定した固定ページのみです。

    どこかに問題があるのでしょうか・・・。
    お手数をおかけしますが、よろしくお願いいたします。

    モデレーター jim912

    (@jim912)

    [設定] > [All in One SEO]
    Home Description:
    Home Keywords (comma separated):
    に入力してください。

    jim912さんお返事ありがとうございます。

    ありがとうございました。
    topページのみ、ここから設定するのですね。
    問題が解決しました。
    本当にお世話になりました。感謝です。

    質問させてください。

    ワードプレス形式のサイトで、SEO対策プラグインとしてAll in One SEOを使い始めました。
    その中の設定で、ホームの詳細とホームのキーワードを入力しているのですが、
    最終的に吐き出されたHTMLでは両方空白になってしまいます。
    呼び出しのコードは
    詳細
    <?php echo get_post_meta($post->ID, _aioseop_description, true); ?>
    キーワード
    <?php echo get_post_meta($post->ID, _aioseop_keywords, true); ?>
    としています。

    もしかしてプラグインが当サイトのホームをホームと認識せず空白になっているのかな、
    と考えているのですが、解決策が見つからず悩んでいます。

    どなたか心当たりがあれが教えてください。

    モデレーター gatespace

    (@gatespace)

    suzuki_showgunさん。
    このトピックスは既に「解決済み」のトピックスです。
    同じような質問の場合は、新しくスレッドを立ててください。
    (その際、このスレッドへのリンクを張ると○です)

    このフォーラムでは便乗質問はNGです。
    これはスレッドを立てた本人にしか「解決済み」にできないためです。
    便乗質問が解決されないといつまでも「解決済み」にできませんよね?
    また「解決済み」のスレッドもあまり目に止まらないうえ、
    一度解決したのですから、さらなる回答を得ることは難しいと思います。

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • トピック「topページのみAll in One SEO Pack の設定が読み込めない」には新たに返信することはできません。