サポート » バグ報告と提案 » Ver4.7.4で画像タグを挿入すると後の文章の一部が欠落する

  • 解決済 dreative

    (@dreative)


    バグの報告です。

    タイトルの通り
    Var 4.7.4で記事投稿のテキストモードで
    画像を挿入するとimgタグの後に続く文章の一部が欠落してimgタグが挿入されます。
    ver 4.7.3では同様の現象はみられませんでした。

    投稿画面にはTinyMCE Advancedのプラグインを使用していますが、
    TinyMCE Advancedがバージョンアップしていて、
    TinyMCE Advancedのバージョンアップ前とバージョンアップ後でも

    文章の一部欠落は治っていませんでした。
    一応WordPress側のバグとして報告させていただきます。

14件の返信を表示中 - 1 - 14件目 (全14件中)
  • CG

    (@du-bist-der-lenz)

    テキストモードでいくつか試しましたが、事象は確認できませんでした。

    返信ありがとうございます。

    当方でもテストで数行の文字数で画像を挿入した場合は、前述したような文章の欠落は発生しませんでした。
    当方のサイトは最低でも3000字程度は書いていて

    下書きで別のテキストに記事を書いておいてコピーアンドペーストで投稿画面にペーストしてから、記事を校正して投稿しています。

    その時例えば

    sounyuusuruimg.jpg
    その後文章がつづきます。
    これはテストです。

    <img src=”sounyuusuruimg.jpg”>文章がつづきます。
    これはテストです。

    というような感じで一部imgタグが、文章のいち部分に重なるようにimgタグが挿入されてしまいます。

    ちょっと文章では伝わりにくいかもしれませんが、上記のような現象が記事を投稿する際に毎回発生するという状況です。

    投稿画面に関係する使用しているプラグインは
    ・TinyMCE Advanced
    ・AddQuicktag
    ・AmazonJS
    です。ver 4.7.3までは上記のような現象は発生していませんでした。
    WordPress側の投稿画面で何か改良した時の不具合であると思うのですが。。

    現状ver4.7.4から4.7.5にverUPする時に改善されるのを期待するしかないのでしょうか?
    当方では欠落した部分を再度コピペしなおすことで対処療法していきます。

    投稿画面に関係する使用しているプラグインは
    ・TinyMCE Advanced
    ・AddQuicktag
    ・AmazonJS

    プラグインを導入されている、とのことですが、プラグインを停止した場合はどうなりますか?

    Fumito MIZUNO様

    返信ありがとうございます。
    Dreativeです。

    ・TinyMCE Advanced
    ・AddQuicktag
    ・AmazonJS

    上記プラグインを停止して
    3000字以上の長文になる過去の記事を新規作成で
    試しにコピーアンドペーストで、新規投稿画面にペースト後、
    挿入予定の画像を挿入したところ

    やはり文章の一部がimgタグに上書きされる状態で
    本文の一部が欠落してしまいます。
    テストに使用した記事本文の文字数は約5000字です。

    おそらく文字数が多い時、のjavascript関連の処理に問題があるように思います。
    画像挿入には「メディアを追加」ボタンでimgタグを挿入しております。

    テストの際には3000字以上の長文による文字数でテスト・検証していただけますでしょうか。
    よろしくお願いいたします。

    —————————————–
    問題の再現手順

    test.jpg
    これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。
    これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。
    これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。
    これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。
    これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。

    これは現象が発生した、記事の本文です。
    予め別テキストファイルに下書きしておいて新規投稿画面にペーストします。
    test.jpgは画像を挿入するためのファイル名でこれを切り取って「メディアを追加」から該当する画像をアップロードまたは選択してimgタグを挿入すると

    <img src=”test.jpg” />スト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。
    これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。
    これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。
    これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。
    これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。

    というようにimgタグが本文に重なるように挿入されてしまいます。
    このくらいの文章量でも再現しましたのでご連絡させていただきました。

    引き続き現象の検証をしていただけますと幸いです。
    よろしくお願いいたします。

    • この返信は2 ヶ月、 3 週間前に  dreative さんが編集しました。
    CG

    (@du-bist-der-lenz)

    WordPress 4.7.4、3,000文字の普通の文章で、新規にメディアを挿入の条件。
    結果、不便はありませんでした。

    既存記事にメディアを新規に挿入。
    http://broadway.woodstock.work/showcase/#attachment_2815

    1ページ2,000文字以内を文章の目安にしてますが、下書き保存なし未校正、テキストモードで3,000文字程度ほど直接入力、新たに創作したダミー記事に挿入。
    http://wp.me/p5XTd0-57

    CG様

    検証いただきまして、ありがとうございます。
    私のような現象の再現はありませんでしたか。
    本日も1記事投稿したのですが、
    画像タグもそうですが、amazonJSによる商品リンクタグも
    本文の一部に重なって文章が欠落事象が起きてしまいます。

    後考えられるのはテーマでしょうか。
    テーマはTCDのテーマを使用していて、テキストモードの時に
    テーマ独自のタグを挿入するボタンが増えているので、
    WordPress本体の投稿画面とテーマの相性が合っていない可能性があるのかもしれません。

    一度テーマを作成している会社の方へ問い合わせしてみます。
    検証いただきましてありがとうございました。

    このトピックは解決済みでは無く一度保留にしておきます。
    よろしくお願いいたします。

    CG

    (@du-bist-der-lenz)

    同現象はありませんでした。
    「テキストモードの時にテーマ独自のタグを挿入するボタンが増えている」というのが、どういうものかわかりませんが、何らかで挿入ポイントがずれているのではないかしら。

    わたしはTwentyFifteen( http://wp.me/p5XTd0-57 )で確認したわけですが、標準のテーマで確認願います。そこまでの切り分けをした上でないと、バグ報告といえません。
    公式ディレクトリのテーマでない場合、そのテーマが起因していれば、バグ報告は混乱のもととなるので、取り下げるべきと思います。

    返信ありがとうございます。
    dreativeです。

    テーマを別のものに変更して試してみましたが
    同様の現象が発生しました。

    現象が発生するポイントは

    test.jpg
    これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。
    これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。

    という文章を投稿画面にペーストしたとして
    test.jpgという文字列をマウスで選択して切り取った時状態で、
    メディアを追加でimgタグを挿入すると後ろの文章の一部が欠落します。

    test.jpgをバックスペース等で一文字づつ削除していってから
    メディアを追加でimgタグを挿入すると後ろに続く文章の欠落は発生しませんでした。

    追記
    上記のテスト文章を投稿画面にペーストして
    test.jpgをマウスで選択するとtest.jpgの後ろに半角スペースがあります。
    これを選択範囲に入れるか入れないかで
    文章の欠落の発生と未発生がおきます。

    —————————————————
    問題箇所わかりました。
    問題はブラウザのようです。
    問題が起きるのはChromeの最新バージョンで発生するようです。
    IE11で現象が発生するか試したところ現象は発生しませんでした。
    Chromeのみtest.jpgの文字列の後ろに半角スペースが発生します。

    使用環境
    Windows 8.1 64bit
    ブラウザ Chrome バージョン 58.0.3029.81【最新版】

    Chrome最新バージョンで検証していただますでしょうか。
    同様の方法で文章の欠落が発生しないかどうか検証していただけないでしょうか。
    それで現象が発生しないようでしたら問題を取り下げることにします。
    よろしくお願いいたします。

    • この返信は2 ヶ月、 3 週間前に  dreative さんが編集しました。
    • この返信は2 ヶ月、 3 週間前に  dreative さんが編集しました。
    • この返信は2 ヶ月、 3 週間前に  dreative さんが編集しました。
    CG

    (@du-bist-der-lenz)

    ブラウザにIE11を使って変更できたら、問題無いです。
    MacOSX上でのChromeでは問題ないため、Windows上でのChromeとWordPressの相性に課題がありそうです。わたしは20年間、Windowsは使った経験がないので検証しませんが、Windows上でのChromeとWordPressの問題は、2週間前に幾つかトピックが立っています。フォーラムを遡って確認ください。

    また、検証で作ったダミー記事は、長い文章は何かと不便なので通常の1投稿、1,000文字ベースに修正しました。

    こんばんは

    Windows 10 Chrome 58.0.3029.81(64-bit)で確認してみました
    – WordPress 4.7.4
    – Theme: Twenty Seventeen
    – 有効化プラグイン: WP Multibyte Patch 2.8.1

    test.jpg
    これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。
    これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。

    上記文章を新規投稿追加画面にてテキストモードで貼り付け後、

    1. test.jpg部分を選択
    2. Ctrl+Xでカット
    3. そのままの状態で(キャレット位置を変更せずに)「メディアを追加」ボタンにて画像タグを追加

    すると、確かに

    <a href="(略)"><img src="(略)" alt="(略)" width="(略)" height="(略)" class="(略)" /></a>章です。

    の様になるようです。

    test.jpg部分を選択→即画像挿入、や
    Ctrl+X後にテキストエリア内をクリック→画像挿入すると、
    (文章の欠落等も無く)問題無く動作するので気がつきにくいですが、なんらかの不具合があるようですね

    一度選択部分をカットしてからイメージ挿入で発生しますが、それは、Chrome バージョ
    ン 58.0.3029.81 (64-bit)での現象で、Chrome Canary バージョン: 60.0.3079.0(Official Build)canary (64 ビット)では発生しませんん。

    たまたま、同時期にWordPressとChromeのアップデートが重なったからでGoogle Chromeの問題でしょう。

    FireFox 54.0B1(64ビット)でも発生しませんね。

    Colorful-life様
    npssl様

    検証していただきましてありがとうございます。
    私と同様の現象が発生したこと承知しました。

    さて、私はWEBシステムの開発の現場から離れて久しいのですが、
    現在のWEBシステムの開発の現場では、今回のような問題が発生した場合はブラウザ側の問題にして終わりにしてしまうのでしょうか。
    私の頃はWEBシステムは MAC/Windows Chrome IE FireFox 等主要なブラウザで動作確認して
    その内一つでも意図しない動作が発生する場合は、WEBシステム側の問題であるとしてWEBシステムの改良を行っていました。

    今回は、WindowsでChromeの最新バージョンで特殊な操作をすることで不具合が発生する
    ということですが、これは正式にWordPress4.7.4の不具合として問題ないでしょうか。
    私としてはWindows版のChromeの使用シェアから考えて相当数の人がChromeブラウザを使用しているわけなので、これをChromeブラウザが最新版にアップデートしたからWordPressが正常に動作しないのは、Chromeブラウザが悪いで片付けるのはWEBシステム開発をしてきた人間としては納得できない部分があります。

    皆さんのご意見はどうでしょうか?
    皆さんのご意見を聞いてからこのトピックはクローズさせていただくことにします。

    よろしくお願いいたします。

    今回は、WindowsでChromeの最新バージョンで特殊な操作をすることで不具合が発生する
    ということですが、これは正式にWordPress4.7.4の不具合として問題ないでしょうか。
    私としてはWindows版のChromeの使用シェアから考えて相当数の人がChromeブラウザを使用しているわけなので、これをChromeブラウザが最新版にアップデートしたからWordPressが正常に動作しないのは、Chromeブラウザが悪いで片付けるのはWEBシステム開発をしてきた人間としては納得できない部分があります。

    個別の現象とは異なるトピックだと思いますので、
    本トピックはクローズして、
    別のスレッドを作成して議論したほうがよいと思いますが、いかがでしょうか。

    Fumito MIZUNO様

    返信ありがとうございます。
    今回の事象に関してWordPressコア開発陣に
    不具合報告することはできるのでしょうか?
    英語のサイトのWordPress.orgを見ても
    日本語サイトの同じようなフォーラムがあるだけで
    WordPressコア開発陣に不具合報告する手段がわかりませんでした。

    とりあえずこのトピックはクローズします。

14件の返信を表示中 - 1 - 14件目 (全14件中)
  • このトピックに返信するにはログインが必要です。