サポート » バグ報告と提案 » ver.4.5にアップグレードしたらメディアアップロードでHTTPエラー

  • 解決済 mitsu666

    (@mitsu666)


    いつもお世話になっております。

    ver.4.5にアップグレードした結果、
    メディアアップロードでHTTPエラーが出てアップロードできなくなりました。

    https://ja.forums.wordpress.org/topic/158985?replies=16
    こちらのページを拝見して
    class-wp-image-editor-imagick.php
    の書き換え、
    もしくは上書きを試したのですが
    症状は改善されず。

    サーバはxサーバを使っております。
    どうか有識者の方、ご教授ください。
    何卒よろしくお願いいたします。

7件の返信を表示中 - 1 - 7件目 (全7件中)
  • https://ja.forums.wordpress.org/topic/158985?replies=16
    こちらのページを拝見して
    class-wp-image-editor-imagick.php
    の書き換え、
    もしくは上書きを試したのですが
    症状は改善されず。

    1. 試した内容を具体的に教えていただけますか(「書いてあるとおり」ではなく)
    2. HTTPエラーの内容も詳しく教えてください。

    トピック投稿者 mitsu666

    (@mitsu666)

    gblsmさま

    ご返信ありがとうございます!
    返信が遅くなり申し訳ございません。

    >1. 試した内容を具体的に教えていただけますか(「書いてあるとおり」ではなく)

    && defined( 'Imagick::ALPHACHANNEL_UNDEFINED' )
    && defined( 'Imagick::ALPHACHANNEL_OPAQUE' )

    以上のように、class-wp-image-editor-imagick.phpの該当部分を書き換えました。

    >2. HTTPエラーの内容も詳しく教えてください。
    wpの付箋のようなダイアログが出て、

    img_teacher011.jpg
    HTTP エラー。

    と出てしまいます。
    おそれいりますがご教授いただけると助かります。

    mitsu666さん
    最初に報告があった https://ja.forums.wordpress.org/topic/158985?replies=16 とはエラーの内容が異なるので、もしかすると別の原因なのかもしれません。

    テーマやプラグインの影響があるかもしれないので確認のため、例えば Twenty Sixteen テーマ(カスタマイズなし)を有効にし、プラグインをすべて停止した状態で、もう一度メディアアップロードを試してみてください。

    トピック投稿者 mitsu666

    (@mitsu666)

    gblsmさま

    早速にありがとうございます。
    プラグインをすべて止め、
    テーマをオリジナルからデフォルトテーマへ変えてみましたが
    同じ現象にてアップロードできませんでした。。

    不思議です。

    トピック投稿者 mitsu666

    (@mitsu666)

    追記:
    アップローダーでアップロードを試したところ、

    Warning: require_once(/home/aaaaaaaa/wp-includes/class-wp-image-editor.php) [function.require-once]: failed to open stream: No such file or directory in /home/aaaaaaa/wp-includes/media.php on line 2886
    
    Fatal error: require_once() [function.require]: Failed opening required '/home/aaaaaaaa/wp-includes/class-wp-image-editor.php' (include_path='.:/usr/share/pear53') in /home/aaaaaaaa/wp-includes/media.php on line 2886

    というエラーが出てやはりアップされませんでした。
    なぜでしょう。。

    もしかするとWordPress 4.5へのアップグレードの時に、一部のファイルが更新されていないのかもしれませんね。管理画面からもう一度アップグレードしてみてはどうでしょう?

    トピック投稿者 mitsu666

    (@mitsu666)

    gblsmさま

    さっそく再アップロードいたしましたところ、

    Notice: add_object_page の使用はバージョン 4.5 から非推奨になっています! 代わりに add_menu_page() を使ってください。 in /home/aaaa/functions.php on line 3662
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/aaaa/wp-includes/functions.php:3662) in /home/aaaa/wp-includes/pluggable.php on line 1171

    以上のエラーが出ますが、
    メディア画面に戻りましたらアップされておりました!

    加えて、
    PS Taxonomy Expander
    というプラグインを停止したところ、
    まっしろだったメディアライブラリが復旧いたしました。
    ありがとうございます!

    だがしかし、
    PS Taxonomy Expander
    を停止してしまうと任意で順番が変えられないのでこまったことに。
    別のプラグインをさがしてみます。

    この度もありがとうございます!
    とても勉強になりたすかりました!
    ほっとしました。。

7件の返信を表示中 - 1 - 7件目 (全7件中)
  • トピック「ver.4.5にアップグレードしたらメディアアップロードでHTTPエラー」には新たに返信することはできません。