• wordpress4.7.2をインストール後、プラグインAddquicktagをインストールしたのですが、設定画面で【変更を保存】ボタンを押すと下記のエラーが出て変更ができません。

    –変更したい箇所–
    デフォルトのクイックタグを非表示にするにチェックを入れる。

    –エラーメッセージ–

    Fatal error: Uncaught Error: [] operator not supported for strings in /Applications/MAMP/htdocs/wordpressフォルダ名/wp-content/plugins/addquicktag/inc/class-settings.php:614 Stack trace: #0 /Applications/MAMP/htdocs/wordpressフォルダ名/wp-includes/class-wp-hook.php(300): Add_Quicktag_Settings->validate_settings(Array) #1 /Applications/MAMP/htdocs/wordpressフォルダ名/wp-includes/plugin.php(203): WP_Hook->apply_filters(Array, Array) #2 /Applications/MAMP/htdocs/wordpressフォルダ名/wp-includes/formatting.php(4286): apply_filters(‘sanitize_option…’, Array, ‘rmnlQuicktagSet…’, Array) #3 /Applications/MAMP/htdocs/wordpressフォルダ名/wp-includes/option.php(270): sanitize_option(‘rmnlQuicktagSet…’, Array) #4 /Applications/MAMP/htdocs/wordpressフォルダ名/wp-admin/options.php(219): update_option(‘rmnlQuicktagSet…’, Array) #5 {main} thrown in /Applications/MAMP/htdocs/wordpressフォルダ名/wp-content/plugins/addquicktag/inc/class-settings.php on line 614

    考えられる原因と対処法を教えてください。

    [モデレータより]
    「【重要】お読みください」フォーラムに投稿されていましたので、「プラグイン」フォーラムを移動しました。
    「【重要】お読みください」は、WordPress 日本語サイト運営チームから、みなさんへの連絡等に使用していますので、質問があっても回答がつかない場合があります。

    通常の質問は個別のフォーラムへ投稿してください。

    • このトピックは7年、 5ヶ月前にOkamoto Hidetakaが編集しました。理由: 「【重要】お読みください」フォーラムに投稿されていましたので、「プラグイン」フォーラムを移動しました。
12件の返信を表示中 - 1 - 12件目 (全12件中)
  • CG

    (@du-bist-der-lenz)

    こうした問題提議にはPHPバージョンがご利用環境情報として必須です。余計な推測を立てる無駄が出てくるので。

    確実はわかりませんがメッセージからは、変数の初期化が必要なのではないですか。
    PHP5.4から、[]による配列の初期化ができるようになりました。従来、PHPで配列を生成するにはarray()という関数を使用しなければなりませんでした。

    • この返信は7年、 5ヶ月前にCGが編集しました。理由: タイポを修正

    こんにちは

    php7.1を使っていないですか?
    もしそうなら、php7.0以前に変更してみてください。

    トピック投稿者 chaaanweb

    (@chaaanweb)

    ご回答ありがとうございます。
    PHP7.1になっていました。
    ダウングレードする方法がわからないので、よろしければ教えて頂けないでしょう?

    トピック投稿者 chaaanweb

    (@chaaanweb)

    ご回答、ご指摘ありがとうございます。
    以後、PHPのバージョンを記載するようにしたいと思います。
    配列の初期化は、私のスキルではむずかしいため、一旦PHPバージョンを確認してみたいと思います。
    それでも動作しなければ、初期化について検討したいと思います。

    CG

    (@du-bist-der-lenz)

    PHPバージョンの選択は、MAMPの環境設定で選択できます。

    トピック投稿者 chaaanweb

    (@chaaanweb)

    度々ご返信ありがとうございます。
    MAMPの設定→PHPに<php7.1.0>と<php7.0.13>があるため<php7.0.13>を選択してOKボタンを押すのですが、
    変更されません。。

    MAMP>bin>phpフォルダで、<php7.1.0>フォルダ名を変更したら、以下のメッセージが出て変更ができません。


    Apache couldn’t be started. Please check your MAMP installation and configuration.

    どこか間違っているのでしょうか?

    CG

    (@du-bist-der-lenz)

    落としてみるとしたなら、5.6 が無難かと思います。
    https://www.mamp.info/en/downloads/

    トピック投稿者 chaaanweb

    (@chaaanweb)

    度々ご返信ありがとうございます。

    5.6も落としたのですが、以下のメッセージが出て変更ができません。


    Apache couldn’t be started. Please check your MAMP installation and configuration.

    サーバの起動を一旦終了し、現在のphp7.1.0のフォルダ名を_php7.1.0と変更して、再度起動しているのですが、
    うまくいかないです。。

    もしどこか間違っているのでしたら、ご教示いただけませんか?

    CG

    (@du-bist-der-lenz)

    MacOSX自体のApacheもリブート必要ありますよ

    MAMPのログを確認してみてはどうでしょうか?
    以下にあるようです。
    /Applications/MAMP/logs/apache_error.log
    他にもApacheのログファイルがあるようでしたら、見てみたら良いかもしれません。

    @du-bist-der-lenzさん

    >> MacOSX自体のApacheもリブート必要ありますよ

    知らないので教えて欲しいのですが、Mac OS XのApacheとMAMPのApacheは別のインスタンスではないのでしょうか?
    ポート番号が同じなら一方は起動できませんし、ポート番号が異なるのならそのポートを占有している方のインスタンスが使われると思うのですが・・・

    どちらかをリバースプロキシとして使用している場合にも、phpを呼び出すように定義されている、どちらか一方のApacheを再起動すれば良いように思いますが、違いますでしょうか?

    トピック投稿者 chaaanweb

    (@chaaanweb)

    度々ご教示頂きありがとうございます。

    ターミナルを起動し、Apacheの再起動も行いましたが、
    やはりPHPのバージョンを変更できませんでした。

    以下の手順で行いました。
    MAMPサーバを停止→Apache再起動→MAMP設定からPHPバージョンを変更→PHPinfoを確認
    →バージョンが変更されていない。。。
    という状況です。

    どこか間違っている箇所がありましたらご指摘頂けませんか。

    トピック投稿者 chaaanweb

    (@chaaanweb)

    ご返信ありがとうございます。

    エラーログを確認しました。
    何かエラーが出ているようですが、内容を理解できません。。
    もし、何か分かるようでしたら、ご教示いただけませんでしょうか。

    <エラーメッセージ(/Applications/MAMP/logs/apache_error.log)>

    [Thu Feb 02 22:58:00 2017] [notice] caught SIGTERM, shutting down
    [Thu Feb 02 23:00:32 2017] [notice] Digest: generating secret for digest authentication …
    [Thu Feb 02 23:00:32 2017] [notice] Digest: done
    [Thu Feb 02 23:00:32 2017] [notice] FastCGI: process manager initialized (pid 57248)
    [Thu Feb 02 23:00:32 2017] [notice] Apache/2.2.31 (Unix) mod_wsgi/3.5 Python/2.7.12 PHP/7.1.0 mod_ssl/2.2.31 OpenSSL/1.0.2j DAV/2 mod_fastcgi/2.4.6 mod_perl/2.0.9 Perl/v5.24.0 configured — resuming normal operations
    [Thu Feb 02 23:00:42 2017] [notice] caught SIGTERM, shutting down
    [Thu Feb 02 23:00:50 2017] [notice] Digest: generating secret for digest authentication …
    [Thu Feb 02 23:00:50 2017] [notice] Digest: done
    [Thu Feb 02 23:00:50 2017] [notice] FastCGI: process manager initialized (pid 57297)
    [Thu Feb 02 23:00:50 2017] [notice] Apache/2.2.31 (Unix) mod_wsgi/3.5 Python/2.7.12 PHP/7.1.0 mod_ssl/2.2.31 OpenSSL/1.0.2j DAV/2 mod_fastcgi/2.4.6 mod_perl/2.0.9 Perl/v5.24.0 configured — resuming normal operations
    [Thu Feb 02 23:00:58 2017] [error] [client ::1] File does not exist: /Applications/MAMP/htdocs/docs-assets, referer: http://localhost:8888/MAMP/?language=Japanese

12件の返信を表示中 - 1 - 12件目 (全12件中)
  • トピック「wordpressのプラグインAddquicktag設定エラーについて」には新たに返信することはできません。