サポート » 使い方全般 » wordpressをバージョンアップ後も旧エディタのままについて

  • 解決済 kenjis1969

    (@kenjis1969)


    こんばんは、トピックタイトルの通りなんですが、Wordpressを更新しても旧エディタのままです。
    4つのサイトのうち他の3つは全てGutenbergに移行したのですが、1つだけ全くの旧エディタのままなのです。

    旧エディタで作ったページをGutenbergに移行後に編集しようとすると、Gutenberg内で旧エディタが使える、と言うのとは違い、どこをどう見ても全くの旧エディタのままなのです。

    現在のWordpressバージョンと使っているプラグインはこちらです。

    wordpressのバージョンは5.0.2–ja

    プラグイン
    Akismet
    Breadcrumb NavXT
    Comet Cache
    Jetpack by WordPress.com
    Login No Captcha reCAPTCHA
    MetaSlider
    Search Regex
    SiteGuard WP Plugin
    WP Multibyte Patch
    WP-PageNavi
    WPtouch Mobile Plugin
    Yoast SEO

    ちなみに
    プラグインは全て無効化してみました⇒変化なし

    ダッシュボード以下、他のサイトと、どこかに違いがないか調べてみましたが、特に変わっているところはありませんでした。

    キャッシュやクッキーも一応削除してみました。

    FTPから他のサイトと違いがあるかフォルダの中身を確認してみましたが、特にこれと言ったものは見受けられませんでした。

    実は5.0へアップ後には気づいていたのですが、5.0.2が出るときに解決するでしょっ・・・ってお気楽に考えていたんですが、現在に至るまで原因もわからず解決法もわからずじまいです。

    どなたか原因と解決方法ご存じないですか?

    ここでだめならいよいよ、一旦サーバを綺麗にしようとも考えています。

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • CG

    (@du-bist-der-lenz)

    4つのサイトは同一環境のようですね。更新時に使用中のプラグインが有効になったままだったってことはないですか。

    DRILL LANCER

    (@rickaddison7634)

    設定→投稿設定ユーザー→あなたのプロフィールを確認してみてください。

    • この返信は3年、 5ヶ月前にDRILL LANCERが編集しました。
    CG

    (@du-bist-der-lenz)

    間近のトピックですから、確認はしていますよね。

    スレッド開始 kenjis1969

    (@kenjis1969)

    ビジュアルリッチエディターを使用しない 

    にはチェックが入っていない状態です。
    他のサイトのものも確認しましたが、同じように入っていない状態です。

    更新時に使用中のプラグインが有効になったままだった

    確かにそれはありますが、更新時の条件は全てのサイトで同じです。
    どのサイトも更新時、すべてのプラグインが有効になったままです。

    プラグインされているものが、それぞれのサイトで若干違うものを使っていることもありますが、すべて無効にしても変化はありませんでした。

    Wordpress更新時も特に問題なく更新が終了しましたし、この旧エディタがGutenbergになっていないということ以外は、ログインができないとか、管理画面に入れないとか、記事を上手く公開できないとか、一度上げた記事を編集できないとか、全く何も不具合が起きていません。

    バックアップはあるので、最悪、一度全てを白紙に戻してしまうのもありかなと思ってはいますが、前回Sightguardが原因でログインできなくなった時も数日して有効化したら、何の問題もなく使えてたと言う事もあるので、もう少し様子を見て改善されないようであれば、サーバから全て削除して一から作り直してみようと思います。

    DRILL LANCER

    (@rickaddison7634)

    私の環境では「Classic Editor」をインストールして有効化しているので
    設定→投稿設定

    すべてのユーザーのデフォルトエディター	
     ◉クラシックエディター
     ○ブロックエディター
    
    ユーザーにエディターの切り替えを許可します。	
    ◉はい
    ○いいえ

    の項目が表示され、「ユーザーにエディターの切り替えを許可します。」をはいにすると
    ユーザー→あなたのプロフィール

    エディター	
    ◉クラシックエディター
    ○ブロックエディター

    が表示されます。
    「Classic Editor」をインストールして削除したり、
    「Classic Editor」をインストールして「ブロックエディタ」を選択したりするという手もあるかもしれません。

    スレッド開始 kenjis1969

    (@kenjis1969)

    おはようございます。

    設定→投稿設定に『すべてのユーザーのデフォルトエディター』と言う項目が見当たりません。
    たぶんClassic Editorをプラグインしてないからだと思いますが・・・

    念のため、参考までに・・・
    投稿設定に表示されている項目は

    ・フォーマット
    ・投稿用カテゴリーの初期設定
    ・デフォルトの投稿フォーマット
    ・リンクカテゴリーの初期設定

    でも『Classic Editor』をプラグインすることで選択できるようになるんですね・・・
    それちょっとやってみます。
    ありがとうございます。

    スレッド開始 kenjis1969

    (@kenjis1969)

    こんにちは

    まず、結果から言いますと、『Classic Editor』をプラグインすることでブロックエディターに切り替えることはできました。
    その後、一旦『Classic Editor』の無効化やアンインストールなどを試してみましたが、『Classic Editor』が有効でブロックエディターでない場合は、クラシックエディターに戻ってしまうようです。

    本来Wordpress5.0.2であれば、『Classic Editor』のプラグインを必要とすることなくブロックエディターが使える・・・と認識しています。
    いまいち釈然としませんが、今はこれでも良いと思います。

    そのうちバグか何か見つかって修正されるのか、バージョンアップを重ねていくうちに、こちらのサーバに入っているどこかおかしな場所が改善されるのか・・・
    おそらく4つのうちの1つだけがおかしいと言う事は、どこか設定が他の3つと違うかサーバ内で何かおかしなことになっているんじゃないかとは思うのですが・・・

    現在、4つのサイト全て同じサーバで同じ環境で動いています。サーバもWordpressも設定がそれぞれ同じ(のはず・・・)ですが、一点だけ違うことがありました。
    4つのサイトは、それぞれ違う時期に立ち上げているため、最初にインストールしたバージョンが全て違うことです。
    そのため、サーバ内に作られているフォルダに若干の違いがあります。
    一番古いもので2012年で2.7くらいだったと思います。最新のものでは2018年で今回問題があるのは2013年のものです。詳しいバージョンはいまここではFTPがないのでわからないのですが・・・

    今回も原因特定には至らずの結果報告で申し訳ありませんが・・・問題も根本的な解決にはなっていませんが、今回はこれにて・・・

    CG

    (@du-bist-der-lenz)

    バージョンを重ねているといっても系統ごとに特徴が違いますから、どのエディションからスタートしているのかって、大きいところだと思いますよ。3系からアップした4系では、4系で廃止されたリンク機能が継承されていましたね。4.9系でグーテンベルクプラグインをインストールしていた場合、WordPress5への更新で、グーテンベルク設定が吸収されていないことからも、思えています。「データベースを更新します」、となるもの、ならないものも現時点まででありました。年末年始の期間に、サイトの半分ぐらいはWordPress5に更新する予定なので、5つのサーバーに渡っているので統計にはなりませんが、20サイトで違いをパターン化できる期待は抱いてます。

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • トピック「wordpressをバージョンアップ後も旧エディタのままについて」には新たに返信することはできません。