サポート » 使い方全般 » wordpressを専用ディレクトリに配置後エラーが表示されサイトが表示されな

  • beginer2012

    (@beginer2012)


    「WordPress を専用ディレクトリに配置する」http://wpdocs.sourceforge.jp/Giving_WordPress_Its_Own_Directoryの中段の「既存のサブディレクトリをルートディレクトリとして表示する場合」に従い作業後、改めてwordpressにログインしホームページを表示しようとしたら下記のエラーが出てブログが表示されなくなりました。
    <エラー>
    エラー画面というよりも、site0001/index.phpに書かれた内容が表示されています。

    /** * Tells WordPress to load the WordPress theme and output it. * * @var bool */ define(‘WP_USE_THEMES’, true); /** Loads the WordPress Environment and Template */ require(‘./site0001/wordpress/wp-blog-header.php’); ?>

    かなり調べたのですが、問題点がわかりませんでした。アドバイスをお願いします。

    作業前の設定等
    【wordpressのインストール先】http://cz.com/site0001/wordpress
    【移動後のホームページ】http://cznihonjinkai.com/site0001
    ※site0001にbasic認証を設定しています。

    作業手順は以下のとおりです。

    1. 管理画面 > オプション > 一般設定 にて、「サイトアドレス(URL)」をhttp://cznihonjinkai.com/site0001に変更(/wordpressを削除)>変更を保存>ログアウト
    2. site0001/wordpress/index.php, site0001/wordpress/.htaccess の2つをでs区トップにコピーしffftpでsite0001の下にコピー。
    3. 2でコピーしたsite0001/index.pspの書きかえ。変更前require(‘./wp-blog-header.php’); 変更後require(‘./site0001/wp-blog-header.php’);
    4. site0001/wordpress/wp-config.phpを切り取りsite0001の下にペースト。
    5. site0001/.htaccessを更新。
    6. 再度wordpressにログイン>サイトを表示>上記のエラー画面が表示された
    7. 以上です

1件の返信を表示中 - 16 - 16件目 (全16件中)
  • トピック投稿者 beginer2012

    (@beginer2012)

    その後について同様の問題で悩む方に参考になるかもしれないのでご報告いたします

    最終的に、もうひとつWPをインストールしてデータを少し入れた段階で専用ディレクトリへの配置を試みたところうまくいきました。
    複雑な事は試さずに、まずは新しいディレクトリにブログを直接作り直す事にしました。

    きっと、一番最初に投稿した「作業手順」の2で.htaccessをコピーしたのが間違いだったとおもいます。Pretty permalinkを使っていないにも関わらず、basic認証で使っていた.htaccessをエディタでなくノートパッドで開いたのがいけなかった気がします。今回はindex.phpのコピペと書き直しのみでうまく行きました。

1件の返信を表示中 - 16 - 16件目 (全16件中)
  • トピック「wordpressを専用ディレクトリに配置後エラーが表示されサイトが表示されな」には新たに返信することはできません。