サポート » 使い方全般 » WordPressインポート時の予期せぬエラーへの対処

  • 解決済 akausagi

    (@akausagi)


    WordPress半年の初心者です。localhostにて構築しています。

    この度、XAMPPのバージョンを1.8.1から1.8.3に上げようと、XAMPP1.8.1でエクスポートしたデータをXAMPP1.8.3でインポートしたところ、「予期せぬエラーが発生しました。WordPress.org かこのサーバーの設定で何かがうまくいっていないようです。この問題が引き続き発生するようならフォーラムで相談してみてください。」というメッセージが出ました。

    ◆実施環境
    ・同一PCにてXAMPPのバージョンアップを実施
    ・バージョンアップに伴うApacheなどのport番号に変更なし

    ◆これまでの確認事項
    1.過去のフォーラム記事を参考に、アップロードファイルサイズなど変更しましたが解決せず。
    2.リネームして保存していたXAMPP1.8.1に戻して、エクスポートしそのままインポートしましたが同じエラー表示。

    という状況で困っております。

    対処のアドバイスをいただきたく、宜しくご教示のほどお願い申し上げます。

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • nobita

    (@nobita)

    こんにちは

    「予期せぬエラーが発生しました。WordPress.org かこのサーバーの設定で何かがうまくいっていないようです。この問題が引き続き発生するようならフォーラムで相談してみてください。」

    とのことですが、WordPressのバージョンが、3.6.1ではなく、3.7ということはありませんか?

    トピック投稿者 akausagi

    (@akausagi)

    ダッシュボードの「現在の状況」に「WordPress 3.6.1 を使用中」と表示されています。
    他にも足りない情報あればお知らせください。

    お手上げ状態ですので、ご教示宜しくお願いします。

    ◆追加確認事項
    3.XAMPP1.8.3で、エクスポートしそのままインポートしましたが同じエラー表示。

    以上

    nobita

    (@nobita)

    開発版を使っている場合は、3.7の初期のベータ版は、3.7でもWordPress 3.6.1と表示されます。

    ベータ版使っていませんか? ベータテスタープラグインとか

    トピック投稿者 akausagi

    (@akausagi)

    nobita様、引き続きのサポート感謝します。
    宜しくお願いします。

    > ベータ版使っていませんか?
    XAMPP1.8.3インストール続いてWordPressをインストールしました。この時、WordPressのバージョンは意識しませんでした。結果、ダッシュボード>更新で確認すると
     最新バージョンの WordPress をお使いです。
     WordPress 3.6.1 について詳細を読む
     プラグイン
     プラグインはすべて最新版です。
     テーマ
     お使いのテーマはすべて最新版です。
    と表示される状態です。
    ●WordPressのバージョンを確認する方法をご教示ください。

    > ベータテスタープラグインとか
    インストール済みのプラグインは以下の4本です。
     Akismet バージョン 2.5.9
     File Gallery バージョン 1.7.7
     Hello Dolly バージョン 1.6
     WP Multibyte Patch バージョン 1.7
    全て「停止」して再度トライしましたが、結果は同じエラーでした。

    ●エクスポート、インポートは下記手順で宜しいでしょうか?(念のため確認)
     (1) ツール>エクスポート画面で、「全てのコンテンツ」選択肢「エクスポートファイルをダウンロード」する。
     (2) インポートは、ツール>インポート画面で、「WordPress」をクリックする。

    以上

    nobita

    (@nobita)

    エラー文の原文は、

    An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the <a href=\"http://wordpress.org/support/\">support forums</a>

    なんですが、includes/plugin-install.php,includes/theme.php で themes_api()
    plugins_api()内に記述されています。

    ベータ版で、3.7にアップデートしたのにバージョン3.6.1になっていたものは、現在手持ちにないので、確認できません、

    3.6.1でも、3.7でも、このエラーメッセージは、存在するようです。(全文検索してみました、3.7は公開版)

    プラグインで、テーマAPIを使っているかどうかは、調べていませんが、メッセージはそこにしかないので、たぶん使われているということだと思います。

    体験的に、この問題が起きたとき(3.7でテーマやプラグインのアップデートで)の対処は、

    Windows local は、Opensslのインストールと、mod_sslの有効化、で正常に動くようになりました

    共有サーバで起きたもの(xrea.comは駄目 coreserverは、OK)は、手間をかけたくないので、3.6.1にダウングレードして、動いています。

    様子見用に、3.7のエラーが出るやつもひとつ置いている状態です。

    トピック投稿者 akausagi

    (@akausagi)

    > Windows local は、Opensslのインストールと、mod_sslの有効化、で正常に動くようになりました
    下記サイトに関連する(しそうな?)記事を見つけました。
     http://thinkit.co.jp/free/article/0706/3/7/
    これを理解して、Apacheのインストールからやり直すということでしょうか?

    同サイトに関連記事がたくさんあるので「Apache+SSL環境構築」について調べます。
    他にも、参考になる初心者向けサイトあればお知らせください。

    以上

    トピック投稿者 akausagi

    (@akausagi)

    追伸です。

    > Windows local は、Opensslのインストールと、mod_sslの有効化、で正常に動くようになりました
    XAMPP Control PanelでApacheのConfigのApache(httpd-ssl.conf)を編集して有効化するのでしょうか?
    修正箇所を具体的にご教示いただければ助かります。

    下記サイトの記事は07年と古いので、最新の記事を探してみます。
    > 下記サイトに関連する(しそうな?)記事を見つけました。
    >  http://thinkit.co.jp/free/article/0706/3/7/

    以上

    トピック投稿者 akausagi

    (@akausagi)

    nobita様、下記の通り”解決”できました。
    お忙しい中ご対応くださりありがとうございました。
    以下の通り、まとめさせていただきました。

    ◆現象
     XAMPPのバージョンを1.8.1から1.8.3に上げようと、XAMPP1.8.1でエクスポートしたデータをXAMPP1.8.3でインポートしたところ、「予期せぬエラーが発生しました。WordPress.org かこのサーバーの設定で何かがうまくいっていないようです。この問題が引き続き発生するようならフォーラムで相談してみてください。」というメッセージが出た。
     
    ◆原因
     イントラネット内のWordPressサーバーがプラグインファイルをインターネットからダウンロードできなかったことによる。
     (初めてインポートする時に、WordPressのサーバーがプラグインファイル「WordPress Importer」をインターネットからダウンロードすることを知りませんでした。)

    ◆対処
     いつも(ローカルホスト環境でプラグインをインストールする時)と同様、プラグインのzipファイルをダウンロードしてから、zip形式のプラグインをアップロードする方法でインストールした。

    ◆結果
     XAMPP1.8.1でエクスポートしたデータをXAMPP1.8.3でインポートできた。

    ◆参考
     WordPress のインポートツールでエラーが発生する時の対処方法

    以上

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • トピック「WordPressインポート時の予期せぬエラーへの対処」には新たに返信することはできません。