サポート » 使い方全般 » WordPress の新しいバージョンのやり方

  • sss21145

    (@sss21145)


    いつもお世話になっております。
    昔のサイトを復活させようとしているのですが、WordPressを更新させようとすると

    WordPress 5.9.2 は PHP 5.6.20 以降を必要とするため、更新を実行できません。現在稼働しているバージョンは 5.2.17 です。

    のような文章が出てきて更新できません。
    サーバーはサクラのレンタルサーバーさんです。
    「スクリプト設定」→「言語のバージョン設定」でPHPのバージョンを新しくしたらWordPressの管理画面やH
    Pにエラーが出て見れなくなってしまいます。
    どのようにしたら良いでしょうか?
    宜しくお願いいたします。

1件の返信を表示中 - 1 - 1件目 (全1件中)
  • @sss21145 さん、こんにちは。

    少し多忙でフォーラムから離れていました。解決済みでしたらごめんなさい。

    もうひとつのスレッドで古いサイトを立ち上げなおしているという事だったかと思います。
    まずは、WordPress を最新にする必要がありますが、それには PHP も最新にする必要があると思われます。
    ご存じの通り、さくらのレンタルサーバーでは PHP のバージョンも変更できますので、可能であれば以下の手順にて試してみてください。

    1.前回のスレッドでプラグインの個別のフォルダのリネームを行ったと思いますが、同じ方法で、ひとつ上の「plugins」というフォルダを例えば「plugins_」などにリネームを行います。
    これですべてのプラグインが無効化できるはずです。

    2.次にさくらのレンタルサーバーの管理画面にアクセスし、PHP のバージョンを最新版に変更します。

    3.最後に WordPress の管理画面にアクセスし、WordPress のバージョンを最新版にアップデートしてみてください。

    もし3の管理画面にアクセスできない場合は、もうひとつのスレッドで munyagu さんが教えてくれている参考ページを見て最新の WordPress で更新してみてください。

    ご参考になれば。

1件の返信を表示中 - 1 - 1件目 (全1件中)
  • このトピックに返信するにはログインが必要です。