サポート » 使い方全般 » WordPress 3.3.1サイトの引っ越し

  • 解決済 harazaki

    (@harazaki)


    古いWordPress 3.3.1で作られたブログをPHP5.2(CGI版)で運営しています。
    サーバーはロリポップです。

    PHP7.3(モジュール版)にバージョンアップしたところ、当然ブログはまったく表示されなかったので、ロりポップに言って元のPHP5.2(CGI版)に戻してもらい、現在は表示されており更新も可能です。

    これを何とかしてPHP7.3(モジュール版)にバージョンアップした上で、Wordpressも最新のWordPress 5.3.2にバージョンアップしたいのですが、どうすればよいのでしょうか?^^;
    現在は以下のように警告されていまして、更新はできない状態です。

    「WordPress 5.3.2 は PHP 5.6.20 以降を必要とするため、更新を実行できません。現在稼働しているバージョンは 5.2.17 です。」

    ちなみに同じサーバー内にPHP7.3(モジュール版)で動かしているWordPress5.1.3で作ったブログがあるのですが、もしこちらに丸々引っ越しする方が楽なのであれば、それでもいいと考えています。

    しかし、その場合、PHP5.2(CGI版)上で動いているWordPress 3.3.1で作られたブログのデータベースからエクスポートしたものは、PHP7.3(モジュール版)上で動いているWordPress5.1.3にすんなり移せるものなのでしょうか?

    手順や気をつけることがあれば教えていただけませんか?
    よろしくお願いいたします。

    • このトピックはharazakiが7ヶ月、 3週前に変更しました。
6件の返信を表示中 - 1 - 6件目 (全6件中)
  • DRILL LANCER

    (@rickaddison7634)

    安全にPHPをバージョンアップするための基本手順

    上記の記事の通りに作業を行えばできると思います。

    ありがとうございます。
    しかし、ご紹介いただいたサイトにある事はすでに行っておりまして、結果は先に書きました通りです。

    要はサーバーがPHP5.2(CGI版)なのでWordPress3.3.1のこれ以上のバージョンアップができないんです。(今の環境だとwordpressの更新が実行できない)

    最新のWordPress5.3.2はPHP5.6.20以降を必要とするようなのですが、ロリポップは現在のPHP5.2以外だとPHP7.2、もしくはPHP7.3にしか上げることができないんです。
    PHP5.6にすることができれば、何とかなりそうなのですが。。。

    DRILL LANCER

    (@rickaddison7634)

    下記手順でいかがでしょうか?

    1. 事前にバックアップを取っておく
    2. プラグインを無効化しておく(余計なエラーの発生を防ぐため)
    3. とりあえず PHP を 7.3 にしてみる
    4. WordPress本体・テーマ・プラグインをアップデート
    5. PHP バージョンの互換性を確認し、対応していないものは代替を探す or 切り捨てる
    6. 一つづつプラグインを問題が発生しないか確認しながら有効化していく
    • この返信は7ヶ月、 2週前にDRILL LANCERが編集しました。
    • この返信は7ヶ月、 2週前にDRILL LANCERが編集しました。

    ありがとうございます。

    PHP7.3にバージョンアップしてサイトが表示されなくなった際に、FTPですべてのプラグインのパーミッションを000にしてみたのですが、やはり表示されませんでした。
    テーマはPHPをバージョンアップする前にwordpressの標準テーマに切り替えてあります。

    つまり、プラグインやテーマがPHP7.3では動かないのではなく、WordPress3.3のシステム本体が古過ぎて、PHP7.3では動かない(=つまり管理画面に入れないわけなので、wordpressのバージョンアップさえできないという事)ということはないですかね?

    ちなみに、PHP7.3にバージョンアップしたあとに、サイトにアクセスすると次のような一文が真っ白い画面に表示されていました。

    「お使いのサーバーの PHP では WordPress に必要な MySQL 拡張を利用できないようです。」

    これ何か関係ありますかね~?

    DRILL LANCER

    (@rickaddison7634)

    つまり、プラグインやテーマがPHP7.3では動かないのではなく、WordPress3.3のシステム本体が古過ぎて、PHP7.3では動かない(=つまり管理画面に入れないわけなので、wordpressのバージョンアップさえできないという事)ということはないですかね?

    おおいにあり得るので手動更新で WordPress を更新するのも手かもしれません。

    「お使いのサーバーの PHP では WordPress に必要な MySQL 拡張を利用できないようです。」

    現状 お使いのプランでは PHP 7.3 で WordPress のサイトを作成するのに向いていない可能性があります。PHP 7.2 を選択してみてください。

    • この返信は7ヶ月、 2週前にDRILL LANCERが編集しました。

    結局、手動でwordpressのバージョンを3.2から5.14まで上げたあと、PHP7.3にアップグレードしたら、何ら問題はありませんでした。
    ありがとうございました!

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • トピック「WordPress 3.3.1サイトの引っ越し」には新たに返信することはできません。