サポート » インストール » WordPress 5.1.1の更新について

  • 解決済 udaike

    (@udaike)


    初めて投稿させて頂きます。

    現在、WwordPress5.1.1をインストールしてあるのですが、WordPressの更新画面で5.2.1へ更新しようとすると
    「WordPress 5.2.1 は PHP バージョン5.6.20以上が必要なため、更新できません。現在の PHP バージョンは5.2.17です。」
    と表示されて更新できません。

    phpinfo()でphp情報を確認すると、PHPバージョン7.1.5となっています。

    どのような手順で挑めば、更新できるようになるかご教示いただければ幸いです。

    ロリポップのサーバーでwordpress簡単インストールしました。

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • CG

    (@du-bist-der-lenz)

    間近のトピックでもあることですし、読もうとしなかったはずはないでしょうが、「phpバージョンをあげたがWP管理画面ではあがっていないことになる」とは違うという主張でしょうか。

    CG様

    お忙しい中、早々のご指摘ありがとうございます。

    私も確認可能な範囲で上位ディレクトリィにある.htaccess設定内容を確認してみましたが、該当する記述は無いようでした。

    また、wp-admin内には、.htaccessは存在していませんでした。

    サーバー運営サポートに問い合わせしましたが、phpinfo()でバージョン確認するように回答をいただいたのみで、止む無く、本フォーラム内の似ている事例を探してみましたが、自分では解決できずに、投稿させていただいた次第です。

    状況説明が足りず申し訳ありません。何卒、よろしくお願いします。

    ロリポップはドメイン別にバージョンを指定できるようですが、同一ディレクトリに別ドメイン(初期ドメインとか)が割当られているとかは無いのですか?

    npssl様

    お忙しい中、ご対応ありがとうございます。

    今回は、ディレクトリを作成してサブドメインとして新たにwordpressをインストールしています。

    ルートディレクトリにもwordpressをインストールして運用していますので、それが影響している可能性があるということでしょうか。

    貴重なご指摘ありがとうございます。調べてみます。

    ロリポップの管理画面でドメインごとにphpバージョンを設定する事ができます。

    今回、新たにwordpressをインストールしたサブドメインのみphpバージョンを7.1に設定していました。

    npss様にご指摘頂きましたことから、全てのドメインについてphpバージョンを7.1に設定変更してみたところ、phpversion()でも7.1を認識できてWordPress5.2.1に更新できました。

    本スレッドに関わってくださった皆様、ありがとうございました。

    CG

    (@du-bist-der-lenz)

    「ディレクトリを作成してサブドメインとして新たにwordpressをインストールしています。」ということ、その「ルートディレクトリにもwordpressをインストールして運用しています」ということで、入れ子になっているのでしょうね。その場合では、ルートディレクトリの設定の支配下になるでしょうね。

    CG様

    ありがとうございます。

    「ルートディレクトリの設定の支配下になるでしょうね。」とのこと。

    どうも、そのようかと思います。

    サブドメインも個別にPHPバージョンの設定が可能になっていたので、何のための個別設定なのか疑問が残るところですが、今回の問題につきましては、解決となりました。

    ちなみに、不具合発生時にサブドメインでphpinfo()を見てみると、7.1になっていたので、phpinfo()とphpversion()とで相違発生する場合があることが分かりました。

    CG

    (@du-bist-der-lenz)

    WordPressをインストールしているディレクトリに、サブドメインとして新たにWordPressをインストールすることは、考えにありませんでした。ロリポップでは同一ディレクトリにサブドメインサイトを作ることができるんですね。勉強になりました。ありがとうございます。

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • トピック「WordPress 5.1.1の更新について」には新たに返信することはできません。