サポート » インストール » WordPress2.8へアップデート後のエラー

  • 解決済 pienimyk

    (@pienimyk)


    ダッシュボードのメッセージにつられて、2.8にアップデートしたのですが、カテゴリーとタグを表示させていたサイドバーに

    Warning: implode() [function.implode]: Bad arguments.
    in /自分のサイトのパス/wp-includes/taxonomy.php on line 778

    と表示されてしまいました。
    該当部分(taxonomy.php内)には

    $select_this =
    implode(', ', apply_filters( 'get_terms_fields', $selects, $args ));

    とありましたが、分からない為、前のVer(2.7.1)のtaxonomy.phpにしたところ、解消されました。このエラーは私が使っていた日本語版の2.7.1を英語対応の2.8にアップした事が原因でしょうか?
    2.7.1のtaxonomy.phpで動作には特に支障無いように感じますが、心配なので投稿しました。ご存知の方がおられましたら教えて下さい。

2件の返信を表示中 - 1 - 2件目 (全2件中)
  • スレッド開始 pienimyk

    (@pienimyk)

    追記です。
    先ほど、日本語版の2.8をダウンロードし、taxonomy.phpをアップしたところ、英語版と同じエラーが出ました。
    themeの問題かと思い、デフォルトのthemeにしてみたのですが、同じです。

    ※管理人様
    「インストール」に投稿しましたが、「使い方全般」の方が適切かもしれません。。ご面倒でなければトピックスを移動して頂ければ・・と思います。

    スレッド開始 pienimyk

    (@pienimyk)

    一応、自己解決しました。
    詳細は不明ですが、使っているプラグインが原因の様です。
    Language Switcher1.1.8を使用停止にしたところ、WP2.8日本語版のtaxonomy.phpエラーが無くなりました。Language Switcherの作者サイトを確認すると、Language Switcher1.20(WP2.8対応)と言うのがあったのでこちらを使用したら解消しました。お騒がせしました。

2件の返信を表示中 - 1 - 2件目 (全2件中)
  • トピック「WordPress2.8へアップデート後のエラー」には新たに返信することはできません。