サポート » プラグイン » WordPress3.1にアップグレード後、All in One SEO Packにエラーが出る

  • 解決済 ys8

    (@ys8)


    「重大なエラーを引き起こしたため、プラグインを有効化できませんでした。」
    Fatal error: require_once() [function.require]: Failed opening required ‘/var/www/vhosts/ドメイン名/httpdocs/wp-content/plugins/all-in-one-seo-pack/aioseop.class.php’ (include_path=’.:’) in /var/www/vhosts/ドメイン名/httpdocs/wp-content/plugins/_all-in-one-seo-pack/all_in_one_seo_pack.php on line 488
    と出ます。

    all_in_one_seo_pack.phpの488行目は
    require_once( WP_PLUGIN_DIR . '/all-in-one-seo-pack/aioseop.class.php');
    でした。

    他のプラグインを無効にし、All in One SEO Packだけを有効化しても現象は同じでした。
    ちなみに、アップグレード前のバージョン3.0.3ではエラーもなくプラグインは正常に動いていました。
    このエラーを解消するための方法はないでしょうか?

    よろしくお願いします。

2件の返信を表示中 - 1 - 2件目 (全2件中)
  • モデレーター jim912

    (@jim912)

    ys8さん、こんにちは。

    エラーメッセージで、

    n /var/www/vhosts/ドメイン名/httpdocs/wp-content/plugins/_all-in-one-seo-pack/all_in_one_seo_pack.php on line 488

    と、プラグインのディレクトリ名が、_all-in-one-seo-packのようにアンダースコア付きになっています。
    require_onceで呼び出すファイルが、all-in-one-seo-packと決めうちになっているため、ファイルが無いとエラーになっていると思われます。

    All in One SEO Packのディレクトリ名を再確認してみてください。

    スレッド開始 ys8

    (@ys8)

    jim912さん こんにちは。回答ありがとうございます!
    エラーが出て画面が真っ白になってしまったので
    一旦アンダースコアをつけたことをすっかり忘れていました。
    …こんなウッカリミスだったとは。以後気をつけて見るようにしてみます。

    (_を付ける前の最初のエラーは何だったのかわかりませんでしたが…)
    無事解決しました!ありがとうございました!

2件の返信を表示中 - 1 - 2件目 (全2件中)
  • トピック「WordPress3.1にアップグレード後、All in One SEO Packにエラーが出る」には新たに返信することはできません。