サポート » インストール » WordPress4.7にアップグレードの不具合が又生じました

  • 解決済 kooen

    (@kooen)


    kooenです。
    WordPressを4.61から4.7にアップグレードした時の不具合です。
    以下トラブってますご指導方よろしくお願いします。

    ※投稿画面でパソコンファイルから表示される画像を投稿してもブログに反映されない
       
    ※編集投稿画面で 下書き保存、更新、公開、プレビュ-ボタンをクリックすると下記のエラーメッセージが表示される。
    Warning: Cannot modify header information – headers already sent by (output started at /home/kooen/www/ooyodo/wp-config.php:1) in /home/kooen/www/ooyodo/wp-admin/post.php on line 197

    Warning: Cannot modify header information – headers already sent by (output started at /home/kooen/www/ooyodo/wp-config.php:1) in /home/kooen/www/ooyodo/wp-includes/pluggable.php on line 1179

5件の返信を表示中 - 1 - 5件目 (全5件中)
  • モデレーター mypacecreator

    (@mypacecreator)

    いったんすべてのプラグインを停止してみてください。
    それでも同様のメッセージが表示されるでしょうか?

    こちらに記載の内容を参考に、問題の切り分けを行ってみてください。
    特にこのケースはテーマ・プラグインの情報が重要だと思います。
    https://ja.wordpress.org/support/topic/%e5%95%8f%e9%a1%8c%e8%a7%a3%e6%b1%ba%e3%81%ae%e3%81%9f%e3%82%81%e3%81%ae%e3%83%81%e3%82%a7%e3%83%83%e3%82%af%e3%83%aa%e3%82%b9%e3%83%88-%e3%83%89%e3%83%a9%e3%83%95%e3%83%88%e7%89%88/

    さっそくの返答ありがとうございます。
    全プラグインを停止しても同じメッセージが表示されます。
    このメッセージの意味が不明なので
    解ると、また解決糸口が見つかるかもしれませんが・・・

    ご紹介のサイトもさらに詳細に勉強してみます。
     

    wp-config.phpの頭に空行やBOMがある可能性がありますね。

    wp-config.phpをWindowsのメモ帳等で編集しませんしたか?

    「wp-config.php bom」辺りでググってみてください。

    そうするとアップデート関係なさそう…………

    • この返信は11 ヶ月、 4 週間前に  Hinaloe さんが編集しました。

    >wp-config.phpをWindowsのメモ帳等で編集しませんしたか?
     おっしゃる通りメモ帳で編集し上書きしました(WordPressのデバックモ-ドを解除の為)
     それ以降おかしくなった様な?感じもします。
    TeraPadで「wp-config.php bom」を再度編集 上書きしてみます。
     

    Hinaioeさん皆さん解決しました~。
     ありがとうございました。
    TeraPadで「wp-config.php」を再度
    文字コ-ドを「UTF-8N」BOMなし
     改行コ-ドを「LF」に指定 して保存上書き転送したらOKでした。
    大変勉強になりましたWordPressメモ帳での編集は絶対ダメですね。

5件の返信を表示中 - 1 - 5件目 (全5件中)
  • トピック「WordPress4.7にアップグレードの不具合が又生じました」には新たに返信することはできません。