サポート » 使い方全般 » WPのメジャーバージョンの自動更新

  • 先日、quick-adsense-reloadedの更新が原因で、
    WPサイトがエラーになり、止まってしまいました。
    https://ja.wordpress.org/support/topic/%e3%80%90%e8%87%b3%e6%80%a5%e3%80%91wp%e3%82%b5%e3%82%a4%e3%83%88%e3%81%ae%e3%82%a8%e3%83%a9%e3%83%bc/

    原因は、WPが5.0.0以上でなくて、quick-adsense-reloadedが更新されたからだったのですが、
    私はいくつかWPサイトを持っているので、そこまでバージョンを確認したりできないです。

    今回は、偶然にサイト確認をしたため、早くエラーを見つけられましたが、
    またエラーがあったら、サイトが止まったまま気づかないと思います。

    Advanced Automatic Updatesというプラグインを入れいるのですが、
    メジャーバージョンの自動更新は推奨されていないようです。

    ですが、メジャーバージョンの自動更新をして、
    今回のようなエラーでサイトが止まることを避けたいです。

    このプラグインでの『メジャーバージョンの自動更新』というのは、危険なのでしょうか?
    今回のエラーを避けるような方法は、どんなものがあるでしょうか?

2件の返信を表示中 - 1 - 2件目 (全2件中)
  • 私はいくつかWPサイトを持っているので、そこまでバージョンを確認したりできないです。

    まず、↑の現状の管理体制を改善してみてはいかがでしょうか。管理しきれないのであれば、

    ■ WPではなくて静的なHTMLのサイトにする
    ■ WPの管理を任せるスタッフを雇用する
    ■ ウェブ制作会社に保守を委託する

    など

    まず管理体制を整えてから、個別のプラグインについて考えたほうが良いのでは、と思います。

    • この返信は2年、 2ヶ月前に水野史土が編集しました。

    こんにちは

    個人的なメモですが、WordPress5.2で、Fatal Error Recovery Modeという機能が追加されています。

    https://tenman.info/labo/snip/archives/10547

    この記事を書いた当時、一通りエラーを発生させて、うまく動作しているようでした。

    サイトヘルス などでググると関連した記事がみつかるかも、、、

2件の返信を表示中 - 1 - 2件目 (全2件中)
  • トピック「WPのメジャーバージョンの自動更新」には新たに返信することはできません。