サポート » 使い方全般 » wp-emoji-release.min.jsによるhttpsエラー

  • 常時SSL化したページなのですが、トップページ以外はエラーが出てしまいます。
    F12で見てみると、wp-emoji-release.min.jsが原因でmixed contentとなっています。
    wp-emoji-release.min.jsだけが、http://となっており、ブロックされています。
    修正法を教えてください。
    よろしくお願いします。

    ヘルプの必要なページ: [リンクを見るにはログイン]

4件の返信を表示中 - 1 - 4件目 (全4件中)
  • プラグインを利用してwp-emoji-release.min.jsを無効化しましたが、トップページ以外は変わりません。

    こんにちは

    どのような手順でSSL化されたのでしょうか?
    データベースにあるサイトのURLを全てHTTPSに書き換えていますか?

    それから、該当のjsを無効にするのに、何というプラグインを使いましたか?
    私はDisable Emojisを使ってみましたが、どのページでもwp-emoji-release.min.jsは読み込まれなくなりました。

    ありがとうございます。

    >どのような手順でSSL化されたのでしょうか?
    さくらの証明書を購入して、SAKURA RS WP SSLというプラグインを使ってSSL化しました。

    >データベースにあるサイトのURLを全てHTTPSに書き換えていますか?
    書き換えてあります。

    >該当のjsを無効にするのに、何というプラグインを使いましたか?
    Disable Emojisです。

    トップページは鍵マークがつきますが、その他は、!マークがついています。
    F12で見ると「wp-emoji-release.min.js によって危害を受けています」と表示されています。

    トップページでは絵文字が無効になっているのではなく、トップページではwp-emoji-release.min.jsがhttpsで読み込まれていますね。

    ページによってwp-emoji-release.min.jsのURLが変わるというのは、どこかでscript_loader_srcフィルターフックが使われていると思うので、プラグインを一つづつ無効にするなどして原因を調査してみてください。

    また、トップページ以外のページでは、
    http://alcot-sekkotsuin.com/wp-content/themes/luxech/images/favicon.ico
    http://alcot-sekkotsuin.com/wp-content/themes/luxech/images/apple-touch-icon-precomposed.png
    もhttpで読み込もうとしていて、これらはhttpsにリダイレクトされて問題なく読み込まれている様子ですが・・・
    wp-emoji-release.min.jsがhttpsにリダイレクトしない理由はよく分かりません。
    リダイレクトはSAKURA RS WP SSLがhtaccessを書き換えて行っていると思いますので、さくらに聞いてみたらいいかもしれません。

    また、私はSAKURA RS WP SSLプラグインを使ったことは無いのですが、データベースを書き換えたならこのプラグインはいらないんじゃないかと思うんですが・・・ちがうのかな?

4件の返信を表示中 - 1 - 4件目 (全4件中)
  • トピック「wp-emoji-release.min.jsによるhttpsエラー」には新たに返信することはできません。