サポート » プラグイン » WP-PageNaviをアップデートしたらHPが表示されなくなりました!

  • つたない知識で「TwentyEleven1.3」をカスタマイズして使用しています。
    WordPressのバージョンはよくわかりませんが「更新」のページでは「WordPress 5.2.4 は PHP 5.6.20 以降を必要とするため、更新を実行できません。現在稼働しているバージョンは 5.2.17 です。」と表示されます。
    なんとか解決したく、質問させていただきます。
    トピックタイトルの通り「WP-PageNavi」を「バージョン 2.93.1」にアップデートしたらHPのトップ画面が表示されなくなりました。
    「WP-PageNavi」自体の有効化もできず、有効化しようとすると「重大なエラーを引き起こしたため、プラグインを有効化できませんでした。」となります。
    その下には「Warning: require_once(__DIR__/scb/load.php) [function.require-once]: failed to open stream: No such file or directory in /home/users/0/lolipop.jp-4714f6ba86823599/web/wp-content/plugins/wp-pagenavi/wp-pagenavi.php on line 12
    Fatal error: require_once() [function.require]: Failed opening required ‘__DIR__/scb/load.php’ (include_path=’.:/usr/local/php/5.2/lib/php’) in /home/users/0/lolipop.jp-4714f6ba86823599/web/wp-content/plugins/wp-pagenavi/wp-pagenavi.php on line 12」と表示されます。
    プラグインのアップグレードはこれまで何度もしてきましたが、このような事は初めてでたいへん困っております。
    アドバイスお願いいたします。

    ヘルプの必要なページ: [リンクを見るにはログイン]

14件の返信を表示中 - 1 - 14件目 (全14件中)
  • 質問した後いろいろ試してみましたが、トップページ(http://hisashige.net)のみが表示されないようです。
    上記プラグインのアップデート以外、原因として思い当たることはないのですが・・・
    なにとぞよろしくお願いいたします。

    • この返信は8ヶ月、 2週前にkntn13が編集しました。

    こんにちは

    PHP のバージョンが古い(5.2.17)ため表示されるエラーのようです。可能であれば PHP のバージョンを 5.6.20 以上にバージョンアップしてみてください。
    https://lolipop.jp/manual/user/php-setting/

    念のために作業前にバックアップを取得することをお勧めします。

    ishitaka様
    ありがとうございます!
    PHPのバージョンアップ、試してみたいのですが致命的なミスを犯しそうで思い切れません(笑)
    バックアップの取り方もいまいちわからないので・・・
    それにしてもプラグインのアップデート(しかも有効化できていない)ぐらいでトップページが表示できないようになるなんて私には理解できません。
    他の方のアドバイスも待ちつつ、明日しっかり勉強してからやってみます!

    それにしてもプラグインのアップデート(しかも有効化できていない)ぐらいでトップページが表示できないようになるなんて私には理解できません。

    WP-PageNavi のアップデートにより動作しなくなった(無効化)からではないでしょうか?
    下記のようにすると表示される(ページナビゲーションは表示されませんが)と思います。

    <?php wp_pagenavi(); ?>

    <?php if ( function_exists( 'wp_pagenavi' ) ) { wp_pagenavi(); } ?>

    ishitaka様
    ありがとうございます!
    ただ本当に知識が無く、申し訳ありません。
    教えていただいた変更箇所がどこなのかわかりません(泣)
    トップページが表示できるのならページナビゲーションぐらいは犠牲にしてもいいのでぜひご教示ください。
    またバックアップは月額払いをしてでも取っておくほうがいいのでしょうか?
    ちなみに私も「ロリポップ」を使用しています。
    よろしくお願いいたします。

    テンプレートを見てみないとわかりません。WP-PageNavi プラグインを導入したときに、テンプレート(index.php、archive.php、single.php など)に追加しませんでしたか?
    デバッグモードでエラーを確認されてはいかがでしょうか。
    http://wpdocs.osdn.jp/WordPressでのデバッグ

    ishitaka様
    ありがとうございます!
    少し勉強して対処したいと思います。
    しかしいくら考えてもなぜ「トップページのみが表示できなくなる」のか理解できません(笑)

    もしくは「WP-PageNavi」をダウングレードする方法があればいいのですが・・・

    WP-PageNavi プラグインを削除し、以前のバージョン(2.70 辺り?)の ZIP 形式のプラグインファイルを使用してアップロードインストールするといいかと思います。
    以前のバージョンの ZIP 形式のプラグインファイルは、下記ページ(ページの下部)よりダウンロードすることができます。
    https://ja.wordpress.org/plugins/wp-pagenavi/advanced/

    ありがとうございます!
    その方法を試してみたいと思います。
    とりあえず「2.80」をダウンロードしました。
    ただ「プラグインファイルを使用してのアップロードインストール」のやり方がわからないのでやり方を調べてからやってみたいと思います。
    自分の無知さが恥ずかしいです・・・

    ただ「プラグインファイルを使用してのアップロードインストール」のやり方がわからないのでやり方を調べてからやってみたいと思います。

    プラグインの新規追加ページの上部に表示されている『プラグインを使って WordPress の機能を拡張できます。WordPress プラグインディレクトリから自動インストールを行うか、.zip 形式のプラグインをこちらのページからアップロードできます。』の『こちらのページ』をクリックするとアップロードインストールすることができます。

    ishitaka様
    ありがとうございました!
    最新の「WP-PageNavi」プラグインを削除し「2.80」をあらためてアップロードインストールすると治りました!
    本来なら「PHP」のバージョンアップをすべき(WordPressも・・・)で今回の対処は本当の解決ではないのかもしれませんが、とりあえずはこのままにしておきます。
    まったく素人の私に親切にアドバイスいただき本当にありがとうございました。
    いつも気にせずしている「プラグインのアップデート」ぐらいでこのような事になるとは思ってもいませんでした。
    またお世話になることがあるかもしれません。
    その節にはよろしくお願いいいたします。

    本来なら「PHP」のバージョンアップをすべき(WordPressも・・・)で今回の対処は本当の解決ではないのかもしれませんが、とりあえずはこのままにしておきます。

    WordPress 3.3 系でしたら、最低限セキュリティーアップデートの 3.3.2 へアップデートされたほうがいいかと思います。

    WordPress 3.3.2 (そして WordPress 3.4 ベータ 3)

    ishitaka様
    ありがとうございます!
    実は恥ずかしながら、パソコン内にローカル環境がない(!)のでどうしてもバージョンアップには躊躇してしまいます。
    調べると「Local by Flywheel」という初心者にもやさしい無料ソフトがあるようなので、勉強してチャレンジしてみたいと思います!

14件の返信を表示中 - 1 - 14件目 (全14件中)
  • トピック「WP-PageNaviをアップデートしたらHPが表示されなくなりました!」には新たに返信することはできません。