サポート » プラグイン » WP Super Cache「ページがマッチしません ! タイムスタンプが違うか見つかり

  • 解決済 dswwpsh

    (@dswwpsh)


    WP Super Cacheプラグインについてご質問いたします。

    キャッシュテストで
    「ページがマッチしません ! タイムスタンプが違うか見つかりません !」
    とエラーメッセージが出て困っております。
    ネット検索でいくつかの方法を試したのですが解決できず、
    ぜひとも教えていただきたいと思いご質問させていただきました。

    WP Super Cacheのバージョンは V1.2でエラーが出る以前までは、ページマッチしていました。

    エラー直前に行った作業といえば、現在稼働中のwordPressの他に同じ階層にWordPressをもう1点インストールした事ぐらいです。
    同じ階層に
    ・WordPress(1)
    ・WordPress(2)
    があり(1)は独自ドメインが割り当てられています。
    (それぞれ別のデータベースを作成しています。)
    (1)(2)共に同じエラーでページがマッチしません。

    ●エラー解消の為行った作業は以下です。

    ・WP Super Cache 設定 >> 詳細で
    「キャッシュファイルの提供に mod_rewrite を利用する。 (推奨)」
    「キャッシュファイルの提供に PHP を利用する。」
    「レガシーなページキャッシング。」
    などの設定変更を試してみました。
    「既知のユーザー向けにはページをキャッシュしない。 (推奨)」
    の項目に問題があるというページもありましたので上記と組み合わせon/offを試してみました。

    ・Mod Rewrite ルールの更新と更新が正常に行われているか確認しました。
    (.htaccessの内容については変更を加えていません。)

    ・パーマリンク設定も変更して試してみました(現在は [投稿名] となっています)

    ・WP Super Cache以外のプラグインを全て停止し試してみました。

    ・使用しているテンプレートのfunctionを白紙にしたり
    「Twenty Eleven」「Twenty Ten」などのテンプレートで試してみました。

    ・以下のpermissionの設定を666または777等にして試してみました。
       wp-config.php
       wp-content
       cache
       wp-cache-config.php
       advanced-cache.php
       WordPressフォルダ/.htaccess

    ・cacheフォルダの中身を一端削除したり、WP Super Cacheプラグインの削除/インストールを行いました。

    上記の作業を行ったのですが、解消されず困っております。

    ●その他として
    サーバーはコアサーバーを使用しており
    PHP セーフモードがOFFにできないため
    wp-admin/.htaccessに下記を記入しています。

    <Files admin.php>
    AddHandler application/x-httpd-phpcgi .php
    </Files>
    <Files options-general.php>
    AddHandler application/x-httpd-phpcgi .php
    </Files>
    <Files async-upload.php>
    AddHandler application/x-httpd-phpcgi .php
    </Files>
    <Files plugin-install.php>
    AddHandler application/x-httpd-phpcgi .php
    </Files>
    <Files update.php>
    AddHandler application/x-httpd-phpcgi .php
    </Files>
    <Files update-core.php>
    AddHandler application/x-httpd-phpcgi .php
    </Files>

    何卒、ご助力よろしくお願いいたします。

1件の返信を表示中 - 1 - 1件目 (全1件中)
  • スレッド開始 dswwpsh

    (@dswwpsh)

    自己解決いたしました。
    どうやらサーバー(コアサーバー)の仕様が大きく影響する内容だったみたいで申し訳ないです。

    ファイル所有者の修正とパーミションの繰り返しで
    「ページがマッチしません ! タイムスタンプが違うか見つかりません !」を解消することができました。
    この方法は他ページ参照で把握していたつもりですが
    URLの階層が深くなると、cashフォルダ内もそれに伴い追加されていくことを理解していませんでした。

    今回行った作業手順は以下です。

    1)WordPress設定 >> WP Super Cache 設定 >> キャッシュテストボタンを押す

    2)wp-contents/cashの中にsupercacheというフォルダが自動生成される。
    (されない場合は、cashのパーミッションを777等にしてキャッシュテストを押す)

    3)自己生成されたことを確認する

    4)サーバーコントロールパネルより、ファイル所有者の修正を行い2〜3分待つ
    (ファイル所有者の修正のボタンを押すだけ)

    5)自動生成されたsupercacheパーミッションを777等に

    6)キャッシュテストボタンを押す

    7)wp-contents/cash/supercacheの中にドメイン名でフォルダが作成される。

    8)サーバーコントロールパネルより、ファイル所有者の修正を行い2〜3分待つ

    9)自動生成されたドメイン名フォルダのパーミッションを777等に

    10)キャッシュテストボタンを押す

    11)キャッシュを保存するフォルダが自動生成された事を確認
    ※URLディレクトリごとにフォルダが生成されるので、キャッシュを保存するフォルダが生成されるまで、7・8・9・10を繰り返す。
    (フォルダが生成されなくなるまで繰り返す。)

    12)サーバーコントロールパネルより、ファイル所有者の修正を行い2〜3分待つ

    13)キャッシュテストボタンを押す

    14)両方のページのタイムスタンプがマッチしました !と表示される

    上記の操作を
    後に設置したWordPress(2)に行うことで
    先に設置していたWordPress(1)で出ていたエラーも何もせずに解消していました。
    「ファイル所有者の修正」が影響しているのでしょうか
    理由はよくわからないのですが解決しました。
    お騒がせしました。

1件の返信を表示中 - 1 - 1件目 (全1件中)
  • トピック「WP Super Cache「ページがマッチしません ! タイムスタンプが違うか見つかり」には新たに返信することはできません。