サポート » インストール » WP5.2.1への更新でPHPバージョンチェック不具合

  • 解決済 masaki_k

    (@masaki_k)


    こんばんわ。
    ワードプレス5.1.1から5.2.1へ更新しようとしているのですが、

    「WordPress 5.2.1 は PHP バージョン5.6.20以上が必要なため、更新できません。現在の PHP バージョンは5.3.29です。」
    と表示されて更新できません。

    Coreserverを利用していて、サーバー側ではPHP7.3に変更してあり、phpinfo()等でもversion7.3.2となるのですが、
    Query Monitorで確認すると、更新ページ(update-core.php)ではPHP5.3.29と判定されていました。

    テーマはオリジナルを使用していますが、Twenty Twelveに変更しても同様で、そこからプラグインを全て無効にしても更新はできませんでした。

    どの様に対処すべきか教えていただければ幸いです。

1件の返信を表示中 - 1 - 1件目 (全1件中)
  • 自己解決しました。

    wp-admin/.htaccess において

    <files update-core.php>
    AddHandler application/x-httpd-phpcgi .php
    </files>

    とcgiモードで機能するように記載されており、
    cgiモードでバージョン指定をしない場合にphp5.3.29と判定されてしまうようです。

    これを
    <files update-core.php>
    AddHandler application/x-httpd-php73cgi .php
    </files>
    として無事にアップデートできました。

    お騒がせしました。

1件の返信を表示中 - 1 - 1件目 (全1件中)
  • このトピックに返信するにはログインが必要です。