サポート » マルチサイト » Youtube埋め込みタグが消える現象

  • 解決済 kaigoouji

    (@kaigoouji)



    質問させていただきます。

    現在 4.91でマルチサイトを運営しておりますが、投稿や固定ページでYoutubeのコードを貼り付けてもどうしても削除されてしまいます。
    (ビジュアルで一旦表示されても 公開や保存をすると削除されます)

    色々なページでfunction.phpに追加 の記事で試しておりますが
    全てだめで、
    他のシングルサイトでは問題ない事なのに一つだけ考えられるのは
    マルチサイトのみのページです。

    同様なご経験者様がいらして解決方法がありましたらご教授願えれば幸いです。

    もし
    他に記載があり見落としておりましたらお詫び申し上げます。

15件の返信を表示中 - 1 - 15件目 (全27件中)
  • CG

    (@du-bist-der-lenz)

    さっそく 4.91でマルチサイトを作り。投稿や固定ページでYoutubeのURLを貼り付けて確認しました。どうしても削除されてしまう現象は再現できませんでした。「function.phpに追加」して試したものってなんですか。

    CGさん

    早速のご返事、ご確認ありがとうございます。

    function.phpに追加


    グーグル先生に
    「wp youtube タグ消えてしまう」
    で検索した 上位のページ全て 試しました。。

    テーマに問題あるかと思って変えてもみましたが。。。

    CG

    (@du-bist-der-lenz)

    マルチサイトは久しぶりだったので、手間取って20分程かかりましたが。当然、テーマはTwenty Seventeenでプラグインも使っていない状態ですので、 @kaigoouji とも同じ状況だと思います。
    グーグル先生とはご縁がないのでよくわかりませんが、検索エンジンは同じ情報をリストしてくれないと思いますので、はっきりしませんでした。

    CGさま

    お手間をかけさせてしまったようで恐縮至極に存じます。

    状況が狭まってきました。

    マルチサイトをインストールした管理者とした参加サイト(仮にAサイト)での投稿は問題なく表示されました。

    しかし
    マルチサイト参加サイトのページで新サイトBでの管理者での投稿がダメという事が分かりました。
    (上手く伝わりますか?)

    仰る通り Aでの投稿(youtube表示)は問題なしでした。

    以上が 現時点での状況です

    こんにちは

    どのような方法(URL(oEmbed)、embed ショートコード又は iframe)で埋め込んでいますか?

    ishitaka さま

    ありがとうございます。

    テキストから iframeで埋め込んでおります。

    また
    TinyMCE Advanced のビジュアルモードで
    挿入
    メディア
    でも 試してみました。

    普段(シングルサイト)はiframeで埋め込んでいるので。

    CG

    (@du-bist-der-lenz)

    わたしは Youtube のURLだけを投稿に入れています。ビジュアルエディタで動画を確認できますよね。

    • この返信は9 ヶ月、 1 週前に  CG さんが編集しました。理由: スクリーンショットの追加

    iframe の場合は下記ページ等が参考になると思います。
    http://gobounuki.biz/archives/3646

    CGさま

    urlだけの投稿ですか?

    申し訳御座いませんプラグインを使った投稿方法しか分かりません。

    TinyMCE Advanced 有効状態で
    ちなみに今
    挿入→メディア→YOUTUBEurL
    挿入したところ やはり消えました。

    追伸ですが
    親サイトAはiframeで問題なく投稿できてます。

    申し訳御座いませんプラグインを使った投稿方法しか分かりません。

    URL を書くだけです。URL は独立した行に先頭から記述してください。

    詳細は下記ページを参照してみてください。
    https://wpdocs.osdn.jp/oEmbed

    CG

    (@du-bist-der-lenz)

    プラグインは動画検索だけで、URLだけ、本文に書いています。

    ishitaka さま

    こちらも 上記と一緒で 参加サイトの親サイトは URLを貼るだけで表示されました。

    しかし
    子サイトBでは URLが記述され、ビジュアル化してくれません。。。

    CGさま 

    投稿の順番ちがいでしたね。

    直上と同じ内容です。

    今一度 

    >iframe の場合は下記ページ等が参考になると思います。
    >http://gobounuki.biz/archives/3646

    での 
    functions.phpを追記してみました。

    // フィルタの登録
    add_filter(‘content_save_pre’,’test_save_pre’);

    function test_save_pre($content){
    global $allowedposttags;

    // iframeとiframeで使える属性を指定する
    $allowedposttags[‘iframe’] = array(‘class’ => array () , ‘src’=>array() , ‘width’=>array(),
    ‘height’=>array() , ‘frameborder’ => array() , ‘scrolling’=>array(),’marginheight’=>array(),
    ‘marginwidth’=>array());

    return $content;
    }

    ————————-

    やはり iframeは消えてしまいます。

    自己レスです

    只今

    親サイトAでも
    URLの貼付けした状態 で
    (ビジュアルモードではURLのみですが)

    実際投稿表示を確認すると 表示されました。

    (かなり大きいサイズなのでスマホ等には切り取られた表示です)

    サイズをリサイズ等は また改めて。になると思いますが

    取急ぎ皆様への 報告です。

    ただ
    親サイトと子サイトでは 表示が違う事がよく分かりまりました。

15件の返信を表示中 - 1 - 15件目 (全27件中)
  • トピック「Youtube埋め込みタグが消える現象」には新たに返信することはできません。