フォーラムへの返信

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • トピック投稿者 dreative

    (@dreative)

    経過の報告です。

    WordPress.orgの方で、
    チケットを作成して検証してもらいました。
    Bug when inserting images with TinyMCE for latest Chrome

    Google翻訳による拙い文章でしたが、コア開発者の方には伝わったようで、
    Chromeのバグなんじゃないの?みたいなニュアンスでしたが、
    一応パッチを当てて対応していただけるようです。

    本事象に検証にご協力いただいた方々
    ご協力ありがとうございました。

    本トピックはクローズします。

    トピック投稿者 dreative

    (@dreative)

    Fumito MIZUNO様

    返信ありがとうございます。
    なるほどバグトラッキングシステムなのですね。

    チケット作成はできそうですが、説明は英文でしないといけないんですよね。
    英文は苦手でして。。
    javascriptはブラウザ依存言語で敬遠していたのでほとんどわかりません。。

    バグの報告だけのチケット発行でも問題ないのでしょうか。
    バグ報告のチケット発行ならGoogle翻訳を使ってなんとか
    英文で報告できそうなのですが、それで問題ないでしょうか。

    トピック投稿者 dreative

    (@dreative)

    Fumito MIZUNO様

    返信ありがとうございます。
    今回の事象に関してWordPressコア開発陣に
    不具合報告することはできるのでしょうか?
    英語のサイトのWordPress.orgを見ても
    日本語サイトの同じようなフォーラムがあるだけで
    WordPressコア開発陣に不具合報告する手段がわかりませんでした。

    とりあえずこのトピックはクローズします。

    トピック投稿者 dreative

    (@dreative)

    Colorful-life様
    npssl様

    検証していただきましてありがとうございます。
    私と同様の現象が発生したこと承知しました。

    さて、私はWEBシステムの開発の現場から離れて久しいのですが、
    現在のWEBシステムの開発の現場では、今回のような問題が発生した場合はブラウザ側の問題にして終わりにしてしまうのでしょうか。
    私の頃はWEBシステムは MAC/Windows Chrome IE FireFox 等主要なブラウザで動作確認して
    その内一つでも意図しない動作が発生する場合は、WEBシステム側の問題であるとしてWEBシステムの改良を行っていました。

    今回は、WindowsでChromeの最新バージョンで特殊な操作をすることで不具合が発生する
    ということですが、これは正式にWordPress4.7.4の不具合として問題ないでしょうか。
    私としてはWindows版のChromeの使用シェアから考えて相当数の人がChromeブラウザを使用しているわけなので、これをChromeブラウザが最新版にアップデートしたからWordPressが正常に動作しないのは、Chromeブラウザが悪いで片付けるのはWEBシステム開発をしてきた人間としては納得できない部分があります。

    皆さんのご意見はどうでしょうか?
    皆さんのご意見を聞いてからこのトピックはクローズさせていただくことにします。

    よろしくお願いいたします。

    トピック投稿者 dreative

    (@dreative)

    返信ありがとうございます。
    dreativeです。

    テーマを別のものに変更して試してみましたが
    同様の現象が発生しました。

    現象が発生するポイントは

    test.jpg
    これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。
    これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。

    という文章を投稿画面にペーストしたとして
    test.jpgという文字列をマウスで選択して切り取った時状態で、
    メディアを追加でimgタグを挿入すると後ろの文章の一部が欠落します。

    test.jpgをバックスペース等で一文字づつ削除していってから
    メディアを追加でimgタグを挿入すると後ろに続く文章の欠落は発生しませんでした。

    追記
    上記のテスト文章を投稿画面にペーストして
    test.jpgをマウスで選択するとtest.jpgの後ろに半角スペースがあります。
    これを選択範囲に入れるか入れないかで
    文章の欠落の発生と未発生がおきます。

    —————————————————
    問題箇所わかりました。
    問題はブラウザのようです。
    問題が起きるのはChromeの最新バージョンで発生するようです。
    IE11で現象が発生するか試したところ現象は発生しませんでした。
    Chromeのみtest.jpgの文字列の後ろに半角スペースが発生します。

    使用環境
    Windows 8.1 64bit
    ブラウザ Chrome バージョン 58.0.3029.81【最新版】

    Chrome最新バージョンで検証していただますでしょうか。
    同様の方法で文章の欠落が発生しないかどうか検証していただけないでしょうか。
    それで現象が発生しないようでしたら問題を取り下げることにします。
    よろしくお願いいたします。

    • この返信は5年、 2ヶ月前にdreativeが編集しました。
    • この返信は5年、 2ヶ月前にdreativeが編集しました。
    • この返信は5年、 2ヶ月前にdreativeが編集しました。
    トピック投稿者 dreative

    (@dreative)

    CG様

    検証いただきまして、ありがとうございます。
    私のような現象の再現はありませんでしたか。
    本日も1記事投稿したのですが、
    画像タグもそうですが、amazonJSによる商品リンクタグも
    本文の一部に重なって文章が欠落事象が起きてしまいます。

    後考えられるのはテーマでしょうか。
    テーマはTCDのテーマを使用していて、テキストモードの時に
    テーマ独自のタグを挿入するボタンが増えているので、
    WordPress本体の投稿画面とテーマの相性が合っていない可能性があるのかもしれません。

    一度テーマを作成している会社の方へ問い合わせしてみます。
    検証いただきましてありがとうございました。

    このトピックは解決済みでは無く一度保留にしておきます。
    よろしくお願いいたします。

    トピック投稿者 dreative

    (@dreative)

    Fumito MIZUNO様

    返信ありがとうございます。
    Dreativeです。

    ・TinyMCE Advanced
    ・AddQuicktag
    ・AmazonJS

    上記プラグインを停止して
    3000字以上の長文になる過去の記事を新規作成で
    試しにコピーアンドペーストで、新規投稿画面にペースト後、
    挿入予定の画像を挿入したところ

    やはり文章の一部がimgタグに上書きされる状態で
    本文の一部が欠落してしまいます。
    テストに使用した記事本文の文字数は約5000字です。

    おそらく文字数が多い時、のjavascript関連の処理に問題があるように思います。
    画像挿入には「メディアを追加」ボタンでimgタグを挿入しております。

    テストの際には3000字以上の長文による文字数でテスト・検証していただけますでしょうか。
    よろしくお願いいたします。

    —————————————–
    問題の再現手順

    test.jpg
    これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。
    これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。
    これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。
    これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。
    これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。

    これは現象が発生した、記事の本文です。
    予め別テキストファイルに下書きしておいて新規投稿画面にペーストします。
    test.jpgは画像を挿入するためのファイル名でこれを切り取って「メディアを追加」から該当する画像をアップロードまたは選択してimgタグを挿入すると

    <img src=”test.jpg” />スト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。
    これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。
    これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。
    これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。
    これはテスト文章です。これはテスト文章です。これはテスト文章です。これはテスト文章です。

    というようにimgタグが本文に重なるように挿入されてしまいます。
    このくらいの文章量でも再現しましたのでご連絡させていただきました。

    引き続き現象の検証をしていただけますと幸いです。
    よろしくお願いいたします。

    • この返信は5年、 2ヶ月前にdreativeが編集しました。
    トピック投稿者 dreative

    (@dreative)

    返信ありがとうございます。

    当方でもテストで数行の文字数で画像を挿入した場合は、前述したような文章の欠落は発生しませんでした。
    当方のサイトは最低でも3000字程度は書いていて

    下書きで別のテキストに記事を書いておいてコピーアンドペーストで投稿画面にペーストしてから、記事を校正して投稿しています。

    その時例えば

    sounyuusuruimg.jpg
    その後文章がつづきます。
    これはテストです。

    <img src=”sounyuusuruimg.jpg”>文章がつづきます。
    これはテストです。

    というような感じで一部imgタグが、文章のいち部分に重なるようにimgタグが挿入されてしまいます。

    ちょっと文章では伝わりにくいかもしれませんが、上記のような現象が記事を投稿する際に毎回発生するという状況です。

    投稿画面に関係する使用しているプラグインは
    ・TinyMCE Advanced
    ・AddQuicktag
    ・AmazonJS
    です。ver 4.7.3までは上記のような現象は発生していませんでした。
    WordPress側の投稿画面で何か改良した時の不具合であると思うのですが。。

    現状ver4.7.4から4.7.5にverUPする時に改善されるのを期待するしかないのでしょうか?
    当方では欠落した部分を再度コピペしなおすことで対処療法していきます。

8件の返信を表示中 - 1 - 8件目 (全8件中)