フォーラムへの返信

15件の返信を表示中 - 1 - 15件目 (全15件中)
  • フォーラム: その他
    返信が含まれるトピック: Local by Flywheelの環境を実存サイトにコピー出来ない

    @ishitaka
    お返事ありがとうございました。
    連休をはさんだので、対応が遅くなりました、大変申し訳ございません。
    Edgeではキャッシュを、ChromeではCookieとかキャッシュとかをクリアしたら、リダイレクトされず、きちんと表示されました。
    (Chromeでは結構時間がかかりましたが…)
    本当にありがとうございました。

    話は変わりまして…
    また、引き続き、Search-Replace-DBでInternal Server Error 500となる原因と対処法をご存じの方いらっしゃいましたら、お手数ですがご教授頂ければ幸いです。
    (Windows上のLocal by FlywheelにインストールされているWordPressのサイトには、元から「.htaccess」ファイルが存在しません)

    以上宜しくお願い致します。

    フォーラム: その他
    返信が含まれるトピック: Local by Flywheelの環境を実存サイトにコピー出来ない

    すみません、追記です。
    https://wp-topics.com/base/141/
    を見て、一応.htaccessの内容を確認しています。

    フォーラム: その他
    返信が含まれるトピック: local by flywheelにサイトの環境をコピー出来ない
    gaugauking

    (@gaugauking)

    お世話になります。

    https://interconnectit.com/products/search-and-replace-for-wordpress-databases/
    に、何が悪いのか、エラーメッセージとともに問い合わせました。
    そしたら
    「もうすぐv4.0が出るよ。ちょっと貴方も試してみて」
    と、ベータ版と思われるもののダウンロードサイトを教えてもらいました。
    (ベータ版と思われるので、ダウンロードサイトのURLの提示は差し控えます、すみません)

    v4.0(多分ベータ版)をダウンロードしてインストールしました。
    v4.0(多分ベータ版)は3か所ほどプログラムの書き換えが必要でしたが、書き換えて実行したら、無事に本番サイトをLocal by Flywheelにコピー出来ました。
    (有効化していたからかは分かりませんが、BackWPupプラグインはコピーされませんでした)
    管理画面もサイト画面もAdminerもきちんと表示されました。

    色々ありがとうございました。
    また色々お騒がせしましたが、取り合えず解決しましたので、報告します。

    お礼とお詫びまで。

    フォーラム: その他
    返信が含まれるトピック: local by flywheelにサイトの環境をコピー出来ない

    WordPressの勉強をするため、
    https://www.star.ne.jp/free/(以下スターサーバ)に無料でドメインを作って、そこで色々やっていました。

    また、お返事頂いた皆さんの意見を実際に実行したり、他にも独自で調べたことを色々やっていたため、返事が遅れました、申し訳ございません。

    @munyagu
    ご意見ありがとうございます。
    All-in-One WP Migrationだとディスクスペースが無いとなってエクスポート(ダウンロード)が出来ません。
    多分スターサーバのサーバでなにがしかの制限がかかっているのだと思います。
    (先の投稿で書こうとして書き忘れていました、すみません)

    @npssl
    ご意見ありがとうございます。
    スペースの入らないところにインストールしようとしたらエラーになりました。
    C:\Users\<ユーザ>\Local Sites
    じゃないと駄目みたいです。
    (多分、Localを、全員が使えるようにではなく、今使ってるユーザのみ使用でインストールしたからではないかと思っています)

    @oisit
    ご意見ありがとうございます。
    サーバの環境は私が構築したものではなく、スターサーバが予め用意しているものを使うようになっているので、あまりサーバの設定をいじれないのです、すみません。

    @oisit
    ご意見ありがとうございます。
    移行作業自体は一つ前のLocalのバージョンからしていました。
    3.3.0をインストールしてみます、ありがとうございます。

    ちょっと色々整理が出来なくなってきたので、もう一度自分で整理してみます、すみません。

    フォーラム: 使い方全般
    返信が含まれるトピック: the_author_posts_link()

    ご返信ありがとうございます。
    おっしゃる通り、Yoast SEOの設定を変更したら、無事投稿者アーカイブが表示されました。
    ありがとうございました、深く感謝いたします。
    あちらでは大変失礼いたしました。
    お礼とお詫びまで。

    フォーラム: バグ報告と提案
    返信が含まれるトピック: バグ?(Yoast SEOとthe_author_posts_link())

    大変申し訳ございません。
    あちらに書き込んでからすぐにこちらにも書き込んだので、見てませんでした。
    お騒がせして大変申し訳ございませんでした、以後留意します。
    お詫びまで。

    フォーラム: 使い方全般
    返信が含まれるトピック: the_author_posts_link()

    お世話になります。
    テーマはTwenty Nineteenのまま、プラグインを一つ一つ停止して動作を確認しましたが、
    Yoast SEO
    というプラグインを停止したら、投稿者アーカイブが表示されるようになりました。
    (デフォルトじゃないテーマを一つ変えて試してみましたが、うまくいきました)
    本にはこのプラグインをインストールして有効化した方がよいと書かれていましたが、まさか誤動作?を起こすとは…。
    お騒がせしました、すみませんでした、ありがとうございました。

    フォーラム: 使い方全般
    返信が含まれるトピック: the_author_posts_link()

    ご返信ありがとうございます。

    おっしゃる通り、全てのプラグインを停止し、テーマ:Twenty Nineteen で、
    https://<ドメイン>/author/<投稿者名>/
    https://<ドメイン>/?author=1
    を両方とも試してみました。
    「投稿者アーカイブ:
    <投稿者名>」
    となり投稿が表示されたので、多分うまくいったと思います。

    ということは、テーマに問題があるのでしょうか、それともプラグインが何か関係しているのでしょうか。
    (プラグインなら、一つ一つ停止して確認しないとダメでしょうけど…)

    フォーラム: 使い方全般
    返信が含まれるトピック: the_author_posts_link()

    ご返信ありがとうございます。
    URLを多く書いたからなのか、承認待ちになっているので、再度投稿します、ご容赦ください。

    HTMLタグを書くと解釈されてしまうみたいですね、大変申し訳ございません。
    先の「the_author_posts_link() で出力された HTML」は、
    <a title=”<投稿者名> の投稿” href=”https://<ドメイン>/author/<投稿者名>/” rel=”author”><投稿者名></a>
    と、ブラウザの開発ツールでは表示されます。

    https://<ドメイン>/author/<投稿者名>/

    https://<ドメイン>/?author=1
    も(実際のIDも1でした)、両方ともfront-page.phpに飛んで
    https://<ドメイン>/
    が表示されてしまいます。

    (これでうまくいくかな?)

    フォーラム: 使い方全般
    返信が含まれるトピック: the_author_posts_link()

    すみません、「先の「the_author_posts_link() で出力された HTML」」は

    <a title=”<投稿者名> の投稿” href=”https://<ドメイン>/author/<投稿者名>/” rel=”author”><投稿者名></a>

    と、ブラウザの開発ツールでは表示されます。

    フォーラム: 使い方全般
    返信が含まれるトピック: the_author_posts_link()

    お世話になります。
    ご返信ありがとうございます。

    「the_author_posts_link() で出力された HTML」は、
    <投稿者名>
    となります。
    (ブラウザの開発ツールでは上記のように表示されています)

    get_author_posts_url()でURLを表示させてみても、
    https://<ドメイン>/author/<投稿者名>/
    となります。

    「表示されたページの URL」は、投稿者のリンクをクリックすると、front-page.phpに飛ぶので、サイトのトップの
    https://<ドメイン>/
    が表示されます。

    現在WordPressの独学中で、投稿者は管理者でもある私しかいないので、管理者だとトップに飛んでしまうのでしょうか。

    フォーラム: プラグイン
    返信が含まれるトピック: 「Jetpackを設定」から先に進まない
    gaugauking

    (@gaugauking)

    ishitaka様 ご返信ありがとうございます。
    設定をすれば一部機能を利用出来るんですね、また一つ勉強になりました、ありがとうございました。

    フォーラム: プラグイン
    返信が含まれるトピック: 「Jetpackを設定」から先に進まない
    gaugauking

    (@gaugauking)

    npssl様 ご回答頂きありがとうございます。
    そうですか、ローカル環境では使えないのですか…。
    また一つ勉強になりました、ありがとうございました。

    フォーラム: プラグイン
    返信が含まれるトピック: 「Jetpackを設定」から先に進まない
    gaugauking

    (@gaugauking)

    すみません、もしかしてローカル環境だからこうなってしまうのでしょうか。
    無料レンタルサーバと同じ環境をローカルに構築しようとしていたのですが…。

    フォーラム: 使い方全般
    返信が含まれるトピック: タグが追加出来ません

    ishitaka様、ありがとうございます。
    本の画像に追加ボタンが写っていたので、てっきり追加ボタンがあるものと思っていました。
    失礼致しました。
    エンターキーを押したら追加出来ました。
    お詫びとお礼まで。

15件の返信を表示中 - 1 - 15件目 (全15件中)