フォーラムへの返信

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • スレッド開始 icetan

    (@icetan)

    根本解決にはいたりませんでしたが対処いたしましたので手順を記します。

    ・一度アップした全メディアを削除
    ・「メディア設定」で月別にフォルダに保存を選択
    ・「メディアの追加」から画像追加
    ・投稿に挿入、その際必ずアイキャッチ画像を設定

    同名ファイルを何度もアップするとアップ時にエラーも出るし、アイキャッチ画像も設定できない感じでした。そのため一度全画像を削除し、月別に区分けることにしました。
    プラグイン問題ではなさそうです。失礼いたしました。

    スレッド開始 icetan

    (@icetan)

    最後もう一度トライしたらできました!!!!
    もう途中ゴチャゴチャで分けわからなくなってましたが、こんな感じになりました。

    <div class="navigation">
    <div class="nav-previous"><?php previous_post_link_plus(array('order_by' => 'menu_order', 'in_same_tax' => 'true', 'format' => '<span class="meta-nav">%link</span>',  'in_same_tax' => true, 'link' => '%title' )); ?></div>
    <div class="nav-next"><?php next_post_link_plus(array('order_by' => 'menu_order', 'in_same_tax' => 'true', 'format' => '<span class="meta-nav">%link</span>',  'in_same_tax' => true, 'link' => '%title' )); ?></div>
    </div>

    やっぱりポイントは’menu_order’の部分でした。見よう見まねで何とかかんとか;;
    Fatal errorに関しては恐らく一旦プラグインを削除していたのを気づかず作業していたのではないかと・・・他のシンタックスエラーは途中出まくりでした。大変失礼いたしました。
    pluto1234様、ご教示ありがとうございました!

    スレッド開始 icetan

    (@icetan)

    色々弄ってたらエラーは出なくなったのですが思うようになりません。
    時間がないので今回は別の方法を取ることにしました。ありがとうございました。

    スレッド開始 icetan

    (@icetan)

    早速のお返事ありがとうございます。
    ps_auto_sitemap.phpの方は、ご指摘を参考にし、

    ORDER BYposts.post_date DESC”;
    の部分を
    ORDER BY posts.menu_order ASC”;

    としたことで解決いたしました!ありがとうございます!
    ナビゲーションの部分ですが、

    <?php next_post_link_plus( array( 'in_same_tax' => true) ); ?>

    としたり色々ですが、いずれもナビゲーション箇所に

    Fatal error: Call to undefined function next_post_link_plus() in /〇〇/wordpress-3.5-ja-jetpack-undernavicontrol/wp-content/themes/〇〇/loop-single.php on line 〇〇

    が表示されるという現象です。

    スレッド開始 icetan

    (@icetan)

    pluto1234様 ありがとうございます。
    早速Ambrosite Next/Previous Post Link Plusをインストール有効化いたしました。
    その後色々調べてナビゲーションコード部分を変更いたしましたが、エラーが出てしまいます。
    具体的に下記どの部分をどのように変更すればよいかご教示いただくことは可能でしょうか。

    <div class="navigation">
    <div class="nav-previous"><?php next_post_link( '%link', '%title <span class="meta-nav">' . _x( '',  'Next post link' ) . '</span>', TRUE, '' ); ?></div>
    <div class="nav-next"><?php previous_post_link( '%link', '<span class="meta-nav">' . _x( '', 'Previous post link' ) . '</span> %title', TRUE, '' ); ?></div>
    </div>

    ただ、PS Auto Sitemapも同様なので、function.phoで変えられる方法があればありがたいのですが・・・

    スレッド開始 icetan

    (@icetan)

    感激のあまり忘れました(笑)
    本当にありがとうございました。

    スレッド開始 icetan

    (@icetan)

    teckingさん

    すすすすみません!
    おっしゃるとおりにもう一度最後に記述したらバッチリでした!
    きっと先程は記述ミスがあったのだと思われます。

    本当にありがとうございます&申し訳ありませんでした。
    感謝感謝です。

    スレッド開始 icetan

    (@icetan)

    teckingさん

    お返事遅くなり申し訳ありません。
    本当にありがとうございます。

    ご指示のいただいたようにfunctions.phpに挿入してみましたがエラーが出てページが表示されなくなってしまいました。
    挿入箇所はいろいろ試してみましたが同様でした。
    使っているテーマはTwenty_Tenをカスタマイズしたもので、WPバージョンは3.5になります。

    大変恐縮ですが引き続きアドバイスいただければ幸いです。

8件の返信を表示中 - 1 - 8件目 (全8件中)