フォーラムへの返信

15件の返信を表示中 - 1 - 15件目 (全34件中)
  • 回答ありがとうございます。
    ダブルクオートのままでバックスラッシュを2つ、あるいはシングルクオートに書き直すことで、‘test est_enqueue_scripts’になっていた現象は解決しました。
    しかし、依然としてエラーメッセージが出たままです。

    問題の根本的解決とはならないのですが、名前空間ではなく、アクションフックで行うことは無名関数に書くことにしました。
    関数名を考える手間もなく、なおかつ何度も実行する関数ではないので、無名関数にした方が作業が早いと思い、しばらくはこちらで運用しようと思います。

    
    add_action("wp_enqueue_scripts", function() {
    	wp_enqueue_style("normalize", "https://cdnjs.cloudflare.com/ajax/libs/normalize/7.0.0/normalize.css");
    	wp_enqueue_style("style", get_template_directory_uri() . "/assets/style.css");
    	wp_enqueue_script("script", get_template_directory_uri() . "/assets/script.js");
    });
    

    回答ありがとうございます。
    ハイフンとアンダーバーを間違えるという、初歩的なミスに気づかず、すみません…。
    修正して、バージョンアップしました。

    また、readmeのプラグイン名から翻訳を削除しました。

    glotpressで翻訳の承認権限をもらったあと、実際に翻訳を行いました。
    すると、プラグインのダウンロードや、管理画面の左メニューなどでは、glotpressから読み込まれた翻訳に基いて日本語で表示されるようになりました。
    しかし、プラグインを操作するページを開いてみると、「Text Domain: external-image-replace」も「load_plugin_textdomain(“external-image-replace”)」も設定しているにも関わらず、ページ内の文章がすべて英語で表示されてしまいました。
    何か記述が足りないのでしょうか?

    load_plugin_textdomainを書き換えて、languagesディレクトリも削除しました。
    しかし、glotpressからの翻訳ファイルはダウンロードされず、プラグインの画面がすべて英語になってしまいました。
    GlotPressにコミットするというのがわからなかったため、プラグインが入っているSVNリポジトリにはコミットしてみましたが、変化はありません。
    なお、バージョンは1.0.2のまま変更せず、最終更新日も1.0.2にしたときから変化しませんでした。

    https://translate.wordpress.org/projects/wp-plugins/external-image-replace/dev/ja/default

    また、glotpressのサイトを開いて、当プラグインのページを開いてみると、すでに翻訳が入力されていました。
    各ワードがcurrentという緑色の状態でしたが、これは未承認なのでしょうか?
    Approveを実行してみましたが、「You are not allowed to do that!」とエラーが出て、承認できませんでした。

    https://owncloud.wiredpunch.com/index.php/s/ne9RCRH1GJHtWbs

    英語版のwordslackに承認を申請してみました。

    • この返信は1 年、 3 ヶ月前に muro さんが編集しました。

    すみません、自己解決しました。
    サイトネットワーク側ですべてのプラグインを有効化していましたが、それをいったん止めることで、カテゴリとタグが表示されるようになりました。
    また、マルチサイト側からプラグインを有効化した場合は、問題ありませんでした。

    本体やプラグインを更新できないだけでなく、パーマリンクの設定更新も反映されず、htaccessを追加しろと言われて追加しても何の効果もないなど、yumによるwordpressインストールはおかしいところだけになったので、結局いつものインストールに戻すことにしました。
    お手数をおかけしました。

    フォーラム: 使い方全般
    返信が含まれるトピック: 新規投稿画面がおかしくなって投稿できない。

    まず、ルート直下にwordpressというフォルダを作り、その中に本体をまるごとコピーしました。
    そのあと、phpmysqlからSQLをエクスポートして、URLを書き換えてからインポートしました。

    ところが、過去のSQLをバックアップしていたので、それをインポートしてみたところ、新規投稿画面の異常はなくなりました。
    どうやら最新のDBに何らかの異常が起こってたとかんがえられるのですが、その原因は結局わからずです。
    よって、復帰時点から現在までの記事を、もう手動で投稿画面から書き込んでいくことにします。
    お手数をおかけしました。

    フォーラム: 使い方全般
    返信が含まれるトピック: 新規投稿画面がおかしくなって投稿できない。

    参考サイトのコードからifを外すことで、タイトルと本文入力欄は表示されるようになりました。
    しかし、パーマリンクが「?preview=true」のまま変更できず、クリックすると同じ編集画面がまた開きます。
    さらに、投稿すると権限がないと言われるのは変わらないままです。

    フォーラム: 使い方全般
    返信が含まれるトピック: 新規投稿画面がおかしくなって投稿できない。

    phpmyadminから全テーブルのチェックをかけても特に異常なし。
    wordpressをいったん1つ前にダウングレードしても直らず、そこからまたアップデートしても直らずでした。
    ただ、アップデートの最中、いくつかのファイルが更新できずエラーとなることがありました。
    ftpからファイルを確認すると、所有者がなぜかrootになっていたので、それをkusanagiに変えてからアップデートすることで、アップデートは完了しました。

    回答ありがとうございます。「JP Markdown」というプラグインが原因でした。
    強調表示ではなくMarkdownを使えるようにするだけのプラグインのはずなのですが、有効の状態で記事を保存すると今回の件が発生してしまいました。停止させてから記事を保存し直すと、ちゃんとインデントがタブで表示されるようになりました。
    まさかこのプラグインにこんな余計な機能があるとは思いもしませんでした。新しいプラグインを探し直さなければいけません。

    フォーラム: 使い方全般
    返信が含まれるトピック: 記事内の画像は外部リンクにした方がいい?

    回答ありがとうございます。
    特別な事情がないかぎり、いつもどおりメディアライブラリから画像を使った方がよさそうですね。

    回答ありがとうございます。
    ここでコードタグが効くことをすっかり忘れていました。

    問題の件ですがもう、画像に関してはプラグインを自作、それ以外は手作業で直そうと思います。

    また、外部画像の置き換えに関しては、images_importer_from_urlというプラグインが便利そうだったのですが、有効時にエラーとなって使えませんでした。

    • この返信は2 年、 5 ヶ月前に muro さんが編集しました。

    <!–more–>であるべきところも、インポートしてきた記事では<!– more –>というようにスペースが入っており、「続きを読む」が表示されていませんでしたが、これに関しては「Search Regex」を使うことで解決しました。(本来はハイフン2つですが、フォーラム上ではなぜか入力しても1つになってしまう。)

    • この返信は2 年、 5 ヶ月前に muro さんが編集しました。
    • この返信は2 年、 5 ヶ月前に muro さんが編集しました。

    すみません、返信が遅くなってしまいました。
    更新時のメッセージも変更できました。ありがとうございます。

15件の返信を表示中 - 1 - 15件目 (全34件中)