けい (Kei Nomura)
フォーラムへの返信
-
フォーラム: プラグイン
返信が含まれるトピック: 管理画面の記事タイトルをSEO用のタイトルに変えたいすみません、補足ですがreturnするところ、
return esc_html( $ssp_meta_title );としておいたほうが安全です。
フォーラム: プラグイン
返信が含まれるトピック: 管理画面の記事タイトルをSEO用のタイトルに変えたいWordPressの the_title フィルターフックでできそうな気がします。
/**
* 管理画面のみ、投稿タイトルの出力を変更
*
* @param string $title
* @param int $post_id
* @return string
*/
function custom_admin_title( $title, $post_id ) {
if ( ! is_admin() ) {
// 管理画面以外では何もしない
return $title;
}
$ssp_meta_title = get_post_meta( $post_id, 'ssp_meta_title', true );
if ( $ssp_meta_title ) {
return $ssp_meta_title;
}
return $title;
}
add_filter( 'the_title', 'custom_admin_title', 10, 2 );ポイントとしては冒頭のif条件で、「管理画面のみ」この処理が適用されるようにしている点です。
※実運用では、条件を! is_admin() || wp_doing_ajax()としたほうがよりよいかもしれませんが、いずれにせよ @sui248 さんがやりたいことは実現できると思います。フォーラム: テーマ
返信が含まれるトピック: editor-style.cssをフロントにも適用させたい。@muromuro さん、こんにちは。
add_editor_style で読み込むエディターのHTML構造はフロントとは異なるので、たしかにCSSの中身をそのまま使うのは難しいですね。
私の場合の対応例ですが、Sass(.scss)を使って、editor.scss / style.scss に、フロントとエディターの両方に適用されてほしいコンポーネント等を読み込む記述を入れています。
それで、1箇所書き換えればフロント用のCSSとエディター用のCSSの両方のファイルに変更が反映されるようにしています。あとは、たとえば
.editor-styles-wrapper,
.c-postContent /* フロント側の親要素名 */ {
h2 {
/* ここに適用したいスタイル */みたいな感じにするなどで対応しています。
なお、 サポートサイトの下記ページにこのような説明があります。
たとえばエディタースタイル内の
テーマサポート – Japanese Team – WordPress.org 日本語body { ... }は.editor-styles-wrapper { ... }に書き換えられます。ちなみにこのことはエディターのクラス名を直接 指定すべきでない ことも意味しています。ですので、同じファイルをそのまま直接両方で読み込むのはちょっと扱いが難しいのかなという印象です。
※このあたりのベストプラクティスは確立されていないような気がするので(私が知らないだけかもしれませんが)、他にも私はこうしてます、というような情報あれば歓迎します!
フォーラム: プラグイン
返信が含まれるトピック: Yoast SEOのsitemap_index.xmlが404で表示されないこんにちは。
ヘルプの必要なページに書いていただいたsitemap_index.xmlに直接アクセスしてみたところ、私の環境では問題なく表示できていました。
こちらのサイトのようなツールでチェックしてみましたが、とくにエラーなしの結果でした。
https://www.websiteplanet.com/ja/webtools/sitemap-validator/書いていただいている情報だけだと状況がわかりませんが、少し時間をあけてお試しいただき、まだどうだったかお知らせいただけると幸いです。
フォーラム: インストール
返信が含まれるトピック: バージョンアップとプラグインインストール解決したようで良かったです!
最新版は6.8らしいのですが、複数のサイトで「不具合があったときにバージョンダウンをするとパスワードが云々」といったことをおっしゃっていたので
これについてはおそらくこの件だと思います。
注意が必要なのは、bcrypt で再ハッシュされた後で WordPress 6.7.2などにダウングレードした場合です。パスワードを正しく入力してもログインできなくなってしまいます。ログイン時に入力したパスワードのハッシュ値(MD5で生成)とデータベースに保存してあるハッシュ値(bcryptで生成)が一致しないためです。
「WordPress 6.8にアップデートしたらプラグインが動作しなくなった😱一旦6.7.2に戻そう」というケースでログインできなくなったときは、慌てず「パスワードをお忘れですか ?」のリンクからパスワードをリセットしましょう。
WordPress 6.8で気になる新機能・ブロックエディター周りのアレコレ | 株式会社ベクトルダウングレード後ログインできないときは、上記に記載のようにパスワードリセットをすれば解決するので、ひと通りの対応が終わりましたら、改めて最新版のWordPressへのアップデートをおすすめいたします。
フォーラム: プラグイン
返信が含まれるトピック: jetpack が原因でログインできないこんにちは。推測ではありますが、メールがスパム誤判定でブロックされているということはないでしょうか?
お使いのメールサーバーの設定や、独自ドメインの場合はドメインレコードの設定を確認してみて、問題がないかどうかチェックされてみてはいかがでしょうか。(メール不着問題への対応は昨今、かなり難しくなっているのが正直なところですが、、、)フォーラム: 使い方全般
返信が含まれるトピック: 「超入門」のp53、ヘッダー画像がわかりませんこんにちは。
大変申し訳無いのですが、本フォーラムでは特定の書籍のサポートはできません。
本件については、出版元の技術評論社様の専用窓口(おそらく書籍のどこかに記載があると思います)へのお問い合わせをお願いいたします。※なお、ダウンロードデータ自体に不備がある場合は出版社様の方でご対応いただけると思いますが、そうではない場合(suenaga12さんの固有の環境が要因の場合)にサポートいただけるかどうかは出版社様のサポートポリシーによって異なりますので、あらかじめご了承ください。
こんにちは。情報が少ないので現時点ではっきりした原因は分からないのですが、以前に遭遇したり、人づてに聞いたりした同様のケースについて3点記載します。
@ryoto1425 さんの状況と同じかは不明ですが、確認する価値はあると思いますので、お試しください。- PHPバージョンの変更が影響していたケース
自分で変えたorサーバー会社の事情でPHPのバージョンが変更されたときに、同様の「パスワードリセット用リンクが無効のようです」が発生→もとに戻したら治ったというケースを聞いたことがあります - データベースの容量が超過していたケース
リビジョンデータが大量にあったりとか、記事数が膨大だったりとかで、利用しているレンタルサーバーで定められている容量をオーバーしていた (そういう情報を掲載していたブログをたしか以前読んだことがあるのですが、残念ながらそのブログは終了していましたのでうろ覚えの記憶です)→この場合はphpMyAdminなど、サーバー側で用意されているデータベース編集ツールなどを使ってデータを消したりする必要があるかもしれません - 原因不明ながら、phpMyAdminなどからパスワードの強制リセットをしたら治ったという話もあります(上級者向け)
何かのヒントになれば幸いです。
こんにちは。本フォーラムでは(おそらくセキュリティ上の理由だと思うのですが)、画像ブロックはファイルそのものではなく、URLを指定した埋め込みしかできません。
みなさん、自分のサーバーに画像をアップしたり、外部の画像共有サービスなどを利用して、質問や回答に活用されています。例えばこんな感じで画像の閲覧URLを貼るなどです
https://www.dropbox.com/scl/fi/wpurt919vj6pqhtub5jw2/2025-04-16-16.00.50.png?rlkey=he1w1uotwlqm97xoejwzceycw&dl=0
セキュリティや公序良俗上の問題がなければ何を使っていただいても大丈夫です。フォーラムガイドラインに記載の「外部リソースにリンクする場合に注意すべきこと」の内容に準じてください。
https://ja.wordpress.org/support/article/guidelines/(※特定のサービスを薦める意図はありませんが、参考までに、よく使われるサービス例として、Dropbox, Gyazoなどはよく見ます)
フォーラム: プラグイン
返信が含まれるトピック: BackWPupのジョブの画面にエラーが出る。こんにちは。まずはサーバーのPHPバージョンを確認してみてください。おそらくPHP8.xではないでしょうか?
一般的にこの”Warning: Undefined array key~~”のエラーはPHPを8に上げたときに発生するケースが多いです。ざっと確認したところ、このWarningが出る根本の原因はプラグイン側にあるように思われます。ただ当方でもBackWPup5.1.1の環境がありますが、デバッグモードをONにしてもこのエラーが再現しません。
おそらくなんですが、ある特定の条件下でだけ出るエラーだと思います。
エラーの内容的には、「$job配列の中にtypeキーが存在しない」ということなので、バックアップジョブを新規で作成したときに、どこかの欄が空欄だったり、データが欠けているときに出るのではないかと推測されますいちど、新規で新しいジョブを登録し、同じようなエラーが出るか試してみてください。
(いま登録してあるものとは保存先など条件を変えたりしてみて確認するのも有益だと思います)フォーラム: 使い方全般
返信が含まれるトピック: 固定ページの更新ができないこんにちは。状況を拝読しました。かなり詳細に情報を書いていただいておりますが、なかなか決めてになるような情報がなく、難しい問題ですね。。。
気になったのは以下の内容です。
一部の固定ページを更新する際、「固定ページを更新しました」という表示が出てくるにもかかわらず、編集した内容が反映されない(エラー等は表示されていない)。
一文ずつ小分けに更新すると、反映できる場合がある。
元のページから大幅に内容を削ると更新できるようになる。エラーが出ないというのが謎ですね。一度、ブラウザの開発者ウインドウのコンソールの方でエラーが出ていないか見ていただくとなにか見つかるかもしれません。
Chromeの場合は、 表示>開発/管理>JavaScriptコンソール です。
ここを開いたまま投稿をお試しいただき、赤色の項目が出たらそれを共有いただくとヒントになるかもしれません。(スマイルサーバーにWAFのon/off等の機能はないとのこと)
ご質問内容を読んで、真っ先に疑ったのが、WAFによるブロックでした。
スマイルサーバーの使用経験がないのでわからないのですが、別のサーバーで以前、普通の英文の中の”or”と “and”がSQLインジェクションと認識されて投稿できないことがありました。おいおいそれはないだろという気がしましたが、投稿できたときとできないときで、含まれる文章に傾向がないのか見ていただくのもよさそうです。(on/offできないが、裏側ではWAFが動いているかもしれないので、サーバー会社に聞いてみるものひとつです。教えてくれないかもしれませんが…)一文ずつ小分けに更新すると、反映できる場合がある。
元のページから大幅に内容を削ると更新できるようになる。これも気になるところです。もしかしたらサーバーのスペックが貧弱で処理しきれていない、という可能性もあるかもしれません。
以上可能性としてありそうなものを挙げてみました。そのものズバリと言う回答ができず申し訳ありません。何か参考になれば幸いです。
フォーラム: インストール
返信が含まれるトピック: バージョンアップとプラグインインストールこんにちは。
先日本フォーラムに投稿がありました、こちらの件と近いような気がします。ワードプレス6.7.2への更新ができない | WordPress.org 日本語
https://ja.wordpress.org/support/topic/%E3%83%AF%E3%83%BC%E3%83%89%E3%83%97%E3%83%AC%E3%82%B96-7-2%E3%81%B8%E3%81%AE%E6%9B%B4%E6%96%B0%E3%81%8C%E3%81%A7%E3%81%8D%E3%81%AA%E3%81%84/一度上記ページの内容をお読みいただき、ご自身の状況にあてはまるか確認いただけますでしょうか。
解決しない場合は
- お使いのサーバーの種類(利用しているサービスやプラン等)
- サーバーのPHPのバージョン
- PHPバージョンを最近自分で変えたり、レンタルサーバー側の事情で変更されたりしなかったかもあわせて確認
- お使いのテーマ・プラグインの状況
などを確認し、追記いただけると解決に近づけると思います。
フォーラム: プラグイン
返信が含まれるトピック: CPT UIで作成した特別投稿一覧を固定ページに表示させたいこんにちは。テーマがCocoonということは、エディターはクラシックエディターをお使いでしょうか?
ブロックエディターをお使いなら、PHPコードを書かなくても、固定ページの下部に任意の条件の投稿を表示させられるブロック(クエリーループブロックなど)を挿入すれば実現できると思います。
クラシックエディターだと、ショートコードで対応できるプラグインを使ってみてはいかがでしょうか。
※たとえばこういうもの
https://webantena.net/wordpress/plugin-posts-in-page/ちなみに
②https://www.sasatatsu-blog.com/web/wordpress/293/
→設定しても変化なしこの記事で紹介されているのは「指定の固定ページの下層にカスタム投稿タイプの投稿を出す」方法なので、@mugenneko さんの希望される「固定ページ下部に表示」とは異なります。
フォーラム: 使い方全般
返信が含まれるトピック: サブディレクトリのWordPressをドメイン直下で表示したい@reiko8 モデレーターです。申し訳ありませんがトピックの削除はできませんので、残ってはまずい内容は本フォーラムには書き込まないようご理解お願いいたします。
フォーラム: 使い方全般
返信が含まれるトピック: 管理ページにログイン出来なくなりましたデータベースを作り直してみる(一旦wp-config.phpを退避させてアクセスすると新規インストールからやり直せます) とは、
まったく別のデータベースで新規にインストールし直すということですか?
こちらの作業ですが、「該当のサイトで導入しているテーマ・プラグイン・投稿内容等に問題があったのか」「設置しているWordPress本体に問題があったのか」「そもそもサーバー側でWordPressが動かない何らかの問題があるのか」の切り分けが目的です。
新規でまっさらのWordPressをインストールしても問題が出るようであれば、特定のテーマ・プラグイン・投稿内容の問題ではないと判断できます。逆に、新規インストールで問題が出ないなら、該当のサイトで導入しているテーマ・プラグイン・投稿内容に絞って検証すればよいという判断ができます。新規インストールで問題ないか確認
↓
all-in-one-wp-migration のバックアップで復元してみて、問題が出るか確認という手順で、だんだんと可能性を絞っていく、ということをやっていくとよいです。
- PHPバージョンの変更が影響していたケース