フォーラムへの返信

15件の返信を表示中 - 1 - 15件目 (全16件中)
  • フォーラム: 使い方全般
    返信が含まれるトピック: メディアライブラリに画像が残らない
    スレッド開始 naginagi21

    (@naginagi21)

    皆様、ご回答いただき本当にありがとうございます。
    長らくお返事ができず申し訳ありませんでした。
    ちょっと私生活が多忙となってしまいいろいろと試すことができなくなってしまったため、
    一旦ここでこのトピックは終わらせていただきます。
    中途半端となってしまい申し訳ありません。
    ワードプレスの状態は今も変わらないため、
    皆様からいただいたコメントを参考に解決できたらと思います。

    助けていただいた皆様へ心からお礼申し上げます。

    フォーラム: 使い方全般
    返信が含まれるトピック: メディアライブラリに画像が残らない
    スレッド開始 naginagi21

    (@naginagi21)

    >Katsushi Kawamori さん

    「STAR Server Free スターサーバーフリー」のFTPアカウント設定からimgフォルダに飛び、
    そこから画像をアップロード
    検索&登録の画面にいって検索してみましたが画像は何も表示されませんでした。
    検索対象のフォルダ?には複数候補が出ましたが全てありませんでした。

    wp-content/uploads/2019/07▼ 検索 全てのタイプ全ての拡張子▼ 検索 絞り込み検索
    wp-content/uploads/2019/05
    wp-content/uploads/2019
    wp-content/uploads/

    インストールしたwordpressは一度削除して、
    「STAR Server Free スターサーバーフリー」の簡単インストールを利用して↑と
    同じことをしましたがだめでした。

    フォーラム: 使い方全般
    返信が含まれるトピック: メディアライブラリに画像が残らない
    スレッド開始 naginagi21

    (@naginagi21)

    >Katsushi Kawamoriさん

    教えていただいたwp-config.php の編集なのですが、
    サイトの以下の箇所で合っていますか・・・?

    >アップロードディレクトリの移動
    UPLOADS フォルダーを media に設定します。
    define( ‘UPLOADS’, ‘wp-content/media’ );

    上記の記述をrequire_once(ABSPATH . ‘wp-settings.php’);の前に加えて
    「Media from FTP」でインポートしようとしたところ警告が出ました。
    現在こちらの警告原因を探し中です・・・。

    Warning: simplexml_load_string(): Entity: line 1: parser error : Start tag expected, ‘<‘ not found in /home/●●(サイト名)/●●(サイト名).starfree.jp/public_html/wp-content/plugins/media-from-ftp/inc/class-mediafromftp.php on line 1466

    フォーラム: 使い方全般
    返信が含まれるトピック: メディアライブラリに画像が残らない
    スレッド開始 naginagi21

    (@naginagi21)

    >CGさん

    「STAR Server Free スターサーバーフリー」のプランのお話ですよね?
    フリーWPプランではなく、「フリー PHP+MySQL」プランです。
    すみません書き方が悪かったようで誤解させてしまいました・・・。

    フォーラム: 使い方全般
    返信が含まれるトピック: メディアライブラリに画像が残らない
    スレッド開始 naginagi21

    (@naginagi21)

    >npsslさん

    フリー PHP+MySQLプランなのでアクセスできました。
    FTPを全く利用していなかったので知らなかったのですが、
    簡単インストールでwordpressをインストールしたら自動的にwordpressのファイルがアップされるようです!
    まだ根本の問題の解決はしてませんが、
    これが分かっただけでも解決のヒントになりそうです。ありがとうございました!

    フォーラム: 使い方全般
    返信が含まれるトピック: メディアライブラリに画像が残らない
    スレッド開始 naginagi21

    (@naginagi21)

    >Katsushi Kawamoriさん

    ご回答を見落としてしまってお返事ができていませんでした。申し訳ありません。

    いろいろ知識不足で教えていただいたwp-config.php のどこを編集すればいいのかが分かりませんでした。
    本当に申し訳ありません。

    ただ、本来wordpressはwordpressの公式サイトからインストールをして、
    FTPソフトなどを使用してファイルをアップしてサイト運営に入ると思います。
    ですが私はその手順を踏まず、
    以下のサイトを参考にしてtarServer Freeにある簡単インストールをしたためそもそも
    wordpressのファイルがありません。

    ですので、もしかした教えていただいた方法が私の場合試せないのかもしれません。

    https://metablo-g.com/starseverfree-wp-install/

    フォーラム: 使い方全般
    返信が含まれるトピック: メディアライブラリに画像が残らない
    スレッド開始 naginagi21

    (@naginagi21)

    RICKさん

    初めまして。ご回答ありがとうございます!
    コードなどはいじってないので壊してしまったというのに思い当たるものがないですが、一から始めるというのはありですね。

    スキルと呼べるものがないくらいの初心者なのでデータベースの削除は避けますが、いろいろ試してみてだめだったらドメインの取得から始めてみたいと思います。

    フォーラム: 使い方全般
    返信が含まれるトピック: メディアライブラリに画像が残らない
    スレッド開始 naginagi21

    (@naginagi21)

    Toshiyuki Hondaさん

    使い方は調べればいいということを失念していました。
    すみませんでした。
    ご丁寧に教えていただいてありがとうございます!
    一度試してみてまたご報告しますね。

    フォーラム: 使い方全般
    返信が含まれるトピック: メディアライブラリに画像が残らない
    スレッド開始 naginagi21

    (@naginagi21)

    Toshiyuki Hondaさん
    CGさん

    お返事が遅れてすみません。
    「Media from FTP」をおすすめしてくださってありがとうございます!
    早速ファイルの保存場所を書記に戻して導入してみましたが、だめでした。。。
    何か操作があるのでしょうか?もしあれば教えていただきたいです!
    どうぞよろしくお願いいたします。

    フォーラム: 使い方全般
    返信が含まれるトピック: メディアライブラリに画像が残らない
    スレッド開始 naginagi21

    (@naginagi21)

    >ishitaka さん

    教えていただいた対策法をひとつずつ試してみました。残念ながら変化なしでした。
    ここまでくるといよいよ手詰まりですね・・・。

    ・PHP のバージョンが合っていない。可能ならば、最新の 7 系にします。
    ×

    ・PHP のメモリ不足。memory_limit を例えば 256M 以上にします。
    ×

    ・使用しているテーマが干渉している。テーマを変えたり再インストールしたりすると解消することがあります。

    ×

    ・JavaScriptを連結する機能と、使用しているブラウザと相性が合わない
    ちょっと手こずっていてこれは挑戦できないかもしれません・・・

    ・使用しているプラグインが干渉している

    現在有効なプラグインをひとつずつ無効、すべて無効で試してみましたがだめでした。

    ・AddToAny Share Buttons (シェアボタン)

    ・Akismet Anti-Spam (アンチスパム)

    ・Classic Editor

    ・Table of Contents Plus

    ・WP-Yomigana

    フォーラム: 使い方全般
    返信が含まれるトピック: メディアライブラリに画像が残らない
    スレッド開始 naginagi21

    (@naginagi21)

    >Toshiyuki Hondaさん

    初めまして。ご回答ありがとうございます。
    返信が遅くなってしまい申し訳ありません。

    以下の設定で合っていますか?

    アップロードするファイルの保存場所(upload_path) = img
    ファイルへの完全な URL パス = /img

    残念ながら変化なしでした・・・。

    ・メディア>メディアのアップロード>画像をドラッグアンドドロップ>編
     /img/2019/06/●●(画像名).png
     →URLに変化はあったが、メディアライブラリには変化なし

    ・投稿>記事の編集>アイキャッチ画像の設定>ファイルのアップロード
     /img/2019/06/●●(画像名).png
     →URLに変化はあったが、メディアライブラリには変化なし

    フォーラム: 使い方全般
    返信が含まれるトピック: メディアライブラリに画像が残らない
    スレッド開始 naginagi21

    (@naginagi21)

    >CGさん

    返信が遅くなってしまい申し訳ありません。
    初期設定に戻してみました。

    設定>ファイルアップロード

    アップロードするファイルの保存場所:空欄
    ファイルへの完全な URL パス:空欄

    結果は、このようになりました。残念ながら初期設定では変化はありませんでした。

    ・メディア>メディアのアップロード>画像をドラッグアンドドロップ>編
     http://●●(URL名).jp/wp-content/uploads/2019/06/●●(画像名).png
     →URLに変化はあったが、メディアライブラリには変化なし

    ・投稿>記事の編集>アイキャッチ画像の設定>ファイルのアップロード
     http://●●(URL名).jp/wp-content/uploads/2019/06/●●(画像名).png
     →URLに変化はあったが、メディアライブラリには変化なし

    フォーラム: 使い方全般
    返信が含まれるトピック: メディアライブラリに画像が残らない
    スレッド開始 naginagi21

    (@naginagi21)

    >ishitaka さん

    初めまして。ご回答ありがとうございます。
    同じ現象の方がいらっしゃって少し安心しました。

    ・PHP のバージョンが合っていない

    ・テーマを変えてみる

    はやってみましたが変化なしでした。
    ちょっと今日はここまでしかできないので、また改めてご報告します!

    フォーラム: 使い方全般
    返信が含まれるトピック: メディアライブラリに画像が残らない
    スレッド開始 naginagi21

    (@naginagi21)

    >CGさん

    既にアップロード済の画像
    http://●●(URL名).jp/img/2019/06/●●(画像名).png

    新たにアップロードした画像(画像名のみ同じ)
    http://●●(URL名).jp/img/2019/06/●●(画像名)-1.png

    新たにアップしたほうは画像名の後ろに「-1」がつきました。

    >投稿とメディアが紐付いていないから、メディアライブラリに認識されていないだけではないでしょうか。
    記事にアイキャッチ画像を設定して非公開で投稿をしてみましたが、メディアライブラリには何も表示されませんでした・・・。記事からのメディア追加でアップした画像は見れますがなんか嫌ですね・・・。

    フォーラム: 使い方全般
    返信が含まれるトピック: メディアライブラリに画像が残らない
    スレッド開始 naginagi21

    (@naginagi21)

    現在の設定

    設定>メディア>ファイルアップロード
    アップロードするファイルの保存場所:img
    ァイルへの完全な URL パス:http://●●(URL名).jp/img

    ——————————————————————–

    ・メディア>メディアのアップロード>画像をドラッグアンドドロップ>編集
     http://●●(URL名).jp/img/2019/06/●●(画像名).png

    ・投稿>記事の編集>アイキャッチ画像の設定>ファイルのアップロード
     http://●●(URL名).jp/img/2019/06/●●(画像名).png

    どちらもURLは変わりませんでした。

15件の返信を表示中 - 1 - 15件目 (全16件中)