フォーラムへの返信

15件の返信を表示中 - 1 - 15件目 (全103件中)
  • ~~~ヾ(^∇^)おはよー♪ございます!
    誠にありがとうございます!
    二通りの出力方法ともに、タグリンクが取得できました。
    同じような関数でも、改良というか拡張性を考えて作っているのですね。流石はWP。

    この仕組みがよく解るように、intval($tag->term_id) で記述しておくことにしました。これでスッキリしました。

    まことにありがとうございました!

    本件は、
    echo get_bloginfo('url') . '/' . 'faq-tags/' . $tag->slug;
    とつなげて出力することで、とりあえず進めることにします。
    関数があるのかもしれませんが、今のところ見つけ出せていません。

    すみません、手違いで、投稿がだぶってしまいました。

    ankokkkさん、お蔭で、私も長年放っておいた不具合が解決しました。
    ありがとうございました。

    ankokkkさん、貴重なスレッドを作成していただいたので、私も長年の不具合を解決することが出来ました。ありがとうございました。

    フォーラムのお蔭で解決しました。
    2年間放っておいたのですが、
    http://ja.forums.wordpress.org/topic/6408?replies=7

    に記載されていたとおり、固定ページでもタグを利用するためのコード、

    function add_page_to_tag_archive( $obj ) {
    if ( is_tag() ) {
    $obj->query_vars['post_type'] = array( 'post', 'page' );
    }
    }
    add_action( 'pre_get_posts', 'add_page_to_tag_archive' );

    を、

    function add_page_to_tag_archive( $obj ) {
    global $wp_the_query;
    if( $wp_the_query === $obj && $obj->is_tag() ) {
    $obj->query_vars['post_type'] = array( 'post', 'page' );
    }
    }
    add_action( 'pre_get_posts', 'add_page_to_tag_archive' );

    に置き換えることにより、長年放っておいた不具合がなくなりました。
    これで、タグアーカイブに更なる工夫を加えてみようというモチベーション
    も出てきたので、とても有難かったです。

    フォーラム: 使い方全般
    返信が含まれるトピック: 外国語サイトを作る方法について

    早速のレスをありがとうございました。

    ご教示頂いたurlから、
    http://wpdocs.sourceforge.jp/Installing_WordPress_in_Your_Language
    を見て、ここに記載のある「手動による言語ファイルの設定」が解り易いので、
    これで進めてみることにします。(先ずはサーバ屋さんに申し込まなくては。。)

    できたら報告させていただきます。

    ありがとうございました。

    ご教示ありがとうございました。そして、マナーができていなかったこと、今後気を付けます。

    さっそくテキストウィジェット適用しました。また、本文に直接ショートコード記入も適用できることを確認しました。また、1ページ内に複数設置する際の留意点もご指摘くださり、大変勉強になりました。

    これで可能性が大きく広がった感じです。いずれは、エンタープライズ版(pro)の使用も視野に入れ、urlの適正化や翻訳精度の向上を図りたいです。

    ありがとうございました。

    popup様、誠にありがとうございました。
    長いこと悩んでいたものが解消して、また元に戻すことができました。
    よかったぁ、です。

    gtransはウィジェットとして使うようになっていますが、適用できるウィジェットエリアは一つに限定されるようですね?ですので、サイドバーで使ってしまうと、1カラムのテンプレートでフッターにウィジェットしたい、といった場合使えなくて残念ですが、そのようなことは可能でしょうか?

    古い話で恐縮です。
    前回投稿以来、gtransプラグインも2回程upgradeしましたが、前記の課題が解決されませんでした。そこで、翻訳されたページを表示し、firebugで要素をチェックしましたところ、見た目には表示されないのですが、ソースでは、body要素の最初、つまり#wrapperの一つ前に、div.skiptranslateという要素が挿入されていました(ちなみにテーマはtwentytenベースです)。この要素には特段styleが適用されていないのですが何故か表示されません。これが表示されれば、「原文を表示」ボタンが表示されるはずなのですが、どうすれば可能なのか、アドバイスいただければ幸いです。

    div.skiptranslateの内部を以下に引用します。全て展開すると見難くなるので、ポイントとなる部分のtr要素のみを展開した形で引用しました。

    <table height="100%" cellspacing="0" cellpadding="0" border="0">
    <tbody>
    <tr id=":1.promptSection" valign="middle" style="display:none">
    <tr id=":1.progressSection" valign="middle" style="display: none;">
    <tr id=":1.finishSection" style="">
    <td>
    <td class="goog-te-banner-margin"></td>
    <td nowrap="">
    <div class="goog-te-button">
    <div style="background-image: url("http://translate.googleapis.com/translate_static/img/te_bk.gif"); background-repeat: repeat-x; background-position: 0px -39px;">
    <button id=":1.restore">原文を表示</button>
    </div>
    </div>
    </td>
    </tr>
    <tr id=":1.errorSection" valign="middle" style="display:none">
    </tbody>
    </table>

    display:noneのtr要素はともかく、そうでないtr#:1.finishSection”要素内にある「原文を表示」ボタンが表示されない理由がわかりません。

    同様な事例を解決された方がおられましたら、どうぞよろしくお願いいたします。

    フォーラム: 使い方全般
    返信が含まれるトピック: テーマ変更についておききします

    確かめていただき、誠にありがとうございます!
    これでテーマの切り替えに対するモチベーションが高まりました。
    一応テストサイトは持っているので、試行してから切り替えるつもりですが、
    本サイトをバックアップできるようにしておく必要もあるので、元に戻すこと
    ができる、という事実は大変心強いものとなります。

    本当に有難うございました!

    フォーラム: 使い方全般
    返信が含まれるトピック: テーマ変更についておききします

    情報ありがとうございます。

    そうしますと、3.3からは、「使用停止中」からウィジェットエリアにドラッグ・アンド・ドロップすればする、ということでしょうか。従来は、設定したウィジェットそのものが無くなっており、テストサイトがあったお蔭でコピペして復旧していたと思うので、確かに進化したようですね。

    TS costom widgetプラグインの設定内容(第一ウィジェットエリアのこのウィジェットはトップページだけに表示して、投稿には表示させない、といった設定)までは面倒みてもらえないですよね?

    開発動向、がんばって把握したいと思っています。

    pyonko

    (@pyonko)

    hissy様
    ありがとうございます。ウェブマスタツールを使いながら、この重要なルールに思いが至らなかったのは誠に恥ずかしいかぎりです。
    ご指摘のように、ほとんどのtitleタグの中身が長めです。検索結果に表示されるタイトルは30文字程度ですが、収まっていないものが多いです。part2,part3などを含めて30文字程度に収まる必要がありそうですね。
    まずはタイトル用のテキストを凝縮して様子を見ます。それでも変化がないyぷであれば、やはりGoogleのヘルプセンターに問い合わせしてみることにします。
    ありがとうございました。

    pyonko

    (@pyonko)

    この件については、同じ条件で同じコンテンツのテストサイトでは問題がないため、本番用サーバの設定事項などに起因するものではないかと考え、とりあえず、.htaccrssの
    Redirect permanentの設定を追加して、
    「/page/2」⇒「?paged=2」
    のようにして解決といたしました。

    pyonko

    (@pyonko)

    昨日の記載で、誤りがありました。
    手打ちで表示できたのは、
    カテゴリスラッグ/?page=2. 同/?page=3, …
    ではなく、
    カテゴリスラッグ?paged=2. 同/?paged=3, …
    でした。

    しかし、別のページに行ってから、再度
    カテゴリスラッグ/?page=2
    などとすると、not found となり、そのまま回復しません。
    文字列を「/page/2」⇒「?paged=2」に(jquery等で)変更すればいいか、
    なんて思っていたのですが、根本的に直さないとダメみたいです。
    お知恵をいただければ幸いです。

    なお、テスト環境を別に2つ持っているのですが、問題が起きるのは本番だけです。

15件の返信を表示中 - 1 - 15件目 (全103件中)