フォーラムへの返信

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • フォーラム: 使い方全般
    返信が含まれるトピック: 投稿を編集できない
    スレッド開始 riverain

    (@riverain)

    Apache 2.4.26 で ProxyFCGIBackendType Directive が追加されたのが原因でした。
    /usr/local/apache2/conf/httpd.conf に
    ProxyFCGIBackendType GENERIC を追加すると編集可能になりました。

    参考サイト
    mod_proxy_fcgi – Apache HTTP Server Version 2.4 ProxyFCGIBackendType Directive https://httpd.apache.org/docs/2.4/en/mod/mod_proxy_fcgi.html#proxyfcgibackendtype

    Topic: Invalid post type. « WordPress.org Forums https://wordpress.org/support/topic/invalid-post-type-7/

    Revisions to Wrong SCRIPT_FILENAME in Apache 2.4.26 – Stack Overflow https://stackoverflow.com/posts/44657409/revisions

    フォーラム: 使い方全般
    返信が含まれるトピック: 投稿を編集できない
    スレッド開始 riverain

    (@riverain)

    返信ありがとうございます。

    ApacheのPHP関連の設定は下記の様に設定しています。
    phpinfo()でもPHP Version 7.0.20になっているので多分大丈夫なはず。

    /usr/local/apache2/conf/httpd.conf

    LoadModule proxy_module modules/mod_proxy.so
    LoadModule proxy_fcgi_module modules/mod_proxy_fcgi.so

    #php
    <IfModule prefork.c>
    LoadModule php7_module modules/libphp7.so
    </IfModule>

    DirectoryIndex index.php index.html
    <FilesMatch \.php$>
    SetHandler “proxy:fcgi://127.0.0.1:9000”
    </FilesMatch>

    フォーラム: 使い方全般
    返信が含まれるトピック: 投稿を編集できない
    スレッド開始 riverain

    (@riverain)

    返信ありがとうございます。

    下記コマンドで正常に編集出来ていた時点までロールバックしてみたのですが、状況は変わらず「この投稿タイプの投稿を編集する権限がありません。」、「投稿が見つかりませんでした。」と表示され編集ができませんでした。これで仮に編集できるようになってもセキュリティ的に問題がありますが…。

    # yum history rollback id

    • この返信は4年、 7ヶ月前にriverainが編集しました。
3件の返信を表示中 - 1 - 3件目 (全3件中)