フォーラムへの返信

3件の返信を表示中 - 16 - 18件目 (全18件中)
  • フォーラム: 使い方全般
    返信が含まれるトピック: 画像URLの取得 wp_get_attachment_image_src
    トピック投稿者 fst usr

    (@rtrkwkm)

    >kzさま。

    たびたびありがとうございます。

    $image = wp_get_attachment_image_src($Key, ‘full’);
    echo $image[0];

    で出力されました!

    が、少し挙動がおかしい点がございまして改めてご相談させていただければ、と存じます。

    同じコードを記述しているにも関わらず前後のタグなどで(?)出力される場合と、されない場合があるのです。

    <li><a onmouseover="MM_swapImage('photo','<?php $image = wp_get_attachment_image_src($写真1, 'full'); echo $image[0]; ?>',1)" href="JavaScript:;"><img src="<?php $image = wp_get_attachment_image_src($写真1, 'full'); echo $image[0]; ?>" /></a></li>

    とした場合、aタグ内には出力されるのですがimgタグ内は出力されないのです。
    aで囲まずimg単独で置いて見ても出力されません。

    あと、現在制作中サイトでは1エントリー内に、4枚(カスタムフィールドテンプレートを用いて)画像を表示する予定です。

    よって、上記ソースの$写真1の箇所をそれぞれ設定している$Keyに変えたものを置いているのですが、$写真1(aタグ内)だけしか出力されず他は空の状態です。
    ※同じ$Keyのものを4つコピーした場合は4つ出力されます。

    解決策やそもそもの原因となり得る可能性の心当たりも見当たらないのですが、
    お心当たりございましたらご教授願えませんでしょうか。

    以上、よろしくお願いいたします。

    フォーラム: 使い方全般
    返信が含まれるトピック: 画像URLの取得 wp_get_attachment_image_src
    トピック投稿者 fst usr

    (@rtrkwkm)

    kzさま。

    たびたび
    ありがとうございます。

    $Key が画像の ID とすると

    はい、現状「写真1」としております。

    で、ご指摘いただきました通り、

    <?php $写真1 = get_post_meta($post->ID, ‘写真1’, true); echo wp_get_attachment_link(写真1); ?>

    とした所、

    <img width=”109″ height=”165″ src=”http://hogehoge.com/wp/wp-content/uploads/2010/01/image011.jpg&#8221; class=”attachment-thumbnail” alt=”” title=”image01″ />

    と出力されました。

    この

    http://hogehoge.com/wp/wp-content/uploads/2010/01/image011.jpg

    だけ出力することは可能でしょうか。

    というのも、下記のようなコード内に画像のパスだけを挿入したいと思っております。

    説明が不足しており、申し訳ありません。

    以上、よろしくお願いいたします。

    フォーラム: プラグイン
    返信が含まれるトピック: カスタムフィールドでの画像UPと操作
    トピック投稿者 fst usr

    (@rtrkwkm)

    KZさま。

    ありがとうございます。

    Custom Field GUI Utility

    も合わせて調べてみます。

3件の返信を表示中 - 16 - 18件目 (全18件中)