フォーラムへの返信

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • フォーラム: プラグイン
    返信が含まれるトピック: Flexible Upload を使用するとエラー

    こんばんは。

    途中でおかしな話題が入り、報告するか迷いましたが・・結果を報告します。

    WP2.5を新規セットアップしてプラグインなどを以前と同じ物を入れます(Wp2.5用があるならそちらを使用)
    以前まではここでWP2.2.3MEから利用していたDBを丸々Wp2.5のDBに上書きしてDBをアップデートして記事を復元していました。

    どうやらそれが問題のようでした。

    今回試したのは、WP2.5をセットアップしWp2.2.3MEのDBを引き継ぎます。
    そして、WP2.5のDBにアップデートしてその中の
     wp_comments, wp_postmeta,wp_posts, wp_terms, wp_term_relationships, wp_term_taxonomy
    のみをバックアップ。
    そして新規インストールしたWP2.5のDBに上書き。

    結果は記事は復元され、Flexible Uploadを使用しての2バイト文字を含むアップロードも成功しました。

    以上です。

    momo-i様、大変ありがとうございました。

    フォーラム: プラグイン
    返信が含まれるトピック: Flexible Upload を使用するとエラー

    おはようございます。
     急用で出かけておりました

    sssgさんの方法と同じようにDBの変換をしましたが結果は自分でUTF8にしたものと同じでした。
    ただWin環境ですので少々違う部分もありますが・・

    .
    検索していただいた、WP2.2.3ME->WP2.5への移植のサイトですが、同じようにやってみましたがやはりFlexible Uploadでのアップでエラーが発生します。。。

    どこが原因なのかさっぱりです・・

    フォーラム: プラグイン
    返信が含まれるトピック: Flexible Upload を使用するとエラー

    momo-i様ありがとうございます。

    テスト環境を構築しテストしてみました。
     Windows2000、MySQL5.1.1、PHP5.2.5、WP2.5日本語版

    インストールマニュアル通りにMySQLをセットアップし、今までのWPのデータベースをリストアして再度実験しましたが、やはりエラーが発生します。
    DB名:wordpress_utf8

    MySQLが新しくなったと言うことで、WPも試しに新規インストールしテストしてみたところ
    タイトルに2バイト文字を含めてもエラーは発生しませんでした。
    DB名:wordpress_test

    そしてその新規インストールしたWPのwp-config.phpをwordpress_testからwordpress_utf8に書き換えて使用するDBを変更しました。
     define(‘DB_NAME’, ‘wordpress_utf8’);

    新規記事の投稿内容もDBにはちゃんとUTF8で記録されていました。
    ですが、wordpress_utf8の方に切り替えるとFlexible Uploadのタイトルに2バイト文字を含めるとエラーが発生。
    有効プラグインは、WP Multibyte Patch1.0、Flexible Upload1.13、Akismet2.14

    .
    ふと思ったのですが、このwordpress_utf8 DBはWP2.2.3MEからのデータなのですがそれが問題なのでしょうか
    DBの文字コード周りはもう大丈夫だと思うのですが・・・

    フォーラム: プラグイン
    返信が含まれるトピック: Flexible Upload を使用するとエラー

    こんにちは
     momo-i様、時間を割いて下さりありがとうございます。

    .

    今朝方、DBのバックアップを取っているときに気付いたのですが、
    mysqldumpで出力されるデータはDBがUTF8なら中の文字もUTF8のはずと思い、メモ帳で開いてみたのですが、
    日本語が含まれている所は全て化けていました。

    ですので、
    mysqldumpに–default-character-set=latin1のパラメータをつけてバックアップしてみたところ、日本語部分の文字化けはなくなりました。
    あとはsqlファイルの文字コードをutf8に変換し、内部のlatin1と書かれている部分をutf8と書き換えてwordpress_utf8へリストアしました。

    最初にmomo-i様が言われたとおり、なにやらlatin1で無理矢理書き込みがされていたようです

    .
    その後、フォーラムを見まして・・・
    wp-config.phpを確認してみたところ
    define(‘DB_CHARSET’, ‘utf8’);
    は定義されていませんでした。

    ですので、
    define(‘DB_CHARSET’, ‘utf8’);
    の行を追加し再度2バイト文字のタイトルにしてアップしてみましたが、やはり同様のエラーが発生します
     今回のログです http://www.eonet.ne.jp/~reima/log2.txt

    何が問題なのでしょうか

    フォーラム: プラグイン
    返信が含まれるトピック: Flexible Upload を使用するとエラー

    momo-i様ありがとうございます。

    起動パラメータにlogを追加して2バイト文字を含めて画像をアップしてみました
    http://www.eonet.ne.jp/~reima/log.txt

    やはりmomo-i様のようなログは出力されていませんでした・・
    やはり途中で止まってしまっているようです

    お手数をお掛けしますです。

    フォーラム: プラグイン
    返信が含まれるトピック: Flexible Upload を使用するとエラー

    momo-i様ありがとうございます。

    MySQLにログインし文を打って見ました。
    結果の方は、character_set_filesystem = binary 以外は全てutf8となっておりました
    出力したログです http://www.eonet.ne.jp/~reima/sql.txt

    UTF8なようですが・・・
    Flexible Uploadからの出力がLatin1になっていると言うことでしょうか。

    フォーラム: プラグイン
    返信が含まれるトピック: Flexible Upload を使用するとエラー

    momo-i様ありがとうございます。

    Flexible Uploadを停止すると問題なくアップする事が出来ます。

    現在少し弄って判明した点が1つあります。

    画像をアップする時に半角英数でタイトルをつけてアップし
    アップ完了後のギャラリーからタイトルを指定すると日本語で保存されます。
    やはりFlexible Uploadから書き込むときに問題が起きているように思えますが・・・
    なぜこうなるのか・・

    えと、こちらの使用環境ですが、MySQL5.1.1、PHP5.2.5です。
    default-character-setはUTF8です。

    SQLのログの方ですが、長いのでWebサイトの方にアップしました。
    http://www.eonet.ne.jp/~reima/update.txt

    よろしくお願いします。

    フォーラム: プラグイン
    返信が含まれるトピック: Flexible Upload を使用するとエラー

    momo-i様ありがとうございます。

    max_execution_timeの値の変更も試してみたのですが、値を大きくすればするほどエラーが出るまでの待ち時間が長くなるだけで変化はありませんでした。

    他のプラグインの問題かと思いmomo-i様と同じように
    新規インストールで、WP2.5日本語版+MultiBytePatch1.0+Flexible Upload1.13でテストしましたが、やはりタイトルに2バイト文字があるとエラーが発生します。

    何か環境の問題なのでしょうか
    ME2.2.3を使っていたときはこんな症状はなかったのですが・・

    .
    フォーラムのご案内ありがとうございます。
    フォーラムの記事を少し覗いてみようかと思います

8件の返信を表示中 - 1 - 8件目 (全8件中)