フォーラムへの返信

4件の返信を表示中 - 1 - 4件目 (全4件中)
  • トピック投稿者 yuzamei

    (@yuzamei)

    ありがとうございます。

    ishitaka様にご提案いただいたものを含め色々試しましたところ、原因が分かり問題が解決に至りましたので報告します。

    前提、初心者なのもあり、コンサルなどのアドバイスを受けつつサイトを運営しています。

    アドバイスを受けて、サイトの高速化のために、CDN(AWS CloudFront)を設置したところ、Gutenbergの仕様によりブロックエディタが無効化されていたことがわかりました。

    https://dtbaker.net/blog/rich-textvisualwysiwyg-editor-does-not-work-in-wordpress-behind-cloudfront/

    ご回答いただいたnobita様、Hamano様、ishitaka様ありがとうございました。

    • この返信は1年、 7ヶ月前にyuzameiが編集しました。
    トピック投稿者 yuzamei

    (@yuzamei)

    お二人ともご回答ありがとうございます。
    「ビジュアルリッチエディターを使用しない」のチェックが外れた状態で、かつ、実験用にテストアカウント(投稿者)を作りました。
    https://gyazo.com/847a2541ab41976931653941a8bd53b2
    そのアカウントで新規記事を作成してみました。
    右上には歯車のマークが出ている状態で、ブロックの種類変更や追加はできないままです。
    https://gyazo.com/5ea48fce647b1f677747edc597ed76dd
    PHPのバージョンは7.4.33に戻して確認しました。
    これはワードプレスのアップロードし直しになりそうでしょうか…?
    私の調べるかぎり他に打ち手はなさそうです…。

    トピック投稿者 yuzamei

    (@yuzamei)

    追記:
    エックスサーバーを利用しているのですが、その担当者様にも問い合わせをし、アドバイスをいただいた内容について検証しました。結果、挙動に変化はありませんでした。

    (1)ブラウザキャッシュ、サーバキャッシュの停止
    (2)PHPのバージョン変更

    (2)については、元々の7.4.33から下記に変えてみましたが変化は特にありませんでした。
    PHP8.1.12
    PHP8.0.25
    PHP7.3.33
    PHP7.2.34
    PHP7.1.33
    PHP7.0.33
    PHP5.6.40

    また、ワードプレスのバージョンを5.9.5までダウングレードしてみましたが、(PHPのバージョンは7.4.33にしました。)こちらも挙動が変わりませんでした。

    現状、バージョンは下記の状態です。
    WordPress6.1.1
    PHP8.1.12

    • この返信は1年、 7ヶ月前にyuzameiが編集しました。
    トピック投稿者 yuzamei

    (@yuzamei)

    お忙しいところご返信いただきましたのに反応が遅くなり大変申し訳ございません。

    仰せの検証内容と合っていれば良いのですが、下記の通り状況を確認しました。(プラグインは全て無効にし、テーマはデフォルトの状態です。)

    ビジュアルリッチエディターを使用しない 「チェック」がないことを確認した上で
    https://gyazo.com/b0f85b3bc05de718537b0549b73ecdc9

    投稿画面に遷移したのですが3点リーダーメニューには、選択肢は表示されない状況でした。
    https://gyazo.com/485f090e28eefa2a526e859df60eec82

    他に試すべきことなどありそうでしょうか?

4件の返信を表示中 - 1 - 4件目 (全4件中)