要件

WordPress を実行するには、以下のホスティング環境を推奨します。

  • PHP バージョン 7.3 以上。
  • MySQL バージョン 5.6 以上、または MariaDB バージョン 10.1 以上。
  • HTTPS 対応

本当にこれだけです。ApacheNginx を WordPress を動かすための最も堅牢で多機能なサーバーとして推奨しますが、PHP と MySQL が動くサーバーであればどんなものでも WordPress は動きます。とはいえ、考えうるすべての環境を私たちがテストできるわけではありません。ホスティングページに記載されている各ホスティングサービスは、上記の要件を超える環境を問題なくサポートしています。

Note: If you are in a legacy environment where you only have older PHP or MySQL versions, WordPress also works with PHP 5.6.20+ and MySQL 5.0+, but these versions have reached official End Of Life and as such may expose your site to security vulnerabilities.

Ask for it

こちらがホスティングサービスに送る文例です。コピー & ペーストして使ってください。

オープンソース Web ソフトウェアの WordPress <https://wordpress.org/> を使おうと思っているのですが、このアカウントでは以下をサポートしていますか ?

  • PHP 7.3 以上
  • MySQL 5.6 以上、または MariaDB 10.0 以上
  • Nginx または mod_rewrite モジュールありの Apache
  • HTTPS 対応

ありがとうございます。

より良いセキュリティのための推奨事項

Hosting is more secure when PHP applications, like WordPress, are run using your account’s username instead of the server’s default shared username. Ask your potential host what steps they take to ensure the security of your account.