要件

WordPress を実行するには、以下のホスティング環境を推奨します。

  • PHP バージョン 7.4 以上。
  • MySQL バージョン 5.7 以上、または MariaDB バージョン 10.3 以上。
  • HTTPS 対応

本当にこれだけです。ApacheNginx を WordPress を動かすための最も堅牢で多機能なサーバーとして推奨しますが、PHP と MySQL が動くサーバーであればどんなものでも WordPress は動きます。とはいえ、考えうるすべての環境を私たちがテストできるわけではありません。ホスティングページに記載されている各ホスティングサービスは、上記の要件を超える環境を問題なくサポートしています。

PHP 拡張の推奨詳細については、ホスティングハンドブックを参照してください。

注意: 古いバージョンの PHP や MySQL しか使えない古い環境にいる場合でも、WordPress は PHP 5.6.20以上及び MySQL 5.0以上で動きます。しかしこれらの古いバージョンは既に公式でサポートが終了しており、サイトを脆弱性にさらす危険性があります

リクエストしましょう

こちらがホスティングサービスに送る文例です。コピー & ペーストして使ってください。

オープンソース Web ソフトウェアの WordPress <https://wordpress.org/> を使おうと思っているのですが、このアカウントでは以下をサポートしていますか ?

  • PHP 7.4 以上
  • MySQL 5.7 以上、または MariaDB 10.3 以上
  • Nginx または mod_rewrite モジュールありの Apache
  • HTTPS 対応

ありがとうございます。

より良いセキュリティのための推奨事項

サーバー上で WordPress のような PHP アプリを動かす場合、サーバーの共有されているデフォルトユーザーネームよりも自分のアカウントを使う方がより安全です。詳しくはお使いのホスティング会社にアカウントのセキュリティ向上のためどんな施策をしているかお尋ねください。